summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker/docker_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/docker/docker_git.bb')
-rw-r--r--recipes-containers/docker/docker_git.bb20
1 files changed, 11 insertions, 9 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 13c27313..e055a4f6 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -23,10 +23,11 @@ SRCREV_libnetwork = "4cb38c2987c236dce03c868d99b57b1e28a4b81c"
23SRCREV_cli = "0f1bb353423e45e02315e985bd9ddebe6da18457" 23SRCREV_cli = "0f1bb353423e45e02315e985bd9ddebe6da18457"
24SRC_URI = "\ 24SRC_URI = "\
25 git://github.com/moby/moby.git;nobranch=1;name=docker \ 25 git://github.com/moby/moby.git;nobranch=1;name=docker \
26 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=libnetwork \ 26 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork \
27 git://github.com/docker/cli;branch=master;name=cli;destsuffix=cli \ 27 git://github.com/docker/cli;branch=master;name=cli;destsuffix=git/cli \
28 file://docker.init \ 28 file://docker.init \
29 file://hi.Dockerfile \ 29 file://hi.Dockerfile \
30 file://0001-libnetwork-use-GO-instead-of-go.patch \
30 " 31 "
31 32
32# Apache-2.0 for docker 33# Apache-2.0 for docker
@@ -91,8 +92,8 @@ do_compile() {
91 ln -sf ../../../.. .gopath/src/"${DOCKER_PKG}" 92 ln -sf ../../../.. .gopath/src/"${DOCKER_PKG}"
92 93
93 mkdir -p .gopath/src/github.com/docker 94 mkdir -p .gopath/src/github.com/docker
94 ln -sf ${WORKDIR}/libnetwork .gopath/src/github.com/docker/libnetwork 95 ln -sf ${WORKDIR}/git/libnetwork .gopath/src/github.com/docker/libnetwork
95 ln -sf ${WORKDIR}/cli .gopath/src/github.com/docker/cli 96 ln -sf ${WORKDIR}/git/cli .gopath/src/github.com/docker/cli
96 97
97 export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" 98 export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go"
98 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go" 99 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
@@ -115,15 +116,16 @@ do_compile() {
115 # to build this: 116 # to build this:
116 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_docker}" ./hack/make.sh dynbinary 117 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_docker}" ./hack/make.sh dynbinary
117 118
118 # build the proxy
119 go build -o ${S}/src/import/docker-proxy github.com/docker/libnetwork/cmd/proxy
120
121 # build the cli 119 # build the cli
122 cd ${S}/src/import/.gopath/src/github.com/docker/cli 120 cd ${S}/src/import/.gopath/src/github.com/docker/cli
123 export CFLAGS="" 121 export CFLAGS=""
124 export LDFLAGS="" 122 export LDFLAGS=""
125 export DOCKER_VERSION=${DOCKER_VERSION} 123 export DOCKER_VERSION=${DOCKER_VERSION}
126 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_docker}" make dynbinary 124 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_docker}" make dynbinary
125
126 # build the proxy
127 cd ${S}/src/import/.gopath/src/github.com/docker/libnetwork
128 oe_runmake cross-local
127} 129}
128 130
129SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}" 131SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}"
@@ -137,9 +139,9 @@ INITSCRIPT_PARAMS_${PN} = "defaults"
137 139
138do_install() { 140do_install() {
139 mkdir -p ${D}/${bindir} 141 mkdir -p ${D}/${bindir}
140 cp ${WORKDIR}/cli/build/docker ${D}/${bindir}/docker 142 cp ${WORKDIR}/git/cli/build/docker ${D}/${bindir}/docker
141 cp ${S}/src/import/bundles/latest/dynbinary-daemon/dockerd ${D}/${bindir}/dockerd 143 cp ${S}/src/import/bundles/latest/dynbinary-daemon/dockerd ${D}/${bindir}/dockerd
142 cp ${S}/src/import/docker-proxy ${D}/${bindir}/docker-proxy 144 cp ${WORKDIR}/git/libnetwork/bin/docker-proxy* ${D}/${bindir}/docker-proxy
143 145
144 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 146 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
145 install -d ${D}${systemd_unitdir}/system 147 install -d ${D}${systemd_unitdir}/system