summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker/docker_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/docker/docker_git.bb')
-rw-r--r--recipes-containers/docker/docker_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 246fbfeb..68586c81 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -38,7 +38,6 @@ DOCKER_VERSION = "1.13.0"
38PV = "${DOCKER_VERSION}+git${SRCREV_docker}" 38PV = "${DOCKER_VERSION}+git${SRCREV_docker}"
39 39
40DEPENDS = " \ 40DEPENDS = " \
41 go-cross-${TARGET_ARCH} \
42 go-cli \ 41 go-cli \
43 go-pty \ 42 go-pty \
44 go-context \ 43 go-context \
@@ -61,7 +60,7 @@ DEPENDS = " \
61 60
62PACKAGES =+ "${PN}-contrib" 61PACKAGES =+ "${PN}-contrib"
63 62
64DEPENDS_append_class-target = "lvm2" 63DEPENDS_append_class-target = " lvm2"
65RDEPENDS_${PN} = "curl aufs-util git util-linux iptables \ 64RDEPENDS_${PN} = "curl aufs-util git util-linux iptables \
66 ${@bb.utils.contains('DISTRO_FEATURES','systemd','','cgroup-lite',d)} \ 65 ${@bb.utils.contains('DISTRO_FEATURES','systemd','','cgroup-lite',d)} \
67 " 66 "
@@ -132,6 +131,7 @@ do_compile() {
132} 131}
133 132
134inherit systemd update-rc.d 133inherit systemd update-rc.d
134inherit go
135 135
136SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}" 136SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}"
137SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('DISTRO_FEATURES','systemd','docker.service','',d)}" 137SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('DISTRO_FEATURES','systemd','docker.service','',d)}"