summaryrefslogtreecommitdiffstats
path: root/recipes-containers/criu/criu_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/criu/criu_git.bb')
-rw-r--r--recipes-containers/criu/criu_git.bb12
1 files changed, 3 insertions, 9 deletions
diff --git a/recipes-containers/criu/criu_git.bb b/recipes-containers/criu/criu_git.bb
index c4539e34..b06fa636 100644
--- a/recipes-containers/criu/criu_git.bb
+++ b/recipes-containers/criu/criu_git.bb
@@ -20,11 +20,13 @@ SRC_URI = "git://github.com/checkpoint-restore/criu.git;branch=master;protocol=h
20 file://0001-criu-Skip-documentation-install.patch \ 20 file://0001-criu-Skip-documentation-install.patch \
21 file://0002-criu-Change-libraries-install-directory.patch \ 21 file://0002-criu-Change-libraries-install-directory.patch \
22 file://0003-crit-pycriu-build-and-install-wheels.patch \ 22 file://0003-crit-pycriu-build-and-install-wheels.patch \
23 file://0004-pycriu-attr-pycriu.version.__version__.patch \
24 file://0005-pycriu-skip-dependency-check-during-build.patch \
23 " 25 "
24 26
25COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux" 27COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux"
26 28
27DEPENDS += "libnl libcap protobuf-c-native protobuf-c util-linux-native libbsd libnet" 29DEPENDS += "libnl libcap protobuf-c-native protobuf-c util-linux-native libbsd libnet python3-protobuf-native"
28RDEPENDS:${PN} = "bash cgroup-lite" 30RDEPENDS:${PN} = "bash cgroup-lite"
29 31
30S = "${WORKDIR}/git" 32S = "${WORKDIR}/git"
@@ -55,7 +57,6 @@ export HOST_SYS
55export HOSTCFLAGS = "${BUILD_CFLAGS}" 57export HOSTCFLAGS = "${BUILD_CFLAGS}"
56 58
57inherit python_setuptools_build_meta 59inherit python_setuptools_build_meta
58#inherit setuptools3
59inherit pkgconfig 60inherit pkgconfig
60 61
61B = "${S}" 62B = "${S}"
@@ -73,10 +74,6 @@ do_compile:prepend() {
73 ln -s ${PKG_CONFIG_SYSROOT_DIR}/usr/include/google/protobuf/descriptor.proto ${S}/images/google/protobuf/descriptor.proto 74 ln -s ${PKG_CONFIG_SYSROOT_DIR}/usr/include/google/protobuf/descriptor.proto ${S}/images/google/protobuf/descriptor.proto
74} 75}
75 76
76#PEP517_SOURCE_PATH ="${S}/lib"
77
78#do_compile[network] = "1"
79
80do_compile () { 77do_compile () {
81 #python_pep517_do_compile 78 #python_pep517_do_compile
82 #export PEP517_SOURCE_PATH="${S}/crit" 79 #export PEP517_SOURCE_PATH="${S}/crit"
@@ -87,12 +84,9 @@ do_compile () {
87 oe_runmake FULL_PYTHON=${PYTHON} PYTHON=nativepython3 84 oe_runmake FULL_PYTHON=${PYTHON} PYTHON=nativepython3
88} 85}
89 86
90#do_install[network] = "1"
91
92do_install () { 87do_install () {
93 export INSTALL_LIB="${libdir}/${PYTHON_DIR}/site-packages" 88 export INSTALL_LIB="${libdir}/${PYTHON_DIR}/site-packages"
94 export PEP517_WHEEL_PATH="${PEP517_WHEEL_PATH}" 89 export PEP517_WHEEL_PATH="${PEP517_WHEEL_PATH}"
95 #oe_runmake PREFIX=${exec_prefix} LIBDIR=${libdir} DESTDIR="${D}" PLUGINDIR="${localstatedir}/lib" PIP_BREAK_SYSTEM_PACKAGES=1 install
96 oe_runmake PREFIX=${exec_prefix} LIBDIR=${libdir} DESTDIR="${D}" PLUGINDIR="${localstatedir}/lib" FULL_PYTHON=${PYTHON} PYTHON=nativepython3 install 90 oe_runmake PREFIX=${exec_prefix} LIBDIR=${libdir} DESTDIR="${D}" PLUGINDIR="${localstatedir}/lib" FULL_PYTHON=${PYTHON} PYTHON=nativepython3 install
97 91
98 # python3's distutils has a feature of rewriting the interpeter on setup installed 92 # python3's distutils has a feature of rewriting the interpeter on setup installed