summaryrefslogtreecommitdiffstats
path: root/recipes-containers/containerd/files/0001-build-use-oe-provided-GO-and-flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/containerd/files/0001-build-use-oe-provided-GO-and-flags.patch')
-rw-r--r--recipes-containers/containerd/files/0001-build-use-oe-provided-GO-and-flags.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-containers/containerd/files/0001-build-use-oe-provided-GO-and-flags.patch b/recipes-containers/containerd/files/0001-build-use-oe-provided-GO-and-flags.patch
new file mode 100644
index 00000000..75a984be
--- /dev/null
+++ b/recipes-containers/containerd/files/0001-build-use-oe-provided-GO-and-flags.patch
@@ -0,0 +1,26 @@
1From e31acef290181434efaf47e70db7ad0d92dbe300 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Thu, 19 Apr 2018 17:09:51 -0400
4Subject: [PATCH] build: use oe provided GO and flags
5
6Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
7---
8 Makefile | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/src/import/Makefile b/src/import/Makefile
12index 9d8cf8a18fbc..492d033fe2a7 100644
13--- a/src/import/Makefile
14+++ b/src/import/Makefile
15@@ -134,7 +134,7 @@ bin/%: cmd/% FORCE
16
17 bin/containerd-shim: cmd/containerd-shim FORCE # set !cgo and omit pie for a static shim build: https://github.com/golang/go/issues/17789#issuecomment-258542220
18 @echo "$(WHALE) bin/containerd-shim"
19- @CGO_ENABLED=0 go build -o bin/containerd-shim ${SHIM_GO_LDFLAGS} ${GO_TAGS} ./cmd/containerd-shim
20+ @$(GO) build -o bin/containerd-shim ${SHIM_GO_LDFLAGS} $(GOBUILDFLAGS) ${GO_TAGS} ./cmd/containerd-shim
21
22 binaries: $(BINARIES) ## build binaries
23 @echo "$(WHALE) $@"
24--
252.4.0.53.g8440f74
26