summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/skopeo/files/0001-Makefile-use-pkg-config-instead-of-gpgme-config.patch35
-rw-r--r--recipes-containers/skopeo/skopeo_git.bb5
2 files changed, 2 insertions, 38 deletions
diff --git a/recipes-containers/skopeo/files/0001-Makefile-use-pkg-config-instead-of-gpgme-config.patch b/recipes-containers/skopeo/files/0001-Makefile-use-pkg-config-instead-of-gpgme-config.patch
deleted file mode 100644
index d8782966..00000000
--- a/recipes-containers/skopeo/files/0001-Makefile-use-pkg-config-instead-of-gpgme-config.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From 1dd54dce3159f52a2d33693de95d124d1acb6ba9 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Tue, 24 Aug 2021 09:25:07 -0400
4Subject: [PATCH] Makefile: use pkg-config instead of gpgme-config
5
6OE taints gpgme-config to produce the following flag when called:
7
8 --should-not-have-used-/usr/bin/gpgme-config
9
10Which breaks the build. We change to use pkg-config, and skopeo
11builds as it did before.
12
13Upstream-Status: inappropriate OE specific
14
15Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
16---
17 Makefile | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/src/import/Makefile b/src/import/Makefile
21index 5721b06d..31875d44 100644
22--- a/src/import/Makefile
23+++ b/src/import/Makefile
24@@ -8,7 +8,7 @@ export GOPROXY=https://proxy.golang.org
25 # supports only pkg-config, not general shell scripts, and gpgme does not install a pkg-config file.
26 # If gpgme is not installed or gpgme-config can’t be found for other reasons, the error is silently ignored
27 # (and the user will probably find out because the cgo compilation will fail).
28-GPGME_ENV := CGO_CFLAGS="$(shell gpgme-config --cflags 2>/dev/null)" CGO_LDFLAGS="$(shell gpgme-config --libs 2>/dev/null)"
29+GPGME_ENV := CGO_CFLAGS="$(shell pkg-config gpgme --cflags 2>/dev/null)" CGO_LDFLAGS="$(shell pkg-config gpgme --libs 2>/dev/null)"
30
31 # The following variables very roughly follow https://www.gnu.org/prep/standards/standards.html#Makefile-Conventions .
32 DESTDIR ?=
33--
342.19.1
35
diff --git a/recipes-containers/skopeo/skopeo_git.bb b/recipes-containers/skopeo/skopeo_git.bb
index 35377a8d..9d19675d 100644
--- a/recipes-containers/skopeo/skopeo_git.bb
+++ b/recipes-containers/skopeo/skopeo_git.bb
@@ -21,13 +21,12 @@ RDEPENDS:${PN} = " \
21 21
22SRC_URI = " \ 22SRC_URI = " \
23 git://github.com/containers/skopeo;branch=main;protocol=https \ 23 git://github.com/containers/skopeo;branch=main;protocol=https \
24 file://0001-Makefile-use-pkg-config-instead-of-gpgme-config.patch \
25 file://storage.conf \ 24 file://storage.conf \
26 file://registries.conf \ 25 file://registries.conf \
27" 26"
28 27
29SRCREV = "3e2defd6d37b742adde2aac6cb01f6c3c17da8e2" 28SRCREV = "b95e081162382f9a28f400bee10046ce72b957fe"
30PV = "v1.6.1+git${SRCPV}" 29PV = "v1.8.0+git${SRCPV}"
31GO_IMPORT = "import" 30GO_IMPORT = "import"
32 31
33S = "${WORKDIR}/git" 32S = "${WORKDIR}/git"