summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/docker-distribution/docker-distribution_git.bb2
-rw-r--r--recipes-containers/oci-image-tools/oci-image-tools_git.bb2
-rw-r--r--recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb2
-rw-r--r--recipes-containers/riddler/riddler_git.bb2
-rw-r--r--recipes-containers/runc/runc.inc2
-rw-r--r--recipes-networking/netns/netns_git.bb2
6 files changed, 6 insertions, 6 deletions
diff --git a/recipes-containers/docker-distribution/docker-distribution_git.bb b/recipes-containers/docker-distribution/docker-distribution_git.bb
index b8181c7a..07920b9f 100644
--- a/recipes-containers/docker-distribution/docker-distribution_git.bb
+++ b/recipes-containers/docker-distribution/docker-distribution_git.bb
@@ -23,7 +23,7 @@ EXTRA_OEMAKE="BUILDTAGS=''"
23do_compile() { 23do_compile() {
24 export GOARCH="${TARGET_GOARCH}" 24 export GOARCH="${TARGET_GOARCH}"
25 export GOPATH="${WORKDIR}/git/" 25 export GOPATH="${WORKDIR}/git/"
26 26 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"
27 # Pass the needed cflags/ldflags so that cgo 27 # Pass the needed cflags/ldflags so that cgo
28 # can find the needed headers files and libraries 28 # can find the needed headers files and libraries
29 export CGO_ENABLED="1" 29 export CGO_ENABLED="1"
diff --git a/recipes-containers/oci-image-tools/oci-image-tools_git.bb b/recipes-containers/oci-image-tools/oci-image-tools_git.bb
index 49375b7f..125362bb 100644
--- a/recipes-containers/oci-image-tools/oci-image-tools_git.bb
+++ b/recipes-containers/oci-image-tools/oci-image-tools_git.bb
@@ -27,7 +27,7 @@ EXTRA_OEMAKE="BUILDTAGS=''"
27 27
28do_compile() { 28do_compile() {
29 export GOARCH="${TARGET_GOARCH}" 29 export GOARCH="${TARGET_GOARCH}"
30 30 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"
31 # Setup vendor directory so that it can be used in GOPATH. 31 # Setup vendor directory so that it can be used in GOPATH.
32 # 32 #
33 # Go looks in a src directory under any directory in GOPATH but riddler 33 # Go looks in a src directory under any directory in GOPATH but riddler
diff --git a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
index a4c544d5..176860ec 100644
--- a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
+++ b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
@@ -15,7 +15,7 @@ inherit go
15 15
16do_compile() { 16do_compile() {
17 export GOARCH="${TARGET_GOARCH}" 17 export GOARCH="${TARGET_GOARCH}"
18 18 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"
19 export GOPATH="${S}" 19 export GOPATH="${S}"
20 20
21 # Pass the needed cflags/ldflags so that cgo 21 # Pass the needed cflags/ldflags so that cgo
diff --git a/recipes-containers/riddler/riddler_git.bb b/recipes-containers/riddler/riddler_git.bb
index a04cc3e2..51599803 100644
--- a/recipes-containers/riddler/riddler_git.bb
+++ b/recipes-containers/riddler/riddler_git.bb
@@ -18,7 +18,7 @@ EXTRA_OEMAKE="BUILDTAGS=''"
18 18
19do_compile() { 19do_compile() {
20 export GOARCH="${TARGET_GOARCH}" 20 export GOARCH="${TARGET_GOARCH}"
21 21 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"
22 # Setup vendor directory so that it can be used in GOPATH. 22 # Setup vendor directory so that it can be used in GOPATH.
23 # 23 #
24 # Go looks in a src directory under any directory in GOPATH but riddler 24 # Go looks in a src directory under any directory in GOPATH but riddler
diff --git a/recipes-containers/runc/runc.inc b/recipes-containers/runc/runc.inc
index 7626dad7..64cf3f85 100644
--- a/recipes-containers/runc/runc.inc
+++ b/recipes-containers/runc/runc.inc
@@ -23,7 +23,7 @@ inherit go-osarchmap
23 23
24do_compile() { 24do_compile() {
25 export GOARCH="${TARGET_GOARCH}" 25 export GOARCH="${TARGET_GOARCH}"
26 26 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"
27 # Set GOPATH. See 'PACKAGERS.md'. Don't rely on 27 # Set GOPATH. See 'PACKAGERS.md'. Don't rely on
28 # docker to download its dependencies but rather 28 # docker to download its dependencies but rather
29 # use dependencies packaged independently. 29 # use dependencies packaged independently.
diff --git a/recipes-networking/netns/netns_git.bb b/recipes-networking/netns/netns_git.bb
index 1efcf9a6..470dfacf 100644
--- a/recipes-networking/netns/netns_git.bb
+++ b/recipes-networking/netns/netns_git.bb
@@ -14,7 +14,7 @@ inherit go
14 14
15do_compile() { 15do_compile() {
16 export GOARCH="${TARGET_GOARCH}" 16 export GOARCH="${TARGET_GOARCH}"
17 17 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"
18 # Setup vendor directory so that it can be used in GOPATH. 18 # Setup vendor directory so that it can be used in GOPATH.
19 # 19 #
20 # Go looks in a src directory under any directory in GOPATH but netns 20 # Go looks in a src directory under any directory in GOPATH but netns