summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/oci-image-tools/oci-image-tools_git.bb2
-rw-r--r--recipes-core/packagegroups/packagegroup-container.bb2
-rw-r--r--recipes-core/packagegroups/packagegroup-kubernetes.bb2
3 files changed, 6 insertions, 0 deletions
diff --git a/recipes-containers/oci-image-tools/oci-image-tools_git.bb b/recipes-containers/oci-image-tools/oci-image-tools_git.bb
index 878d4cc7..b925a2a7 100644
--- a/recipes-containers/oci-image-tools/oci-image-tools_git.bb
+++ b/recipes-containers/oci-image-tools/oci-image-tools_git.bb
@@ -29,6 +29,8 @@ EXTRA_OEMAKE="BUILDTAGS=''"
29 29
30S = "${WORKDIR}/git/src/github.com/opencontainers/image-tools" 30S = "${WORKDIR}/git/src/github.com/opencontainers/image-tools"
31 31
32COMPATIBLE_HOST:riscv64 = "null"
33
32do_compile() { 34do_compile() {
33 export GOARCH="${TARGET_GOARCH}" 35 export GOARCH="${TARGET_GOARCH}"
34 export GOROOT="${STAGING_LIBDIR}/go" 36 export GOROOT="${STAGING_LIBDIR}/go"
diff --git a/recipes-core/packagegroups/packagegroup-container.bb b/recipes-core/packagegroups/packagegroup-container.bb
index 8d418e95..c41576a3 100644
--- a/recipes-core/packagegroups/packagegroup-container.bb
+++ b/recipes-core/packagegroups/packagegroup-container.bb
@@ -4,6 +4,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
4 4
5inherit packagegroup 5inherit packagegroup
6 6
7COMPATIBLE_HOST:riscv64 = "null"
8
7PACKAGES = "\ 9PACKAGES = "\
8 packagegroup-container \ 10 packagegroup-container \
9 packagegroup-lxc \ 11 packagegroup-lxc \
diff --git a/recipes-core/packagegroups/packagegroup-kubernetes.bb b/recipes-core/packagegroups/packagegroup-kubernetes.bb
index 70dc9713..7e6937b1 100644
--- a/recipes-core/packagegroups/packagegroup-kubernetes.bb
+++ b/recipes-core/packagegroups/packagegroup-kubernetes.bb
@@ -4,6 +4,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
4 4
5inherit packagegroup 5inherit packagegroup
6 6
7COMPATIBLE_HOST:riscv64 = "null"
8
7# k3s has this restriction 9# k3s has this restriction
8inherit features_check 10inherit features_check
9REQUIRED_DISTRO_FEATURES ?= "seccomp" 11REQUIRED_DISTRO_FEATURES ?= "seccomp"