summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2023-09-01 17:03:08 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-09-04 03:05:49 +0000
commit8f25bfcbae987ed3b1bed82d6d9f937f3739362f (patch)
tree00ff4e2da9a49d2ca795140b1e07e2b63798e9a0
parent72a943b5f1f164252b14554d6deb063969af9da4 (diff)
downloadmeta-virtualization-8f25bfcbae987ed3b1bed82d6d9f937f3739362f.tar.gz
oci-image-tools: don't build for riscv64
Currently oci-image-tools has a do_compile error for riscv64. The problem could be reproduced by: MACHINE=qemuriscv64 bitbake oci-image-tools So explicitly set COMPATIBLE_HOST here to avoid it building for riscv64. When someone interested in using this recipe for riscv64 fixes the compile issue, this setting could be removed. Also don't build packagegroup-container/packagegroup-kubernetes since they depends on oci-image-tools Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/oci-image-tools/oci-image-tools_git.bb2
-rw-r--r--recipes-core/packagegroups/packagegroup-container.bb2
-rw-r--r--recipes-core/packagegroups/packagegroup-kubernetes.bb2
3 files changed, 6 insertions, 0 deletions
diff --git a/recipes-containers/oci-image-tools/oci-image-tools_git.bb b/recipes-containers/oci-image-tools/oci-image-tools_git.bb
index 878d4cc7..b925a2a7 100644
--- a/recipes-containers/oci-image-tools/oci-image-tools_git.bb
+++ b/recipes-containers/oci-image-tools/oci-image-tools_git.bb
@@ -29,6 +29,8 @@ EXTRA_OEMAKE="BUILDTAGS=''"
29 29
30S = "${WORKDIR}/git/src/github.com/opencontainers/image-tools" 30S = "${WORKDIR}/git/src/github.com/opencontainers/image-tools"
31 31
32COMPATIBLE_HOST:riscv64 = "null"
33
32do_compile() { 34do_compile() {
33 export GOARCH="${TARGET_GOARCH}" 35 export GOARCH="${TARGET_GOARCH}"
34 export GOROOT="${STAGING_LIBDIR}/go" 36 export GOROOT="${STAGING_LIBDIR}/go"
diff --git a/recipes-core/packagegroups/packagegroup-container.bb b/recipes-core/packagegroups/packagegroup-container.bb
index 8d418e95..c41576a3 100644
--- a/recipes-core/packagegroups/packagegroup-container.bb
+++ b/recipes-core/packagegroups/packagegroup-container.bb
@@ -4,6 +4,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
4 4
5inherit packagegroup 5inherit packagegroup
6 6
7COMPATIBLE_HOST:riscv64 = "null"
8
7PACKAGES = "\ 9PACKAGES = "\
8 packagegroup-container \ 10 packagegroup-container \
9 packagegroup-lxc \ 11 packagegroup-lxc \
diff --git a/recipes-core/packagegroups/packagegroup-kubernetes.bb b/recipes-core/packagegroups/packagegroup-kubernetes.bb
index 70dc9713..7e6937b1 100644
--- a/recipes-core/packagegroups/packagegroup-kubernetes.bb
+++ b/recipes-core/packagegroups/packagegroup-kubernetes.bb
@@ -4,6 +4,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
4 4
5inherit packagegroup 5inherit packagegroup
6 6
7COMPATIBLE_HOST:riscv64 = "null"
8
7# k3s has this restriction 9# k3s has this restriction
8inherit features_check 10inherit features_check
9REQUIRED_DISTRO_FEATURES ?= "seccomp" 11REQUIRED_DISTRO_FEATURES ?= "seccomp"