summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/containerd/containerd.inc1
-rw-r--r--recipes-containers/docker/docker_git.bb1
2 files changed, 2 insertions, 0 deletions
diff --git a/recipes-containers/containerd/containerd.inc b/recipes-containers/containerd/containerd.inc
index 18d9188e..e7a37192 100644
--- a/recipes-containers/containerd/containerd.inc
+++ b/recipes-containers/containerd/containerd.inc
@@ -38,6 +38,7 @@ do_compile() {
38 38
39 # Pass the needed cflags/ldflags so that cgo 39 # Pass the needed cflags/ldflags so that cgo
40 # can find the needed headers files and libraries 40 # can find the needed headers files and libraries
41 export GOARCH="${TARGET_GOARCH}"
41 export CGO_ENABLED="1" 42 export CGO_ENABLED="1"
42 export CFLAGS="" 43 export CFLAGS=""
43 export LDFLAGS="" 44 export LDFLAGS=""
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 4d6c17c9..4ba5e817 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -97,6 +97,7 @@ do_compile() {
97 97
98 # Pass the needed cflags/ldflags so that cgo 98 # Pass the needed cflags/ldflags so that cgo
99 # can find the needed headers files and libraries 99 # can find the needed headers files and libraries
100 export GOARCH=${TARGET_GOARCH}
100 export CGO_ENABLED="1" 101 export CGO_ENABLED="1"
101 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 102 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
102 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 103 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"