summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/k3s/k3s_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-containers/k3s/k3s_git.bb b/recipes-containers/k3s/k3s_git.bb
index 93a44e33..e33cb44b 100644
--- a/recipes-containers/k3s/k3s_git.bb
+++ b/recipes-containers/k3s/k3s_git.bb
@@ -76,7 +76,8 @@ do_compile() {
76 76
77 cp ${WORKDIR}/modules.txt vendor/ 77 cp ${WORKDIR}/modules.txt vendor/
78 78
79 ${GO} build -trimpath -tags "$TAGS" -ldflags "${GO_BUILD_LDFLAGS} -w -s" -o ./dist/artifacts/k3s ./cmd/server/main.go 79 VERSION_GOLANG="$(go version | cut -d" " -f3)"
80 ${GO} build -trimpath -tags "$TAGS" -ldflags "-X github.com/k3s-io/k3s/pkg/version.UpstreamGolang=$VERSION_GOLANG ${GO_BUILD_LDFLAGS} -w -s" -o ./dist/artifacts/k3s ./cmd/server/main.go
80 81
81 # Use UPX if it is enabled (and thus exists) to compress binary 82 # Use UPX if it is enabled (and thus exists) to compress binary
82 if command -v upx > /dev/null 2>&1; then 83 if command -v upx > /dev/null 2>&1; then