summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-networking/openvswitch/files/openvswitch-add-more-target-python-substitutions.patch50
-rw-r--r--recipes-networking/openvswitch/files/python-make-remaining-scripts-use-usr-bin-env.patch113
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-c298ef781c2d35d939fe163cbc2f41ea7b1cb8d1.patch (renamed from recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-f4b0e64cffb4777ff03d48621c3eadcf1d8c19f3.patch)10
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/openvswitch-ptest-Fix-python-path.patch30
-rw-r--r--recipes-networking/openvswitch/openvswitch_git.bb7
5 files changed, 114 insertions, 96 deletions
diff --git a/recipes-networking/openvswitch/files/openvswitch-add-more-target-python-substitutions.patch b/recipes-networking/openvswitch/files/openvswitch-add-more-target-python-substitutions.patch
deleted file mode 100644
index 2b87a116..00000000
--- a/recipes-networking/openvswitch/files/openvswitch-add-more-target-python-substitutions.patch
+++ /dev/null
@@ -1,50 +0,0 @@
1From d1ab2f62a03c2c977de6fed5fca8de63e328a870 Mon Sep 17 00:00:00 2001
2Message-Id: <d1ab2f62a03c2c977de6fed5fca8de63e328a870.1391527986.git.Jim.Somerville@windriver.com>
3From: Jim Somerville <Jim.Somerville@windriver.com>
4Date: Tue, 4 Feb 2014 15:30:41 +0000
5Subject: [PATCH 1/1] openvswitch: add more target python substitutions
6
7The TARGET_PYTHON variable is used for script
8substitutions to ensure the scripts will be able to properly execute
9if the target system has a different path for the python.
10
11Signed-off-by: Jim Somerville <Jim.Somerville@windriver.com>
12---
13 ovsdb/ovsdb-dot.in | 2 +-
14 ovsdb/ovsdb-idlc.in | 2 +-
15 utilities/ovs-dpctl-top.in | 2 +-
16 3 files changed, 3 insertions(+), 3 deletions(-)
17
18diff --git a/ovsdb/ovsdb-dot.in b/ovsdb/ovsdb-dot.in
19index 85c126d..402a77c 100755
20--- a/ovsdb/ovsdb-dot.in
21+++ b/ovsdb/ovsdb-dot.in
22@@ -1,4 +1,4 @@
23-#! @PYTHON@
24+#! @TARGET_PYTHON@
25
26 from datetime import date
27 import ovs.db.error
28diff --git a/ovsdb/ovsdb-idlc.in b/ovsdb/ovsdb-idlc.in
29index ec1c655..f5c135f 100755
30--- a/ovsdb/ovsdb-idlc.in
31+++ b/ovsdb/ovsdb-idlc.in
32@@ -1,4 +1,4 @@
33-#! @PYTHON@
34+#! @TARGET_PYTHON@
35
36 import getopt
37 import os
38diff --git a/utilities/ovs-dpctl-top.in b/utilities/ovs-dpctl-top.in
39index f43fdeb..8475118 100755
40--- a/utilities/ovs-dpctl-top.in
41+++ b/utilities/ovs-dpctl-top.in
42@@ -1,4 +1,4 @@
43-#! @PYTHON@
44+#! @TARGET_PYTHON@
45 #
46 # Copyright (c) 2013 Nicira, Inc.
47 #
48--
491.8.3.4
50
diff --git a/recipes-networking/openvswitch/files/python-make-remaining-scripts-use-usr-bin-env.patch b/recipes-networking/openvswitch/files/python-make-remaining-scripts-use-usr-bin-env.patch
index 6091930e..68f46ff5 100644
--- a/recipes-networking/openvswitch/files/python-make-remaining-scripts-use-usr-bin-env.patch
+++ b/recipes-networking/openvswitch/files/python-make-remaining-scripts-use-usr-bin-env.patch
@@ -1,4 +1,4 @@
1From 33769657e951da855b9258eb91fa9838373023ad Mon Sep 17 00:00:00 2001 1From 04ad1c3d9f47cfdf4ad9b5d685e953ec094326ff Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com> 2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Fri, 13 Jan 2017 16:12:55 -0500 3Date: Fri, 13 Jan 2017 16:12:55 -0500
4Subject: [PATCH] python: make remaining scripts use /usr/bin/env 4Subject: [PATCH] python: make remaining scripts use /usr/bin/env
@@ -13,11 +13,110 @@ make use of /usr/bin/env to increase the chances of finding python.
13 13
14Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> 14Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
15--- 15---
16 ovsdb/ovsdb-dot.in | 2 +- 16 build-aux/check-structs | 2 +-
17 ovsdb/ovsdb-idlc.in | 2 +- 17 build-aux/extract-ofp-actions | 2 +-
18 utilities/bugtool/ovs-bugtool.in | 2 +- 18 build-aux/extract-ofp-errors | 2 +-
19 3 files changed, 3 insertions(+), 3 deletions(-) 19 build-aux/extract-ofp-fields | 2 +-
20 build-aux/extract-ofp-msgs | 2 +-
21 build-aux/xml2nroff | 2 +-
22 ovn/utilities/ovn-docker-overlay-driver | 2 +-
23 ovn/utilities/ovn-docker-underlay-driver | 2 +-
24 ovsdb/ovsdb-doc | 2 +-
25 ovsdb/ovsdb-dot.in | 2 +-
26 ovsdb/ovsdb-idlc.in | 2 +-
27 utilities/bugtool/ovs-bugtool.in | 2 +-
28 12 files changed, 12 insertions(+), 12 deletions(-)
20 29
30diff --git a/build-aux/check-structs b/build-aux/check-structs
31index f79f235..c7b8730 100755
32--- a/build-aux/check-structs
33+++ b/build-aux/check-structs
34@@ -1,4 +1,4 @@
35-#! /usr/bin/python
36+#! /usr/bin/env python
37
38 import os.path
39 import sys
40diff --git a/build-aux/extract-ofp-actions b/build-aux/extract-ofp-actions
41index 184447b..92ea18d 100755
42--- a/build-aux/extract-ofp-actions
43+++ b/build-aux/extract-ofp-actions
44@@ -1,4 +1,4 @@
45-#! /usr/bin/python
46+#! /usr/bin/env python
47
48 import sys
49 import os.path
50diff --git a/build-aux/extract-ofp-errors b/build-aux/extract-ofp-errors
51index 9642593..11e6de7 100755
52--- a/build-aux/extract-ofp-errors
53+++ b/build-aux/extract-ofp-errors
54@@ -1,4 +1,4 @@
55-#! /usr/bin/python
56+#! /usr/bin/env python
57
58 import sys
59 import os.path
60diff --git a/build-aux/extract-ofp-fields b/build-aux/extract-ofp-fields
61index 498b887..5d6bcec 100755
62--- a/build-aux/extract-ofp-fields
63+++ b/build-aux/extract-ofp-fields
64@@ -1,4 +1,4 @@
65-#! /usr/bin/python
66+#! /usr/bin/env python
67
68 import getopt
69 import sys
70diff --git a/build-aux/extract-ofp-msgs b/build-aux/extract-ofp-msgs
71index 1813638..e9e3c25 100755
72--- a/build-aux/extract-ofp-msgs
73+++ b/build-aux/extract-ofp-msgs
74@@ -1,4 +1,4 @@
75-#! /usr/bin/python
76+#! /usr/bin/env python
77
78 import sys
79 import os.path
80diff --git a/build-aux/xml2nroff b/build-aux/xml2nroff
81index bd4e879..9d81503 100755
82--- a/build-aux/xml2nroff
83+++ b/build-aux/xml2nroff
84@@ -1,4 +1,4 @@
85-#! /usr/bin/python
86+#! /usr/bin/env python
87
88 # Copyright (c) 2010, 2011, 2012, 2013, 2014, 2015, 2016 Nicira, Inc.
89 #
90diff --git a/ovn/utilities/ovn-docker-overlay-driver b/ovn/utilities/ovn-docker-overlay-driver
91index 52de3db..c90f02b 100755
92--- a/ovn/utilities/ovn-docker-overlay-driver
93+++ b/ovn/utilities/ovn-docker-overlay-driver
94@@ -1,4 +1,4 @@
95-#! /usr/bin/python
96+#! /usr/bin/env python
97 # Copyright (C) 2015 Nicira, Inc.
98 #
99 # Licensed under the Apache License, Version 2.0 (the "License");
100diff --git a/ovn/utilities/ovn-docker-underlay-driver b/ovn/utilities/ovn-docker-underlay-driver
101index 2c9c4b6..89b804c 100755
102--- a/ovn/utilities/ovn-docker-underlay-driver
103+++ b/ovn/utilities/ovn-docker-underlay-driver
104@@ -1,4 +1,4 @@
105-#! /usr/bin/python
106+#! /usr/bin/env python
107 # Copyright (C) 2015 Nicira, Inc.
108 #
109 # Licensed under the Apache License, Version 2.0 (the "License");
110diff --git a/ovsdb/ovsdb-doc b/ovsdb/ovsdb-doc
111index 5cf26ee..f76f4bd 100755
112--- a/ovsdb/ovsdb-doc
113+++ b/ovsdb/ovsdb-doc
114@@ -1,4 +1,4 @@
115-#! /usr/bin/python
116+#! /usr/bin/env python
117
118 # Copyright (c) 2010, 2011, 2012, 2013, 2014, 2015 Nicira, Inc.
119 #
21diff --git a/ovsdb/ovsdb-dot.in b/ovsdb/ovsdb-dot.in 120diff --git a/ovsdb/ovsdb-dot.in b/ovsdb/ovsdb-dot.in
22index 134ce22..893c408 100755 121index 134ce22..893c408 100755
23--- a/ovsdb/ovsdb-dot.in 122--- a/ovsdb/ovsdb-dot.in
@@ -29,7 +128,7 @@ index 134ce22..893c408 100755
29 from datetime import date 128 from datetime import date
30 import ovs.db.error 129 import ovs.db.error
31diff --git a/ovsdb/ovsdb-idlc.in b/ovsdb/ovsdb-idlc.in 130diff --git a/ovsdb/ovsdb-idlc.in b/ovsdb/ovsdb-idlc.in
32index cd4532e..dceb02f 100755 131index 721ab50..bfbcf23 100755
33--- a/ovsdb/ovsdb-idlc.in 132--- a/ovsdb/ovsdb-idlc.in
34+++ b/ovsdb/ovsdb-idlc.in 133+++ b/ovsdb/ovsdb-idlc.in
35@@ -1,4 +1,4 @@ 134@@ -1,4 +1,4 @@
@@ -39,7 +138,7 @@ index cd4532e..dceb02f 100755
39 import getopt 138 import getopt
40 import os 139 import os
41diff --git a/utilities/bugtool/ovs-bugtool.in b/utilities/bugtool/ovs-bugtool.in 140diff --git a/utilities/bugtool/ovs-bugtool.in b/utilities/bugtool/ovs-bugtool.in
42index bb771b0..152d171 100755 141index 963c50c..c84d7c2 100755
43--- a/utilities/bugtool/ovs-bugtool.in 142--- a/utilities/bugtool/ovs-bugtool.in
44+++ b/utilities/bugtool/ovs-bugtool.in 143+++ b/utilities/bugtool/ovs-bugtool.in
45@@ -1,4 +1,4 @@ 144@@ -1,4 +1,4 @@
diff --git a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-f4b0e64cffb4777ff03d48621c3eadcf1d8c19f3.patch b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-c298ef781c2d35d939fe163cbc2f41ea7b1cb8d1.patch
index 7e740441..47c81dd9 100644
--- a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-f4b0e64cffb4777ff03d48621c3eadcf1d8c19f3.patch
+++ b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-c298ef781c2d35d939fe163cbc2f41ea7b1cb8d1.patch
@@ -1,4 +1,4 @@
1From e20556d7cf0fc8258db77c1f3e0a160cf9fd4514 Mon Sep 17 00:00:00 2001 1From a2a656e6976a60e5df3ade0d17a40b4ebdc2b41a Mon Sep 17 00:00:00 2001
2From: He Zhe <zhe.he@windriver.com> 2From: He Zhe <zhe.he@windriver.com>
3Date: Wed, 30 Mar 2016 06:23:45 -0400 3Date: Wed, 30 Mar 2016 06:23:45 -0400
4Subject: [PATCH] openvswitch: Add test-install rule to support ptest execution 4Subject: [PATCH] openvswitch: Add test-install rule to support ptest execution
@@ -19,13 +19,13 @@ Signed-off-by: He Zhe <zhe.he@windriver.com>
19 create mode 100644 test.mk 19 create mode 100644 test.mk
20 20
21diff --git a/Makefile.am b/Makefile.am 21diff --git a/Makefile.am b/Makefile.am
22index ed43c2f..f38d278 100644 22index a4dd7b8..0bd32c7 100644
23--- a/Makefile.am 23--- a/Makefile.am
24+++ b/Makefile.am 24+++ b/Makefile.am
25@@ -401,3 +401,4 @@ include datapath-windows/include/automake.mk 25@@ -429,3 +429,4 @@ include windows/automake.mk
26 include windows/automake.mk
27 include ovn/automake.mk 26 include ovn/automake.mk
28 include selinux/automake.mk 27 include selinux/automake.mk
28 include build-aux/automake.mk
29+include test.mk 29+include test.mk
30diff --git a/test.mk b/test.mk 30diff --git a/test.mk b/test.mk
31new file mode 100644 31new file mode 100644
@@ -106,5 +106,5 @@ index 0000000..b10a581
106+ sed -i 's|ovs-appctl-bashcomp\.bash|/etc/bash_completion.d/ovs-appctl-bashcomp\.bash|g' $(TEST_DEST)/tests/testsuite 106+ sed -i 's|ovs-appctl-bashcomp\.bash|/etc/bash_completion.d/ovs-appctl-bashcomp\.bash|g' $(TEST_DEST)/tests/testsuite
107+ sed -i 's|ovs-vsctl-bashcomp\.bash|/etc/bash_completion.d/ovs-vsctl-bashcomp\.bash|g' $(TEST_DEST)/tests/testsuite 107+ sed -i 's|ovs-vsctl-bashcomp\.bash|/etc/bash_completion.d/ovs-vsctl-bashcomp\.bash|g' $(TEST_DEST)/tests/testsuite
108-- 108--
1091.9.1 1092.7.4
110 110
diff --git a/recipes-networking/openvswitch/openvswitch-git/openvswitch-ptest-Fix-python-path.patch b/recipes-networking/openvswitch/openvswitch-git/openvswitch-ptest-Fix-python-path.patch
deleted file mode 100644
index c75ebc50..00000000
--- a/recipes-networking/openvswitch/openvswitch-git/openvswitch-ptest-Fix-python-path.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From 2a78bddb865e0d3377f437428ed6825195af0a14 Mon Sep 17 00:00:00 2001
2From: He Zhe <zhe.he@windriver.com>
3Date: Wed, 13 Apr 2016 03:13:01 -0400
4Subject: [PATCH] openvswitch: ptest: Fix python path
5
6For now PYTHON just happens to be the same as TARGET_PYTHON so we get the right
7python binary. This patch sets PYTHON to TARGET_PYTHON since ptest is going to
8be run on target.
9
10Signed-off-by: He Zhe <zhe.he@windriver.com>
11---
12 tests/atlocal.in | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/tests/atlocal.in b/tests/atlocal.in
16index 5815c6c..db2d2c9 100644
17--- a/tests/atlocal.in
18+++ b/tests/atlocal.in
19@@ -5,7 +5,7 @@ EGREP='@EGREP@'
20 PERL='@PERL@'
21
22 if test x"$PYTHON" = x; then
23- PYTHON='@PYTHON@'
24+ PYTHON='@TARGET_PYTHON@'
25 fi
26
27 PYTHONPATH=$abs_top_srcdir/python:$abs_top_builddir/tests:$PYTHONPATH
28--
291.9.1
30
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index 0ead3020..1fb82aee 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -12,21 +12,20 @@ RDEPENDS_${PN}-ptest += "\
12 " 12 "
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15PV = "2.6.1+${SRCREV}" 15PV = "2.7.0+${SRCREV}"
16 16
17FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:" 17FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:"
18 18
19SRCREV = "f4b0e64cffb4777ff03d48621c3eadcf1d8c19f3" 19SRCREV = "c298ef781c2d35d939fe163cbc2f41ea7b1cb8d1"
20SRC_URI = "file://openvswitch-switch \ 20SRC_URI = "file://openvswitch-switch \
21 file://openvswitch-switch-setup \ 21 file://openvswitch-switch-setup \
22 file://openvswitch-testcontroller \ 22 file://openvswitch-testcontroller \
23 file://openvswitch-testcontroller-setup \ 23 file://openvswitch-testcontroller-setup \
24 git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.6 \ 24 git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.7 \
25 file://openvswitch-add-ptest-${SRCREV}.patch \ 25 file://openvswitch-add-ptest-${SRCREV}.patch \
26 file://run-ptest \ 26 file://run-ptest \
27 file://disable_m4_check.patch \ 27 file://disable_m4_check.patch \
28 file://kernel_module.patch \ 28 file://kernel_module.patch \
29 file://openvswitch-ptest-Fix-python-path.patch \
30 file://python-make-remaining-scripts-use-usr-bin-env.patch \ 29 file://python-make-remaining-scripts-use-usr-bin-env.patch \
31 file://0001-use-the-linux-if_packet.h-Interface-directly.patch \ 30 file://0001-use-the-linux-if_packet.h-Interface-directly.patch \
32 file://0002-Define-WAIT_ANY-if-not-provided-by-system.patch \ 31 file://0002-Define-WAIT_ANY-if-not-provided-by-system.patch \