summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/containerd/containerd-opencontainers/0001-Makefile-update-default-PACKAGE-to-v2.patch28
-rw-r--r--recipes-containers/containerd/containerd-opencontainers_git.bb7
-rw-r--r--recipes-containers/kubernetes/kubernetes_git.bb3
-rw-r--r--recipes-containers/podman/podman_git.bb2
-rw-r--r--recipes-extended/ceph/ceph/0001-delete-install-layout-deb.patch2
-rw-r--r--recipes-extended/diod/diod_1.0.24.bb1
-rw-r--r--recipes-extended/diod/files/0002-Handle-various-time_t-sizes-in-printf-and-scanf.patch100
-rw-r--r--recipes-networking/cni/cni_git.bb3
8 files changed, 139 insertions, 7 deletions
diff --git a/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-update-default-PACKAGE-to-v2.patch b/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-update-default-PACKAGE-to-v2.patch
new file mode 100644
index 00000000..74e313b5
--- /dev/null
+++ b/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-update-default-PACKAGE-to-v2.patch
@@ -0,0 +1,28 @@
1From eb39888898a9d196e3eb63724c6c07777f3b9402 Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Wed, 24 Apr 2024 14:10:11 +0800
4Subject: [PATCH] Makefile: update default PACKAGE to v2
5
6Upstream-Status: Submitted [https://github.com/containerd/containerd/pull/10125]
7
8Signed-off-by: Changqing Li <changqing.li@windriver.com>
9---
10 Makefile | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/Makefile b/Makefile
14index a5b244191..cb9ff4172 100644
15--- a/Makefile
16+++ b/Makefile
17@@ -34,7 +34,7 @@ TEST_IMAGE_LIST ?=
18 # Used to populate variables in version package.
19 VERSION ?= $(shell git describe --match 'v[0-9]*' --dirty='.m' --always)
20 REVISION ?= $(shell git rev-parse HEAD)$(shell if ! git diff --no-ext-diff --quiet --exit-code; then echo .m; fi)
21-PACKAGE=github.com/containerd/containerd
22+PACKAGE=github.com/containerd/containerd/v2
23 SHIM_CGO_ENABLED ?= 0
24
25 ifneq "$(strip $(shell command -v $(GO) 2>/dev/null))" ""
26--
272.25.1
28
diff --git a/recipes-containers/containerd/containerd-opencontainers_git.bb b/recipes-containers/containerd/containerd-opencontainers_git.bb
index 10d1ce8b..ed73e398 100644
--- a/recipes-containers/containerd/containerd-opencontainers_git.bb
+++ b/recipes-containers/containerd/containerd-opencontainers_git.bb
@@ -6,9 +6,10 @@ DESCRIPTION = "containerd is a daemon to control runC, built for performance and
6 6
7 7
8SRCREV = "b1624c3628954e769dd50783b63823040b2db38c" 8SRCREV = "b1624c3628954e769dd50783b63823040b2db38c"
9SRC_URI = "git://github.com/containerd/containerd;branch=main;protocol=https;destsuffix=git/src/github.com/containerd/containerd \ 9SRC_URI = "git://github.com/containerd/containerd;branch=main;protocol=https;destsuffix=git/src/github.com/containerd/containerd/v2 \
10 file://0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch \ 10 file://0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch \
11 file://0001-build-don-t-use-gcflags-to-define-trimpath.patch \ 11 file://0001-build-don-t-use-gcflags-to-define-trimpath.patch \
12 file://0001-Makefile-update-default-PACKAGE-to-v2.patch \
12 " 13 "
13 14
14# Apache-2.0 for containerd 15# Apache-2.0 for containerd
@@ -23,7 +24,7 @@ CVE_VERSION = "v2.0.0-beta.0"
23PROVIDES += "virtual/containerd" 24PROVIDES += "virtual/containerd"
24RPROVIDES:${PN} = "virtual-containerd" 25RPROVIDES:${PN} = "virtual-containerd"
25 26
26S = "${WORKDIR}/git/src/github.com/containerd/containerd" 27S = "${WORKDIR}/git/src/github.com/containerd/containerd/v2"
27 28
28PV = "${CONTAINERD_VERSION}+git" 29PV = "${CONTAINERD_VERSION}+git"
29 30
@@ -32,8 +33,6 @@ inherit goarch
32 33
33GO_IMPORT = "import" 34GO_IMPORT = "import"
34 35
35CONTAINERD_PKG="github.com/containerd/containerd"
36
37INSANE_SKIP:${PN} += "ldflags" 36INSANE_SKIP:${PN} += "ldflags"
38 37
39do_configure[noexec] = "1" 38do_configure[noexec] = "1"
diff --git a/recipes-containers/kubernetes/kubernetes_git.bb b/recipes-containers/kubernetes/kubernetes_git.bb
index caa5ec17..044175eb 100644
--- a/recipes-containers/kubernetes/kubernetes_git.bb
+++ b/recipes-containers/kubernetes/kubernetes_git.bb
@@ -92,6 +92,7 @@ do_compile() {
92 export CC="${CC}" 92 export CC="${CC}"
93 export LD="${LD}" 93 export LD="${LD}"
94 export GOBIN="" 94 export GOBIN=""
95 export GOFLAGS="-trimpath"
95 96
96 # to limit what is built, use 'WHAT', i.e. make WHAT=cmd/kubelet 97 # to limit what is built, use 'WHAT', i.e. make WHAT=cmd/kubelet
97 make cross CGO_FLAGS=${CGO_FLAGS} GO=${GO} KUBE_BUILD_PLATFORMS=${GOOS}/${GOARCH} GOLDFLAGS="" DBG=1 98 make cross CGO_FLAGS=${CGO_FLAGS} GO=${GO} KUBE_BUILD_PLATFORMS=${GOOS}/${GOARCH} GOLDFLAGS="" DBG=1
@@ -125,7 +126,7 @@ PACKAGES =+ "kubeadm kubectl kubelet kube-proxy ${PN}-misc ${PN}-host"
125ALLOW_EMPTY:${PN} = "1" 126ALLOW_EMPTY:${PN} = "1"
126INSANE_SKIP:${PN} += "ldflags already-stripped" 127INSANE_SKIP:${PN} += "ldflags already-stripped"
127INSANE_SKIP:${PN}-misc += "ldflags already-stripped textrel" 128INSANE_SKIP:${PN}-misc += "ldflags already-stripped textrel"
128INSANE_SKIP:kubelet += "ldflags already-stripped" 129INSANE_SKIP:${MLPREFIX}kubelet += "ldflags already-stripped textrel"
129 130
130# Note: we are explicitly *not* adding docker to the rdepends, since we allow 131# Note: we are explicitly *not* adding docker to the rdepends, since we allow
131# backends like cri-o to be used. 132# backends like cri-o to be used.
diff --git a/recipes-containers/podman/podman_git.bb b/recipes-containers/podman/podman_git.bb
index f69dec16..32de3f0c 100644
--- a/recipes-containers/podman/podman_git.bb
+++ b/recipes-containers/podman/podman_git.bb
@@ -134,7 +134,7 @@ do_install_ptest () {
134FILES:${PN} += " \ 134FILES:${PN} += " \
135 ${systemd_unitdir}/system/* \ 135 ${systemd_unitdir}/system/* \
136 ${nonarch_libdir}/systemd/* \ 136 ${nonarch_libdir}/systemd/* \
137 ${systemd_user_unitdir/* \ 137 ${systemd_user_unitdir}/* \
138 ${nonarch_libdir}/tmpfiles.d/* \ 138 ${nonarch_libdir}/tmpfiles.d/* \
139 ${datadir}/user-tmpfiles.d/* \ 139 ${datadir}/user-tmpfiles.d/* \
140 ${sysconfdir}/cni \ 140 ${sysconfdir}/cni \
diff --git a/recipes-extended/ceph/ceph/0001-delete-install-layout-deb.patch b/recipes-extended/ceph/ceph/0001-delete-install-layout-deb.patch
index 91eacfa9..3cd8edba 100644
--- a/recipes-extended/ceph/ceph/0001-delete-install-layout-deb.patch
+++ b/recipes-extended/ceph/ceph/0001-delete-install-layout-deb.patch
@@ -3,6 +3,8 @@ From: Chen Qi <Qi.Chen@windriver.com>
3Date: Wed, 13 Mar 2024 03:41:47 -0700 3Date: Wed, 13 Mar 2024 03:41:47 -0700
4Subject: [PATCH] delete install-layout=deb 4Subject: [PATCH] delete install-layout=deb
5 5
6Upstream-Status: Pending
7
6Signed-off-by: Chen Qi <Qi.Chen@windriver.com> 8Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
7--- 9---
8 cmake/modules/Distutils.cmake | 6 ------ 10 cmake/modules/Distutils.cmake | 6 ------
diff --git a/recipes-extended/diod/diod_1.0.24.bb b/recipes-extended/diod/diod_1.0.24.bb
index 5e191dc0..6019fbfb 100644
--- a/recipes-extended/diod/diod_1.0.24.bb
+++ b/recipes-extended/diod/diod_1.0.24.bb
@@ -14,6 +14,7 @@ SRC_URI = "git://github.com/chaos/diod.git;protocol=https;branch=master \
14 file://diod \ 14 file://diod \
15 file://diod.conf \ 15 file://diod.conf \
16 file://0001-build-Find-lua-with-pkg-config.patch \ 16 file://0001-build-Find-lua-with-pkg-config.patch \
17 file://0002-Handle-various-time_t-sizes-in-printf-and-scanf.patch \
17 " 18 "
18DEPENDS = "libcap ncurses tcp-wrappers lua" 19DEPENDS = "libcap ncurses tcp-wrappers lua"
19 20
diff --git a/recipes-extended/diod/files/0002-Handle-various-time_t-sizes-in-printf-and-scanf.patch b/recipes-extended/diod/files/0002-Handle-various-time_t-sizes-in-printf-and-scanf.patch
new file mode 100644
index 00000000..3c13c101
--- /dev/null
+++ b/recipes-extended/diod/files/0002-Handle-various-time_t-sizes-in-printf-and-scanf.patch
@@ -0,0 +1,100 @@
1From 04b0c5a5cb9e32090b177ff7327ad3260783abe0 Mon Sep 17 00:00:00 2001
2From: Ola x Nilsson <olani@axis.com>
3Date: Mon, 15 Apr 2024 17:31:44 +0200
4Subject: [PATCH] Handle various time_t sizes in printf and scanf
5
6The members of the timeval struct are both signed (defined by POSIX)
7and typically both 64 bits on a system where time_t is 64 bits. This
8is possible also on 32 bit systems where time_t is larger to handle
9the 2038 problem.
10
11It's practically impossible to find a type and printf format that
12works even on all glibc systems. Play it safe and always use printf
13with intmax_t and explict int64_t variables for scanf.
14
15Upstream-Status: Submitted [https://github.com/chaos/diod/pull/100]
16Signed-off-by: Ola x Nilsson <olani@axis.com>
17---
18 libnpfs/conn.c | 5 +++--
19 libnpfs/ctl.c | 7 ++++---
20 utils/dioddate.c | 8 +++++++-
21 3 files changed, 14 insertions(+), 6 deletions(-)
22
23diff --git a/libnpfs/conn.c b/libnpfs/conn.c
24index 6e85fff..c34c840 100644
25--- a/libnpfs/conn.c
26+++ b/libnpfs/conn.c
27@@ -16,6 +16,7 @@
28 #include <stdio.h>
29 #include <string.h>
30 #include <stdint.h>
31+#include <inttypes.h>
32 #include <stdarg.h>
33 #include <errno.h>
34 #include <pthread.h>
35@@ -133,8 +134,8 @@ _debug_trace (Npsrv *srv, Npfcall *fc)
36 (void)gettimeofday(&b, NULL);
37 (void)gettimeofday(&a, NULL);
38 timersub(&a, &b, &c);
39- np_logmsg(srv, "[%lu.%-3lu] %s",
40- c.tv_sec, c.tv_usec/1000, s);
41+ np_logmsg(srv, "[%"PRIdMAX".%-3"PRIdMAX"] %s",
42+ (intmax_t)c.tv_sec, (intmax_t)c.tv_usec/1000, s);
43 } else
44 np_logmsg(srv, "%s", s);
45 }
46diff --git a/libnpfs/ctl.c b/libnpfs/ctl.c
47index f40cde4..317a22e 100644
48--- a/libnpfs/ctl.c
49+++ b/libnpfs/ctl.c
50@@ -16,6 +16,7 @@
51 #include <stdio.h>
52 #include <string.h>
53 #include <stdint.h>
54+#include <inttypes.h>
55 #include <stdarg.h>
56 #include <pthread.h>
57 #include <errno.h>
58@@ -291,9 +292,9 @@ _ctl_get_date (char *name, void *a)
59 np_uerror (errno);
60 goto error;
61 }
62- if (aspf (&s, &len, "%lu.%lu %d.%d\n",
63- tv.tv_sec, tv.tv_usec,
64- tz.tz_minuteswest, tz.tz_dsttime) < 0) {
65+ if (aspf (&s, &len, "%"PRIdMAX".%"PRIdMAX" %d.%d\n",
66+ (uintmax_t)tv.tv_sec, (uintmax_t)tv.tv_usec,
67+ tz.tz_minuteswest, tz.tz_dsttime) < 0) {
68 np_uerror (ENOMEM);
69 goto error;
70 }
71diff --git a/utils/dioddate.c b/utils/dioddate.c
72index bde002f..f392792 100644
73--- a/utils/dioddate.c
74+++ b/utils/dioddate.c
75@@ -21,6 +21,7 @@
76 #include <unistd.h>
77 #include <stdlib.h>
78 #include <stdint.h>
79+#include <inttypes.h>
80 #include <stdarg.h>
81 #include <stdio.h>
82 #if HAVE_GETOPT_H
83@@ -142,11 +143,16 @@ main (int argc, char *argv[])
84 errn (np_rerror (), "error reading date");
85 goto done;
86 }
87- if (sscanf (buf, "%lu.%lu %d.%d", &tv.tv_sec, &tv.tv_usec,
88+
89+ int64_t sec = 0, usec = 0;
90+ if (sscanf (buf, "%"SCNd64".%"SCNd64" %d.%d", &sec, &usec,
91 &tz.tz_minuteswest, &tz.tz_dsttime) != 4) {
92 msg ("error scanning returned date: %s", buf);
93 goto done;
94 }
95+ tv.tv_sec = sec;
96+ tv.tv_usec = usec;
97+
98 if (Sopt) {
99 if (settimeofday (&tv, &tz) < 0)
100 err_exit ("settimeofday");
diff --git a/recipes-networking/cni/cni_git.bb b/recipes-networking/cni/cni_git.bb
index fda7af60..b41b47cf 100644
--- a/recipes-networking/cni/cni_git.bb
+++ b/recipes-networking/cni/cni_git.bb
@@ -34,6 +34,7 @@ LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464
34GO_IMPORT = "import" 34GO_IMPORT = "import"
35 35
36PV = "v1.2.0-rc0+git${SRCREV_cni}" 36PV = "v1.2.0-rc0+git${SRCREV_cni}"
37CNI_VERSION = "v1.2.0"
37 38
38inherit go 39inherit go
39inherit goarch 40inherit goarch
@@ -68,7 +69,7 @@ do_compile() {
68 for p in $PLUGINS; do 69 for p in $PLUGINS; do
69 plugin="$(basename "$p")" 70 plugin="$(basename "$p")"
70 echo "building: $p" 71 echo "building: $p"
71 ${GO} build ${GOBUILDFLAGS} -o ${B}/plugins/bin/$plugin github.com/containernetworking/plugins/$p 72 ${GO} build ${GOBUILDFLAGS} -ldflags '-X github.com/containernetworking/plugins/pkg/utils/buildversion.BuildVersion=${CNI_VERSION}' -o ${B}/plugins/bin/$plugin github.com/containernetworking/plugins/$p
72 done 73 done
73} 74}
74 75