summaryrefslogtreecommitdiffstats
path: root/recipes-networking
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2021-11-15 22:13:38 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-11-19 08:30:42 -0500
commitfd6e0cda911560ae4a78ee913066ffefd8e29b7e (patch)
treeb4bb1884eecabc64a60ab7f1af03392c4282c6a4 /recipes-networking
parent538d688aad04178c99f71807aa66fb773f99c7d0 (diff)
downloadmeta-virtualization-fd6e0cda911560ae4a78ee913066ffefd8e29b7e.tar.gz
openvswitch: fix configure error with dpdk enabled
When enabling 'dpdk' PACKAGECONFIG, the following error appears. | configure: error: Could not find DPDK library in default search path Fix the error by tweaking the configure option regarding dpdk. Add pkgconfig to 'inherit' because pkgconfig is required at do_configure when dpdk is enabled. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-networking')
-rw-r--r--recipes-networking/openvswitch/openvswitch.inc2
-rw-r--r--recipes-networking/openvswitch/openvswitch_git.bb4
2 files changed, 2 insertions, 4 deletions
diff --git a/recipes-networking/openvswitch/openvswitch.inc b/recipes-networking/openvswitch/openvswitch.inc
index b354a847..831e0b35 100644
--- a/recipes-networking/openvswitch/openvswitch.inc
+++ b/recipes-networking/openvswitch/openvswitch.inc
@@ -72,7 +72,7 @@ FILES:${PN} += "${datadir}/ovsdbmonitor"
72FILES:${PN} += "/run" 72FILES:${PN} += "/run"
73 73
74FILES:${PN} += "${libdir}/python${PYTHON_BASEVERSION}/" 74FILES:${PN} += "${libdir}/python${PYTHON_BASEVERSION}/"
75inherit autotools update-rc.d systemd python3native 75inherit pkgconfig autotools update-rc.d systemd python3native
76 76
77SYSTEMD_PACKAGES = "${PN}-switch" 77SYSTEMD_PACKAGES = "${PN}-switch"
78SYSTEMD_SERVICE:${PN}-switch = " \ 78SYSTEMD_SERVICE:${PN}-switch = " \
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index f1a5c4ca..0fb7c132 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -32,10 +32,8 @@ SRC_URI += "git://github.com/openvswitch/ovs.git;protocol=https;branch=branch-2.
32 32
33LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab" 33LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"
34 34
35DPDK_INSTALL_DIR ?= "/opt/dpdk"
36
37PACKAGECONFIG ?= "libcap-ng" 35PACKAGECONFIG ?= "libcap-ng"
38PACKAGECONFIG[dpdk] = "--with-dpdk=${STAGING_DIR_TARGET}${DPDK_INSTALL_DIR}/share/${TARGET_ARCH}-native-linuxapp-gcc,,dpdk,dpdk" 36PACKAGECONFIG[dpdk] = "--with-dpdk=shared,,dpdk,dpdk"
39PACKAGECONFIG[libcap-ng] = "--enable-libcapng,--disable-libcapng,libcap-ng," 37PACKAGECONFIG[libcap-ng] = "--enable-libcapng,--disable-libcapng,libcap-ng,"
40PACKAGECONFIG[ssl] = ",--disable-ssl,openssl," 38PACKAGECONFIG[ssl] = ",--disable-ssl,openssl,"
41 39