summaryrefslogtreecommitdiffstats
path: root/recipes-networking
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-05-23 17:57:15 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-05-24 21:01:45 -0700
commit69a10f062a0cd8c054b495ccb303fea50e4c592d (patch)
tree925463d6e962a6db6f4d88c959b6df5c959b807c /recipes-networking
parent98093ac9ab99d11c4e549436eb0abcef438fb6ce (diff)
downloadmeta-virtualization-69a10f062a0cd8c054b495ccb303fea50e4c592d.tar.gz
netcf: fix network driver check issue on opensuse
Signed-off-by: Ting Liu <b28495@freescale.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking')
-rw-r--r--recipes-networking/netcf/netcf/0001-fix-network-driver-check-issue-on-opensuse.patch28
-rw-r--r--recipes-networking/netcf/netcf_git.bb6
2 files changed, 32 insertions, 2 deletions
diff --git a/recipes-networking/netcf/netcf/0001-fix-network-driver-check-issue-on-opensuse.patch b/recipes-networking/netcf/netcf/0001-fix-network-driver-check-issue-on-opensuse.patch
new file mode 100644
index 00000000..eef5b5cb
--- /dev/null
+++ b/recipes-networking/netcf/netcf/0001-fix-network-driver-check-issue-on-opensuse.patch
@@ -0,0 +1,28 @@
1From 285871a2db42727665a2ab7fc16fa2fb8fa830d3 Mon Sep 17 00:00:00 2001
2From: Ting Liu <b28495@freescale.com>
3Date: Thu, 23 May 2013 17:39:35 +0800
4Subject: [PATCH] fix network driver check issue on opensuse
5
6Upstream-Status: Pending
7
8Signed-off-by: Ting Liu <b28495@freescale.com>
9---
10 configure.ac | 2 +-
11 1 files changed, 1 insertions(+), 1 deletions(-)
12
13diff --git a/configure.ac b/configure.ac
14index 3f30865..708eb28 100644
15--- a/configure.ac
16+++ b/configure.ac
17@@ -77,7 +77,7 @@ fi
18 if test "x$with_driver" = "xcheck" && test -f /etc/ubuntu_version ; then
19 with_driver=debian
20 fi
21-if test "x$with_driver" = "xcheck" && test -f /etc/suse-release ; then
22+if test "x$with_driver" = "xcheck" && (test -f /etc/suse-release || test -f /etc/SuSE-release) ; then
23 with_driver=suse
24 fi
25 if test "x$with_driver" = "xcheck" ; then
26--
271.7.3.4
28
diff --git a/recipes-networking/netcf/netcf_git.bb b/recipes-networking/netcf/netcf_git.bb
index 60fc446d..d380e95e 100644
--- a/recipes-networking/netcf/netcf_git.bb
+++ b/recipes-networking/netcf/netcf_git.bb
@@ -7,10 +7,12 @@ LICENSE = "LGPLv2.1"
7LIC_FILES_CHKSUM = "file://COPYING;md5=bbb461211a33b134d42ed5ee802b37ff" 7LIC_FILES_CHKSUM = "file://COPYING;md5=bbb461211a33b134d42ed5ee802b37ff"
8 8
9SRCREV = "2b0d9ca226c13d7150382367f62b256bdb2db5ef" 9SRCREV = "2b0d9ca226c13d7150382367f62b256bdb2db5ef"
10PR = "r0" 10PR = "r1"
11PV = "0.2.2+git${SRCPV}" 11PV = "0.2.2+git${SRCPV}"
12 12
13SRC_URI = "git://git.fedorahosted.org/netcf.git;protocol=git" 13SRC_URI = "git://git.fedorahosted.org/netcf.git;protocol=git \
14 file://0001-fix-network-driver-check-issue-on-opensuse.patch \
15"
14 16
15DEPENDS += "augeas libnl libxslt libxml2" 17DEPENDS += "augeas libnl libxslt libxml2"
16 18