summaryrefslogtreecommitdiffstats
path: root/recipes-networking
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-06-20 11:02:50 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-06-20 11:02:50 -0400
commit55884d203d1e7ca5c39561f5efdc1bf14034d854 (patch)
tree25be8c11fba9c69aeb12c03b1390cf71ec24575b /recipes-networking
parenta15fcfb678839edd887c5ff2e880a46da00809d7 (diff)
downloadmeta-virtualization-55884d203d1e7ca5c39561f5efdc1bf14034d854.tar.gz
openvswitch: remove 1.9 recipe
The OVS 1.10 integration has soaked for long enough to be stable, so we can remove the old 1.9 recipe. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking')
-rw-r--r--recipes-networking/openvswitch/openvswitch_1.9.0.bb99
1 files changed, 0 insertions, 99 deletions
diff --git a/recipes-networking/openvswitch/openvswitch_1.9.0.bb b/recipes-networking/openvswitch/openvswitch_1.9.0.bb
deleted file mode 100644
index bfaa0046..00000000
--- a/recipes-networking/openvswitch/openvswitch_1.9.0.bb
+++ /dev/null
@@ -1,99 +0,0 @@
1SUMMARY = "OpenvSwitch"
2DESCRIPTION = "Open vSwitch is a production quality, multilayer virtual switch licensed under the open source Apache 2.0 license. It is designed to enable massive network automation through programmatic extension, while still supporting standard management interfaces and protocols (e.g. NetFlow, sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag)"
3HOMEPAGE = "http://openvswitch.org/"
4SECTION = "networking"
5LICENSE = "Apache-2"
6
7DEPENDS += "bridge-utils openssl python perl"
8
9RDEPENDS_${PN} += "util-linux-uuidgen util-linux-libuuid \
10 python perl perl-module-strict ${PN}-switch ${PN}-controller"
11RDEPENDS_${PN}-controller = "${PN} lsb ${PN}-pki"
12RDEPENDS_${PN}-switch = "${PN} openssl procps util-linux-uuidgen"
13RDEPENDS_${PN}-pki = "${PN}"
14RDEPENDS_${PN}-brcompat = "${PN} ${PN}-switch"
15RRECOMMENDS_${PN} += "kernel-module-openvswitch"
16
17PR = "r0"
18
19SRC_URI = "http://openvswitch.org/releases/openvswitch-${PV}.tar.gz \
20 file://openvswitch-switch \
21 file://openvswitch-switch-setup \
22 file://openvswitch-controller \
23 file://openvswitch-controller-setup \
24 "
25
26SRC_URI[md5sum] = "e9004202b0e10c0de9870f19d2044f11"
27SRC_URI[sha256sum] = "825730db82c7b46a142f057a43345590c299e66704ef7a88d9ed4ffd0c3d6b64"
28LIC_FILES_CHKSUM = "file://COPYING;md5=49eeb5acb1f5e510f12c44f176c42253"
29
30# Don't compile kernel modules by default since it heavily depends on
31# kernel version. Use the in-kernel module for now.
32# distro layers can enable with EXTRA_OECONF_pn_openvswitch += ""
33# EXTRA_OECONF = "--with-linux=${STAGING_KERNEL_DIR} KARCH=${TARGET_ARCH}"
34
35ALLOW_EMPTY_${PN}-pki = "1"
36PACKAGES =+ "${PN}-controller ${PN}-switch ${PN}-brcompat ${PN}-pki"
37
38FILES_${PN}-controller = "${sysconfdir}/init.d/openvswitch-controller \
39 ${sysconfdir}/default/openvswitch-controller \
40 ${sysconfdir}/openvswitch-controller \
41 ${bindir}/ovs-controller"
42
43FILES_${PN}-brcompat = "${sbindir}/ovs-brcompatd"
44
45FILES_${PN}-switch = "${sysconfdir}/init.d/openvswitch-switch \
46 ${sysconfdir}/default/openvswitch-switch \
47 "
48inherit autotools update-rc.d
49
50INITSCRIPT_PACKAGES = "${PN}-switch ${PN}-controller"
51INITSCRIPT_NAME_${PN}-switch = "openvswitch-switch"
52INITSCRIPT_PARAMS_${PN}-switch = "defaults 71"
53
54INITSCRIPT_NAME_${PN}-controller = "openvswitch-controller"
55INITSCRIPT_PARAMS_${PN}-controller = "defaults 72"
56
57do_install_append() {
58 install -d ${D}/${sysconfdir}/default/
59 install -m 660 ${WORKDIR}/openvswitch-switch-setup ${D}/${sysconfdir}/default/openvswitch-switch
60 install -d ${D}/${sysconfdir}/openvswitch-controller
61 install -m 660 ${WORKDIR}/openvswitch-controller-setup ${D}/${sysconfdir}/default/openvswitch-controller
62
63 install -d ${D}/${sysconfdir}/init.d/
64 install -m 755 ${WORKDIR}/openvswitch-controller ${D}/${sysconfdir}/init.d/openvswitch-controller
65 install -m 755 ${WORKDIR}/openvswitch-switch ${D}/${sysconfdir}/init.d/openvswitch-switch
66 true || rm -fr ${D}/${datadir}/${PN}/pki
67}
68
69pkg_postinst_${PN}-pki () {
70 # can't do this offline
71 if [ "x$D" != "x" ]; then
72 exit 1
73 fi
74 if test ! -d $D/${datadir}/${PN}/pki; then
75 ovs-pki init --dir=$D/${datadir}/${PN}/pki
76 fi
77}
78
79pkg_postinst_${PN}-controller () {
80 # can't do this offline
81 if [ "x$D" != "x" ]; then
82 exit 1
83 fi
84
85 cd $D/${sysconfdir}/openvswitch-controller
86 if ! test -e cacert.pem; then
87 ln -s $D/${datadir}/${PN}/pki/switchca/cacert.pem cacert.pem
88 fi
89 if ! test -e privkey.pem || ! test -e cert.pem; then
90 oldumask=$(umask)
91 umask 077
92 ovs-pki req+sign --dir=$D/${datadir}/${PN}/pki tmp controller >/dev/null
93 mv tmp-privkey.pem privkey.pem
94 mv tmp-cert.pem cert.pem
95 mv tmp-req.pem req.pem
96 chmod go+r cert.pem req.pem
97 umask $oldumask
98 fi
99}