summaryrefslogtreecommitdiffstats
path: root/recipes-networking
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-09-27 22:36:21 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-03-15 23:15:42 -0400
commit486cdac90e8668918f820968cda22e0adac82e73 (patch)
treebda87b9f771cc5ebc99a42633a2aeb64e7605db1 /recipes-networking
parent6cae8b8adf314bdba7bf8e1c4669657d588399aa (diff)
downloadmeta-virtualization-486cdac90e8668918f820968cda22e0adac82e73.tar.gz
k3s: import version locked ipset dependency
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-networking')
-rw-r--r--recipes-networking/ipset/ipset_6.38.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-networking/ipset/ipset_6.38.bb b/recipes-networking/ipset/ipset_6.38.bb
new file mode 100644
index 00000000..273531fe
--- /dev/null
+++ b/recipes-networking/ipset/ipset_6.38.bb
@@ -0,0 +1,20 @@
1# Copyright (C) 2017 Aaron Brice <aaron.brice@datasoft.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Administration tool for IP sets"
5HOMEPAGE = "http://ipset.netfilter.org"
6LICENSE = "GPL-2.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
8SECTION = "base"
9
10DEPENDS = "libtool libmnl"
11RDEPENDS_${PN} = "kernel-module-ip-set"
12
13SRC_URI = "http://ftp.netfilter.org/pub/ipset/${PN}-${PV}.tar.bz2"
14
15SRC_URI[md5sum] = "0e5d9c85f6b78e7dff0c996e2900574b"
16SRC_URI[sha256sum] = "ceef625ba31fe0aaa422926c7231a819de0b07644c02c17ebdd3022a29e3e244"
17
18inherit autotools pkgconfig module-base
19
20EXTRA_OECONF += "-with-kbuild=${KBUILD_OUTPUT} --with-ksource=${STAGING_KERNEL_DIR}"