summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch
diff options
context:
space:
mode:
authorHongzhi.Song <hongzhi.song@windriver.com>2019-01-30 02:46:52 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-02-03 03:49:55 +0000
commitf9acf9a26617fe3eb4aac5d648f488ad0023a6ff (patch)
tree5f87f6b50a0edfb7a52b8f3a3a9a9ef1a1f46166 /recipes-networking/openvswitch
parent274a72a5dba083f1f09ffedf19ac6e7838e20a41 (diff)
downloadmeta-virtualization-f9acf9a26617fe3eb4aac5d648f488ad0023a6ff.tar.gz
openvswitch: uprev from v2.10.1 to v2.11
The v2.11 version fixed a bug as follow. Error info: ovs|00002|db_ctl_base|ERR|external-ids:hostname=: argument does not end in "=" followed by a value. The result of ptest between v2.11 and v2.10.1 is similar. v2.11: ERROR: 2765 tests were run, 317 failed (1 expected failure). 85 tests were skipped. v2.10.1: ERROR: 2662 tests were run, 311 failed (1 expected failure). 85 tests were skipped. I checked the detailed result. The failed tests were mostly related to python2 as the image only use python3. Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-networking/openvswitch')
-rw-r--r--recipes-networking/openvswitch/files/python-make-remaining-scripts-use-usr-bin-env.patch33
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/kernel_module.patch25
-rw-r--r--recipes-networking/openvswitch/openvswitch_git.bb8
3 files changed, 35 insertions, 31 deletions
diff --git a/recipes-networking/openvswitch/files/python-make-remaining-scripts-use-usr-bin-env.patch b/recipes-networking/openvswitch/files/python-make-remaining-scripts-use-usr-bin-env.patch
index 0dc6b11b..53e3103a 100644
--- a/recipes-networking/openvswitch/files/python-make-remaining-scripts-use-usr-bin-env.patch
+++ b/recipes-networking/openvswitch/files/python-make-remaining-scripts-use-usr-bin-env.patch
@@ -1,6 +1,6 @@
1From a0a2d829642e916bd5d1c498a3e6f3641ed717a0 Mon Sep 17 00:00:00 2001 1From a348e0162343f7d46443eb1fd2bcf0698460a780 Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com> 2From: "Hongzhi.Song" <hongzhi.song@windriver.com>
3Date: Fri, 13 Jan 2017 16:12:55 -0500 3Date: Wed, 23 Jan 2019 04:28:28 -0500
4Subject: [PATCH] python: make remaining scripts use /usr/bin/env 4Subject: [PATCH] python: make remaining scripts use /usr/bin/env
5 5
6Unfortunately there is no concept of a host python vs. target python 6Unfortunately there is no concept of a host python vs. target python
@@ -12,6 +12,7 @@ PYTHON. To make this function smoothly all installed scripts should
12make use of /usr/bin/env to increase the chances of finding python. 12make use of /usr/bin/env to increase the chances of finding python.
13 13
14Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> 14Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
15Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com>
15--- 16---
16 build-aux/check-structs | 2 +- 17 build-aux/check-structs | 2 +-
17 build-aux/dpdkstrip.py | 2 +- 18 build-aux/dpdkstrip.py | 2 +-
@@ -68,17 +69,17 @@ index 48c7f06..b8b8ba9 100755
68 # 69 #
69 # Licensed under the Apache License, Version 2.0 (the "License"); 70 # Licensed under the Apache License, Version 2.0 (the "License");
70diff --git a/build-aux/extract-ofp-actions b/build-aux/extract-ofp-actions 71diff --git a/build-aux/extract-ofp-actions b/build-aux/extract-ofp-actions
71index bd7131f..4d05ef9 100755 72index 64de0f3..f6bca0b 100755
72--- a/build-aux/extract-ofp-actions 73--- a/build-aux/extract-ofp-actions
73+++ b/build-aux/extract-ofp-actions 74+++ b/build-aux/extract-ofp-actions
74@@ -1,4 +1,4 @@ 75@@ -1,4 +1,4 @@
75-#! /usr/bin/python 76-#! /usr/bin/python
76+#! /usr/bin/env python3 77+#! /usr/bin/env python3
77 78
79 import getopt
78 import sys 80 import sys
79 import os.path
80diff --git a/build-aux/extract-ofp-errors b/build-aux/extract-ofp-errors 81diff --git a/build-aux/extract-ofp-errors b/build-aux/extract-ofp-errors
81index 71ae0bd..58ba006 100755 82index 6f64efd..c410fd4 100755
82--- a/build-aux/extract-ofp-errors 83--- a/build-aux/extract-ofp-errors
83+++ b/build-aux/extract-ofp-errors 84+++ b/build-aux/extract-ofp-errors
84@@ -1,4 +1,4 @@ 85@@ -1,4 +1,4 @@
@@ -88,7 +89,7 @@ index 71ae0bd..58ba006 100755
88 import sys 89 import sys
89 import os.path 90 import os.path
90diff --git a/build-aux/extract-ofp-fields b/build-aux/extract-ofp-fields 91diff --git a/build-aux/extract-ofp-fields b/build-aux/extract-ofp-fields
91index 184b75e..cf339f8 100755 92index 3592594..2fc8317 100755
92--- a/build-aux/extract-ofp-fields 93--- a/build-aux/extract-ofp-fields
93+++ b/build-aux/extract-ofp-fields 94+++ b/build-aux/extract-ofp-fields
94@@ -1,4 +1,4 @@ 95@@ -1,4 +1,4 @@
@@ -148,7 +149,7 @@ index bd4e879..db45c56 100755
148 # Copyright (c) 2010, 2011, 2012, 2013, 2014, 2015, 2016 Nicira, Inc. 149 # Copyright (c) 2010, 2011, 2012, 2013, 2014, 2015, 2016 Nicira, Inc.
149 # 150 #
150diff --git a/ovn/utilities/ovn-detrace.in b/ovn/utilities/ovn-detrace.in 151diff --git a/ovn/utilities/ovn-detrace.in b/ovn/utilities/ovn-detrace.in
151index e2e5b4c..5549219 100755 152index c842adc..9e95183 100755
152--- a/ovn/utilities/ovn-detrace.in 153--- a/ovn/utilities/ovn-detrace.in
153+++ b/ovn/utilities/ovn-detrace.in 154+++ b/ovn/utilities/ovn-detrace.in
154@@ -1,4 +1,4 @@ 155@@ -1,4 +1,4 @@
@@ -208,7 +209,7 @@ index 8eea617..38ba33a 100755
208 from datetime import date 209 from datetime import date
209 import ovs.db.error 210 import ovs.db.error
210diff --git a/ovsdb/ovsdb-idlc.in b/ovsdb/ovsdb-idlc.in 211diff --git a/ovsdb/ovsdb-idlc.in b/ovsdb/ovsdb-idlc.in
211index 1ea2115..4ecb2e2 100755 212index 40fef39..84c63a6 100755
212--- a/ovsdb/ovsdb-idlc.in 213--- a/ovsdb/ovsdb-idlc.in
213+++ b/ovsdb/ovsdb-idlc.in 214+++ b/ovsdb/ovsdb-idlc.in
214@@ -1,4 +1,4 @@ 215@@ -1,4 +1,4 @@
@@ -228,7 +229,7 @@ index b8027af..8f52803 100755
228 # Copyright (c) 2008, 2017 Nicira, Inc. 229 # Copyright (c) 2008, 2017 Nicira, Inc.
229 # 230 #
230diff --git a/tests/flowgen.py b/tests/flowgen.py 231diff --git a/tests/flowgen.py b/tests/flowgen.py
231index 221a8f2..5d96d76 100755 232index 976fe7a..7ef32d1 100755
232--- a/tests/flowgen.py 233--- a/tests/flowgen.py
233+++ b/tests/flowgen.py 234+++ b/tests/flowgen.py
234@@ -1,4 +1,4 @@ 235@@ -1,4 +1,4 @@
@@ -258,7 +259,7 @@ index ea72812..f1a9aff 100755
258 import re 259 import re
259 import sys 260 import sys
260diff --git a/utilities/bugtool/ovs-bugtool.in b/utilities/bugtool/ovs-bugtool.in 261diff --git a/utilities/bugtool/ovs-bugtool.in b/utilities/bugtool/ovs-bugtool.in
261index 8d220fd..76cedf4 100755 262index 288c34f..b5a6906 100755
262--- a/utilities/bugtool/ovs-bugtool.in 263--- a/utilities/bugtool/ovs-bugtool.in
263+++ b/utilities/bugtool/ovs-bugtool.in 264+++ b/utilities/bugtool/ovs-bugtool.in
264@@ -1,4 +1,4 @@ 265@@ -1,4 +1,4 @@
@@ -308,7 +309,7 @@ index 350cbd9..1960fb4 100755
308 # Copyright (c) 2012 Nicira, Inc. 309 # Copyright (c) 2012 Nicira, Inc.
309 # 310 #
310diff --git a/utilities/ovs-pcap.in b/utilities/ovs-pcap.in 311diff --git a/utilities/ovs-pcap.in b/utilities/ovs-pcap.in
311index fc15321..bd55a41 100755 312index 7bebc07..b4e5ca8 100755
312--- a/utilities/ovs-pcap.in 313--- a/utilities/ovs-pcap.in
313+++ b/utilities/ovs-pcap.in 314+++ b/utilities/ovs-pcap.in
314@@ -1,4 +1,4 @@ 315@@ -1,4 +1,4 @@
@@ -318,7 +319,7 @@ index fc15321..bd55a41 100755
318 # Copyright (c) 2010 Nicira, Inc. 319 # Copyright (c) 2010 Nicira, Inc.
319 # 320 #
320diff --git a/utilities/ovs-tcpdump.in b/utilities/ovs-tcpdump.in 321diff --git a/utilities/ovs-tcpdump.in b/utilities/ovs-tcpdump.in
321index 91fa14e..bad67b7 100755 322index 22f249f..ff2a51e 100755
322--- a/utilities/ovs-tcpdump.in 323--- a/utilities/ovs-tcpdump.in
323+++ b/utilities/ovs-tcpdump.in 324+++ b/utilities/ovs-tcpdump.in
324@@ -1,4 +1,4 @@ 325@@ -1,4 +1,4 @@
@@ -328,7 +329,7 @@ index 91fa14e..bad67b7 100755
328 # Copyright (c) 2016 Red Hat, Inc. 329 # Copyright (c) 2016 Red Hat, Inc.
329 # 330 #
330diff --git a/utilities/ovs-tcpundump.in b/utilities/ovs-tcpundump.in 331diff --git a/utilities/ovs-tcpundump.in b/utilities/ovs-tcpundump.in
331index c99015b..9a617ce 100755 332index c298700..0d8b8da 100755
332--- a/utilities/ovs-tcpundump.in 333--- a/utilities/ovs-tcpundump.in
333+++ b/utilities/ovs-tcpundump.in 334+++ b/utilities/ovs-tcpundump.in
334@@ -1,4 +1,4 @@ 335@@ -1,4 +1,4 @@
@@ -358,7 +359,7 @@ index e229498..5b70118 100755
358 # Copyright (c) 2010 Nicira, Inc. 359 # Copyright (c) 2010 Nicira, Inc.
359 # 360 #
360diff --git a/vtep/ovs-vtep.in b/vtep/ovs-vtep.in 361diff --git a/vtep/ovs-vtep.in b/vtep/ovs-vtep.in
361index 98748e4..3f12ae2 100755 362index 3383870..42f98db 100755
362--- a/vtep/ovs-vtep.in 363--- a/vtep/ovs-vtep.in
363+++ b/vtep/ovs-vtep.in 364+++ b/vtep/ovs-vtep.in
364@@ -1,4 +1,4 @@ 365@@ -1,4 +1,4 @@
@@ -368,5 +369,5 @@ index 98748e4..3f12ae2 100755
368 # 369 #
369 # Licensed under the Apache License, Version 2.0 (the "License"); 370 # Licensed under the Apache License, Version 2.0 (the "License");
370-- 371--
3712.7.4 3722.8.1
372 373
diff --git a/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch b/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch
index c177202f..5e5a38d9 100644
--- a/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch
+++ b/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch
@@ -1,26 +1,29 @@
1From adfd2380d71dff1a31efaf63cf7ac97470466ec9 Mon Sep 17 00:00:00 2001 1From 9b7fb1346702d59af67435487254ef35940bc16a Mon Sep 17 00:00:00 2001
2From: Amy Fong <amy.fong@windriver.com> 2From: "Hongzhi.Song" <hongzhi.song@windriver.com>
3Date: Thu, 29 Jan 2015 09:56:03 -0500 3Date: Wed, 23 Jan 2019 03:41:30 -0500
4Subject: [PATCH] Specify install path for kernel module 4Subject: [PATCH] datapatch/linux: Specify install path for kernel module
5 5
6Signed-off-by: Amy Fong <amy.fong@windriver.com> 6Signed-off-by: Amy Fong <amy.fong@windriver.com>
7 7Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com>
8--- 8---
9 datapath/linux/Makefile.main.in | 4 ++-- 9 datapath/linux/Makefile.main.in | 4 ++--
10 1 file changed, 2 insertions(+), 2 deletions(-) 10 1 file changed, 2 insertions(+), 2 deletions(-)
11 11
12diff --git a/datapath/linux/Makefile.main.in b/datapath/linux/Makefile.main.in 12diff --git a/datapath/linux/Makefile.main.in b/datapath/linux/Makefile.main.in
13index 7d18253..63c520f 100644 13index 328bbfb..6dcc8d0 100644
14--- a/datapath/linux/Makefile.main.in 14--- a/datapath/linux/Makefile.main.in
15+++ b/datapath/linux/Makefile.main.in 15+++ b/datapath/linux/Makefile.main.in
16@@ -71,8 +71,8 @@ default: 16@@ -71,8 +71,8 @@ default:
17 $(MAKE) -C $(KSRC) M=$(builddir) modules 17 $(MAKE) -C $(KSRC) $(if @KARCH@,ARCH=@KARCH@) M=$(builddir) modules
18 18
19 modules_install: 19 modules_install:
20- $(MAKE) -C $(KSRC) M=$(builddir) modules_install 20- $(MAKE) -C $(KSRC) $(if @KARCH@,ARCH=@KARCH@) M=$(builddir) modules_install
21- depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h` 21- /sbin/depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h`
22+ $(MAKE) -C $(KSRC) M=$(builddir) modules_install INSTALL_MOD_PATH=${INSTALL_MOD_PATH} 22+ $(MAKE) -C $(KSRC) $(if @KARCH@,ARCH=@KARCH@) M=$(builddir) modules_install INSTALL_MOD_PATH=${INSTALL_MOD_PATH}
23+ # depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h` 23+ #/sbin/depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h`
24 endif 24 endif
25 25
26 # Much of the kernel build system in this file is derived from Intel's 26 # Much of the kernel build system in this file is derived from Intel's
27--
282.8.1
29
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index 81a66a94..072d7f14 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -14,17 +14,17 @@ RDEPENDS_${PN}-ptest += "\
14 " 14 "
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17PV = "2.10.1+${SRCPV}" 17PV = "2.11+${SRCPV}"
18 18
19FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:" 19FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:"
20 20
21SRCREV = "78e203138cb7253e9ca5ad8a2c4ed6bb6752f23e" 21SRCREV = "f22ca8011fdb7e81ffce5017cd26539bccf50e94"
22SRC_URI = "file://openvswitch-switch \ 22SRC_URI = "file://openvswitch-switch \
23 file://openvswitch-switch-setup \ 23 file://openvswitch-switch-setup \
24 file://openvswitch-testcontroller \ 24 file://openvswitch-testcontroller \
25 file://openvswitch-testcontroller-setup \ 25 file://openvswitch-testcontroller-setup \
26 git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.10 \ 26 git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.11 \
27 file://openvswitch-add-ptest-${SRCREV}.patch \ 27 file://openvswitch-add-ptest-78e203138cb7253e9ca5ad8a2c4ed6bb6752f23e.patch \
28 file://run-ptest \ 28 file://run-ptest \
29 file://disable_m4_check.patch \ 29 file://disable_m4_check.patch \
30 file://kernel_module.patch \ 30 file://kernel_module.patch \