summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch
diff options
context:
space:
mode:
authorXiangyu Chen <xiangyu.chen@windriver.com>2023-07-21 17:04:32 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-07-25 14:57:32 -0400
commitc5079557091b215663458807a8f617752614a6bd (patch)
tree48350439701d0ed9ab5615d3d4ed71486b869d0d /recipes-networking/openvswitch
parentfcf7968f1dd9e13e68323995573580e161d44ef3 (diff)
downloadmeta-virtualization-c5079557091b215663458807a8f617752614a6bd.tar.gz
ovs: fix some installed packages in openvswitch cannot be executed
The variable "PYTHON3" in Makefile.am set as python3, this cause the following scripts error: /usr/sbin/ovs-bugtool Not found the interpreter python3 /usr/bin/ovs-pcap Not found the interpreter python3 /usr/bin/ovs-test Not found the interpreter python3 /usr/bin/ovs-tcpdump Not found the interpreter python3 /usr/bin/ovs-tcpundump Not found the interpreter python3 /usr/bin/ovs-vlan-test Not found the interpreter python3 /usr/bin/ovs-l3ping Not found the interpreter python3 /usr/bin/ovs-parse-backtrace Not found the interpreter python3 /usr/bin/ovs-dpctl-top Not found the interpreter python3 /usr/share/openvswitch/scripts/ovs-check-dead-ifs Not found the interpreter python3 /usr/share/openvswitch/scripts/ovs-check-dead-ifs Not found the interpreter python3 /usr/share/openvswitch/scripts/ovs-monitor-ipsec Not found the interpreter python3 /usr/share/openvswitch/scripts/ovs-vtep Not found the interpreter python3 Signed-off-by: Xiangyu Chen <xiangyu.chen@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-networking/openvswitch')
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/Makefile.am-set-the-python3-interpreter-with-usr-bin.patch43
-rw-r--r--recipes-networking/openvswitch/openvswitch_git.bb1
2 files changed, 44 insertions, 0 deletions
diff --git a/recipes-networking/openvswitch/openvswitch-git/Makefile.am-set-the-python3-interpreter-with-usr-bin.patch b/recipes-networking/openvswitch/openvswitch-git/Makefile.am-set-the-python3-interpreter-with-usr-bin.patch
new file mode 100644
index 00000000..472ecb57
--- /dev/null
+++ b/recipes-networking/openvswitch/openvswitch-git/Makefile.am-set-the-python3-interpreter-with-usr-bin.patch
@@ -0,0 +1,43 @@
1From 5053d98f6595653dc02485810fda94348b6e8a1b Mon Sep 17 00:00:00 2001
2From: Xiangyu Chen <xiangyu.chen@windriver.com>
3Date: Fri, 21 Jul 2023 08:47:51 +0000
4Subject: [PATCH] Makefile.am: set the python3 interpreter with /usr/bin/env
5
6The variable "PYTHON3" just python3, this cause the following scripts error:
7/usr/sbin/ovs-bugtool Not found the interpreter python3
8/usr/bin/ovs-pcap Not found the interpreter python3
9/usr/bin/ovs-test Not found the interpreter python3
10/usr/bin/ovs-tcpdump Not found the interpreter python3
11/usr/bin/ovs-tcpundump Not found the interpreter python3
12/usr/bin/ovs-vlan-test Not found the interpreter python3
13/usr/bin/ovs-l3ping Not found the interpreter python3
14/usr/bin/ovs-parse-backtrace Not found the interpreter python3
15/usr/bin/ovs-dpctl-top Not found the interpreter python3
16/usr/share/openvswitch/scripts/ovs-check-dead-ifs Not found the interpreter python3
17/usr/share/openvswitch/scripts/ovs-check-dead-ifs Not found the interpreter python3
18/usr/share/openvswitch/scripts/ovs-monitor-ipsec Not found the interpreter python3
19/usr/share/openvswitch/scripts/ovs-vtep Not found the interpreter python3
20
21Upstream-Status: Inappropriate [embedded specific]
22
23Signed-off-by: Xiangyu Chen <xiangyu.chen@windriver.com>
24---
25 Makefile.am | 2 +-
26 1 file changed, 1 insertion(+), 1 deletion(-)
27
28diff --git a/Makefile.am b/Makefile.am
29index 28e85d422..031bbf39c 100644
30--- a/Makefile.am
31+++ b/Makefile.am
32@@ -154,7 +154,7 @@ SUFFIXES += .in
33 -e 's,[@]PKIDIR[@],$(PKIDIR),g' \
34 -e 's,[@]LOGDIR[@],$(LOGDIR),g' \
35 -e 's,[@]DBDIR[@],$(DBDIR),g' \
36- -e 's,[@]PYTHON3[@],$(PYTHON3),g' \
37+ -e 's,[@]PYTHON3[@],/usr/bin/env $(PYTHON3),g' \
38 -e 's,[@]RUNDIR[@],$(RUNDIR),g' \
39 -e 's,[@]VERSION[@],$(VERSION),g' \
40 -e 's,[@]localstatedir[@],$(localstatedir),g' \
41--
422.35.5
43
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index 842ac11b..9d3101a5 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -26,6 +26,7 @@ SRC_URI += "git://github.com/openvswitch/ovs.git;protocol=https;branch=branch-3.
26 file://disable_m4_check.patch \ 26 file://disable_m4_check.patch \
27 file://systemd-update-tool-paths.patch \ 27 file://systemd-update-tool-paths.patch \
28 file://systemd-create-runtime-dirs.patch \ 28 file://systemd-create-runtime-dirs.patch \
29 file://Makefile.am-set-the-python3-interpreter-with-usr-bin.patch \
29 " 30 "
30 31
31LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab" 32LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"