summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2017-08-04 11:01:00 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-08-03 23:47:49 -0400
commitbca5037e5d3d532df7b6eb54b939d6e81d58d6a1 (patch)
tree4e001ec29fdc9c0002b6336f79c2d016189d413b /recipes-networking/openvswitch
parent4eee02bd6405557c664f91b6079c2f203d48c545 (diff)
downloadmeta-virtualization-bca5037e5d3d532df7b6eb54b939d6e81d58d6a1.tar.gz
openvswitch: fix dpdk PACKAGECONFIG
Add dpdk as a runtime dependency when 'dpdk' PACKAGECONFIG is enabled. Also, introduce a variable DPDK_INSTALL_DIR, and default it to /opt/dpdk. This is because users might install DPDK into different locations, e.g. /usr. And it would easy for users to override this variable to make openvswitch build with dpdk correctly. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking/openvswitch')
-rw-r--r--recipes-networking/openvswitch/openvswitch_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index a3c586b7..35f4ba8b 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -48,8 +48,10 @@ SRC_URI += " \
48 48
49LIC_FILES_CHKSUM = "file://COPYING;md5=17b2c9d4c70853a09c0e143137754b35" 49LIC_FILES_CHKSUM = "file://COPYING;md5=17b2c9d4c70853a09c0e143137754b35"
50 50
51DPDK_INSTALL_DIR ?= "/opt/dpdk"
52
51PACKAGECONFIG ?= "" 53PACKAGECONFIG ?= ""
52PACKAGECONFIG[dpdk] = "--with-dpdk=${STAGING_DIR_TARGET}/opt/dpdk/${TARGET_ARCH}-native-linuxapp-gcc,,dpdk," 54PACKAGECONFIG[dpdk] = "--with-dpdk=${STAGING_DIR_TARGET}${DPDK_INSTALL_DIR}/share/${TARGET_ARCH}-native-linuxapp-gcc,,dpdk,dpdk"
53 55
54# Don't compile kernel modules by default since it heavily depends on 56# Don't compile kernel modules by default since it heavily depends on
55# kernel version. Use the in-kernel module for now. 57# kernel version. Use the in-kernel module for now.