summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2020-02-19 20:07:44 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-02-20 12:43:14 -0500
commitb1b4fca4f04ba878d7c70c18817deb42eab3b712 (patch)
tree623922ad8aeb7fe5c37e0663460397d905604505 /recipes-networking/openvswitch
parentcac0cdf86d46f7acfba8e6c3931ed72895c056f7 (diff)
downloadmeta-virtualization-b1b4fca4f04ba878d7c70c18817deb42eab3b712.tar.gz
openvswitch: uprev from v2.12 to v2.13
Another straightforward uprev with one fairly large change in the changelog. The Open Virtual Network component has now been moved to its own repo (https://github.com/ovn-org/ovn.git). If you were using this functionality a new recipe will need to be created. The ptest results are similar to after the v2.12 uprev ERROR: 2206 tests were run, 28 failed unexpectedly. 62 tests were skipped. The failed tests were in the following areas: checkpatch.at (5) ovs-ofctl.at (1) tunnel.at(1) tunnel-push-pop.at(3) tunnel-push-pop-ipv6.at(3) dpif-netdev.at (1) pmd.at(1) ofproto-dpif.at (7) bridge.at (2) ovsdb-idl.at(1) mcast-snooping.at(1) packet-type-aware.at(2) None of these affect core functionality or usecases and are similar to the results we see with v1.12. If specific usecases are affected by these failures we should address them on a need to fix basis. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-networking/openvswitch')
-rw-r--r--recipes-networking/openvswitch/files/python-make-remaining-scripts-use-usr-bin-env.patch373
-rw-r--r--recipes-networking/openvswitch/files/python-switch-remaining-scripts-to-use-python3.patch13
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/0002-Define-WAIT_ANY-if-not-provided-by-system.patch29
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch (renamed from recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-6beb94976e2b3e0c51430b63214de14186d8db39.patch)0
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/ovsdb-idlc.in-fix-dict-change-during-iteration.patch45
-rw-r--r--recipes-networking/openvswitch/openvswitch_git.bb13
6 files changed, 6 insertions, 467 deletions
diff --git a/recipes-networking/openvswitch/files/python-make-remaining-scripts-use-usr-bin-env.patch b/recipes-networking/openvswitch/files/python-make-remaining-scripts-use-usr-bin-env.patch
deleted file mode 100644
index 53e3103a..00000000
--- a/recipes-networking/openvswitch/files/python-make-remaining-scripts-use-usr-bin-env.patch
+++ /dev/null
@@ -1,373 +0,0 @@
1From a348e0162343f7d46443eb1fd2bcf0698460a780 Mon Sep 17 00:00:00 2001
2From: "Hongzhi.Song" <hongzhi.song@windriver.com>
3Date: Wed, 23 Jan 2019 04:28:28 -0500
4Subject: [PATCH] python: make remaining scripts use /usr/bin/env
5
6Unfortunately there is no concept of a host python vs. target python
7to facilitate cross compilation. There is only one PYTHON variable and
8this is used during building and in the header of python scripts after
9installation. The best approach for cross compilation is to thus to
10ensure python is in the path and avoid passing a path as part of
11PYTHON. To make this function smoothly all installed scripts should
12make use of /usr/bin/env to increase the chances of finding python.
13
14Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
15Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com>
16---
17 build-aux/check-structs | 2 +-
18 build-aux/dpdkstrip.py | 2 +-
19 build-aux/extract-ofp-actions | 2 +-
20 build-aux/extract-ofp-errors | 2 +-
21 build-aux/extract-ofp-fields | 2 +-
22 build-aux/extract-ofp-msgs | 2 +-
23 build-aux/sodepends.py | 2 +-
24 build-aux/soexpand.py | 2 +-
25 build-aux/text2c | 2 +-
26 build-aux/xml2nroff | 2 +-
27 ovn/utilities/ovn-detrace.in | 2 +-
28 ovn/utilities/ovn-docker-overlay-driver.in | 2 +-
29 ovn/utilities/ovn-docker-underlay-driver.in | 2 +-
30 ovsdb/dot2pic | 2 +-
31 ovsdb/ovsdb-doc | 2 +-
32 ovsdb/ovsdb-dot.in | 2 +-
33 ovsdb/ovsdb-idlc.in | 2 +-
34 python/build/soutil.py | 2 +-
35 tests/flowgen.py | 2 +-
36 tests/ovsdb-monitor-sort.py | 2 +-
37 tests/uuidfilt.py | 2 +-
38 utilities/bugtool/ovs-bugtool.in | 2 +-
39 utilities/ovs-check-dead-ifs.in | 2 +-
40 utilities/ovs-dpctl-top.in | 2 +-
41 utilities/ovs-l3ping.in | 2 +-
42 utilities/ovs-parse-backtrace.in | 2 +-
43 utilities/ovs-pcap.in | 2 +-
44 utilities/ovs-tcpdump.in | 2 +-
45 utilities/ovs-tcpundump.in | 2 +-
46 utilities/ovs-test.in | 2 +-
47 utilities/ovs-vlan-test.in | 2 +-
48 vtep/ovs-vtep.in | 2 +-
49 32 files changed, 32 insertions(+), 32 deletions(-)
50
51diff --git a/build-aux/check-structs b/build-aux/check-structs
52index 37ffa06..eb44c91 100755
53--- a/build-aux/check-structs
54+++ b/build-aux/check-structs
55@@ -1,4 +1,4 @@
56-#! /usr/bin/python
57+#! /usr/bin/env python3
58
59 import os.path
60 import sys
61diff --git a/build-aux/dpdkstrip.py b/build-aux/dpdkstrip.py
62index 48c7f06..b8b8ba9 100755
63--- a/build-aux/dpdkstrip.py
64+++ b/build-aux/dpdkstrip.py
65@@ -1,4 +1,4 @@
66-#! /usr/bin/env python
67+#! /usr/bin/env python3
68 # Copyright (c) 2017 Red Hat, Inc.
69 #
70 # Licensed under the Apache License, Version 2.0 (the "License");
71diff --git a/build-aux/extract-ofp-actions b/build-aux/extract-ofp-actions
72index 64de0f3..f6bca0b 100755
73--- a/build-aux/extract-ofp-actions
74+++ b/build-aux/extract-ofp-actions
75@@ -1,4 +1,4 @@
76-#! /usr/bin/python
77+#! /usr/bin/env python3
78
79 import getopt
80 import sys
81diff --git a/build-aux/extract-ofp-errors b/build-aux/extract-ofp-errors
82index 6f64efd..c410fd4 100755
83--- a/build-aux/extract-ofp-errors
84+++ b/build-aux/extract-ofp-errors
85@@ -1,4 +1,4 @@
86-#! /usr/bin/python
87+#! /usr/bin/env python3
88
89 import sys
90 import os.path
91diff --git a/build-aux/extract-ofp-fields b/build-aux/extract-ofp-fields
92index 3592594..2fc8317 100755
93--- a/build-aux/extract-ofp-fields
94+++ b/build-aux/extract-ofp-fields
95@@ -1,4 +1,4 @@
96-#! /usr/bin/python
97+#! /usr/bin/env python3
98
99 import getopt
100 import sys
101diff --git a/build-aux/extract-ofp-msgs b/build-aux/extract-ofp-msgs
102index a67e870..92c4bda 100755
103--- a/build-aux/extract-ofp-msgs
104+++ b/build-aux/extract-ofp-msgs
105@@ -1,4 +1,4 @@
106-#! /usr/bin/python
107+#! /usr/bin/env python3
108
109 import sys
110 import os.path
111diff --git a/build-aux/sodepends.py b/build-aux/sodepends.py
112index 90cfaa0..45812bc 100755
113--- a/build-aux/sodepends.py
114+++ b/build-aux/sodepends.py
115@@ -1,4 +1,4 @@
116-#! /usr/bin/env python
117+#! /usr/bin/env python3
118
119 # Copyright (c) 2008, 2011, 2017 Nicira, Inc.
120 #
121diff --git a/build-aux/soexpand.py b/build-aux/soexpand.py
122index 53ca640..00adcf4 100755
123--- a/build-aux/soexpand.py
124+++ b/build-aux/soexpand.py
125@@ -1,4 +1,4 @@
126-#! /usr/bin/env python
127+#! /usr/bin/env python3
128
129 # Copyright (c) 2008, 2017 Nicira, Inc.
130 #
131diff --git a/build-aux/text2c b/build-aux/text2c
132index cb1f256..ab7910e 100755
133--- a/build-aux/text2c
134+++ b/build-aux/text2c
135@@ -1,4 +1,4 @@
136-#! /usr/bin/python
137+#! /usr/bin/env python3
138
139 import re
140 import sys
141diff --git a/build-aux/xml2nroff b/build-aux/xml2nroff
142index bd4e879..db45c56 100755
143--- a/build-aux/xml2nroff
144+++ b/build-aux/xml2nroff
145@@ -1,4 +1,4 @@
146-#! /usr/bin/python
147+#! /usr/bin/env python3
148
149 # Copyright (c) 2010, 2011, 2012, 2013, 2014, 2015, 2016 Nicira, Inc.
150 #
151diff --git a/ovn/utilities/ovn-detrace.in b/ovn/utilities/ovn-detrace.in
152index c842adc..9e95183 100755
153--- a/ovn/utilities/ovn-detrace.in
154+++ b/ovn/utilities/ovn-detrace.in
155@@ -1,4 +1,4 @@
156-#! @PYTHON@
157+#!/usr/bin/env @PYTHON@
158 #
159 # Copyright (c) 2017 eBay Inc.
160 #
161diff --git a/ovn/utilities/ovn-docker-overlay-driver.in b/ovn/utilities/ovn-docker-overlay-driver.in
162index 65edfcd..895426b 100755
163--- a/ovn/utilities/ovn-docker-overlay-driver.in
164+++ b/ovn/utilities/ovn-docker-overlay-driver.in
165@@ -1,4 +1,4 @@
166-#! @PYTHON@
167+#!/usr/bin/env @PYTHON@
168 # Copyright (C) 2015 Nicira, Inc.
169 #
170 # Licensed under the Apache License, Version 2.0 (the "License");
171diff --git a/ovn/utilities/ovn-docker-underlay-driver.in b/ovn/utilities/ovn-docker-underlay-driver.in
172index d91ce9f..e0c8db6 100755
173--- a/ovn/utilities/ovn-docker-underlay-driver.in
174+++ b/ovn/utilities/ovn-docker-underlay-driver.in
175@@ -1,4 +1,4 @@
176-#! @PYTHON@
177+#!/usr/bin/env @PYTHON@
178 # Copyright (C) 2015 Nicira, Inc.
179 #
180 # Licensed under the Apache License, Version 2.0 (the "License");
181diff --git a/ovsdb/dot2pic b/ovsdb/dot2pic
182index de67261..174e723 100755
183--- a/ovsdb/dot2pic
184+++ b/ovsdb/dot2pic
185@@ -1,4 +1,4 @@
186-#! /usr/bin/env python
187+#! /usr/bin/env python3
188
189 # Copyright (c) 2009, 2010, 2011, 2013, 2017 Nicira, Inc.
190 #
191diff --git a/ovsdb/ovsdb-doc b/ovsdb/ovsdb-doc
192index 406c293..d55c6e6 100755
193--- a/ovsdb/ovsdb-doc
194+++ b/ovsdb/ovsdb-doc
195@@ -1,4 +1,4 @@
196-#! /usr/bin/python
197+#! /usr/bin/env python3
198
199 # Copyright (c) 2010, 2011, 2012, 2013, 2014, 2015 Nicira, Inc.
200 #
201diff --git a/ovsdb/ovsdb-dot.in b/ovsdb/ovsdb-dot.in
202index 8eea617..38ba33a 100755
203--- a/ovsdb/ovsdb-dot.in
204+++ b/ovsdb/ovsdb-dot.in
205@@ -1,4 +1,4 @@
206-#! @PYTHON@
207+#! /usr/bin/env @PYTHON@
208
209 from datetime import date
210 import ovs.db.error
211diff --git a/ovsdb/ovsdb-idlc.in b/ovsdb/ovsdb-idlc.in
212index 40fef39..84c63a6 100755
213--- a/ovsdb/ovsdb-idlc.in
214+++ b/ovsdb/ovsdb-idlc.in
215@@ -1,4 +1,4 @@
216-#! @PYTHON@
217+#!/usr/bin/env @PYTHON@
218
219 from __future__ import print_function
220 import getopt
221diff --git a/python/build/soutil.py b/python/build/soutil.py
222index b8027af..8f52803 100755
223--- a/python/build/soutil.py
224+++ b/python/build/soutil.py
225@@ -1,4 +1,4 @@
226-#! /usr/bin/env python
227+#! /usr/bin/env python3
228
229 # Copyright (c) 2008, 2017 Nicira, Inc.
230 #
231diff --git a/tests/flowgen.py b/tests/flowgen.py
232index 976fe7a..7ef32d1 100755
233--- a/tests/flowgen.py
234+++ b/tests/flowgen.py
235@@ -1,4 +1,4 @@
236-#! /usr/bin/env python
237+#! /usr/bin/env python3
238
239 # Copyright (c) 2009, 2010, 2011, 2012, 2015, 2017 Nicira, Inc.
240 #
241diff --git a/tests/ovsdb-monitor-sort.py b/tests/ovsdb-monitor-sort.py
242index 7d368a7..ab4c38c 100755
243--- a/tests/ovsdb-monitor-sort.py
244+++ b/tests/ovsdb-monitor-sort.py
245@@ -1,4 +1,4 @@
246-#! /usr/bin/env python
247+#! /usr/bin/env python3
248
249 # Breaks lines read from stdin into groups using blank lines as
250 # group separators, then sorts lines within the groups for
251diff --git a/tests/uuidfilt.py b/tests/uuidfilt.py
252index ea72812..f1a9aff 100755
253--- a/tests/uuidfilt.py
254+++ b/tests/uuidfilt.py
255@@ -1,4 +1,4 @@
256-#!/usr/bin/env python
257+#!/usr/bin/env python3
258
259 import re
260 import sys
261diff --git a/utilities/bugtool/ovs-bugtool.in b/utilities/bugtool/ovs-bugtool.in
262index 288c34f..b5a6906 100755
263--- a/utilities/bugtool/ovs-bugtool.in
264+++ b/utilities/bugtool/ovs-bugtool.in
265@@ -1,4 +1,4 @@
266-#! @PYTHON@
267+#! /usr/bin/env @PYTHON@
268
269 # This library is free software; you can redistribute it and/or
270 # modify it under the terms of version 2.1 of the GNU Lesser General Public
271diff --git a/utilities/ovs-check-dead-ifs.in b/utilities/ovs-check-dead-ifs.in
272index ac54f6c..13d86b3 100755
273--- a/utilities/ovs-check-dead-ifs.in
274+++ b/utilities/ovs-check-dead-ifs.in
275@@ -1,4 +1,4 @@
276-#! @PYTHON@
277+#!/usr/bin/env @PYTHON@
278
279 import os
280 import re
281diff --git a/utilities/ovs-dpctl-top.in b/utilities/ovs-dpctl-top.in
282index 7f0f1f8..ece707a 100755
283--- a/utilities/ovs-dpctl-top.in
284+++ b/utilities/ovs-dpctl-top.in
285@@ -1,4 +1,4 @@
286-#! @PYTHON@
287+#!/usr/bin/env @PYTHON@
288 #
289 # Copyright (c) 2013 Nicira, Inc.
290 #
291diff --git a/utilities/ovs-l3ping.in b/utilities/ovs-l3ping.in
292index 1b07972..9852699 100644
293--- a/utilities/ovs-l3ping.in
294+++ b/utilities/ovs-l3ping.in
295@@ -1,4 +1,4 @@
296-#! @PYTHON@
297+#!/usr/bin/env @PYTHON@
298 #
299 # Licensed under the Apache License, Version 2.0 (the "License");
300 # you may not use this file except in compliance with the License.
301diff --git a/utilities/ovs-parse-backtrace.in b/utilities/ovs-parse-backtrace.in
302index 350cbd9..1960fb4 100755
303--- a/utilities/ovs-parse-backtrace.in
304+++ b/utilities/ovs-parse-backtrace.in
305@@ -1,4 +1,4 @@
306-#! @PYTHON@
307+#!/usr/bin/env @PYTHON@
308 #
309 # Copyright (c) 2012 Nicira, Inc.
310 #
311diff --git a/utilities/ovs-pcap.in b/utilities/ovs-pcap.in
312index 7bebc07..b4e5ca8 100755
313--- a/utilities/ovs-pcap.in
314+++ b/utilities/ovs-pcap.in
315@@ -1,4 +1,4 @@
316-#! @PYTHON@
317+#!/usr/bin/env @PYTHON@
318 #
319 # Copyright (c) 2010 Nicira, Inc.
320 #
321diff --git a/utilities/ovs-tcpdump.in b/utilities/ovs-tcpdump.in
322index 22f249f..ff2a51e 100755
323--- a/utilities/ovs-tcpdump.in
324+++ b/utilities/ovs-tcpdump.in
325@@ -1,4 +1,4 @@
326-#! @PYTHON@
327+#!/usr/bin/env @PYTHON@
328 #
329 # Copyright (c) 2016 Red Hat, Inc.
330 #
331diff --git a/utilities/ovs-tcpundump.in b/utilities/ovs-tcpundump.in
332index c298700..0d8b8da 100755
333--- a/utilities/ovs-tcpundump.in
334+++ b/utilities/ovs-tcpundump.in
335@@ -1,4 +1,4 @@
336-#! @PYTHON@
337+#!/usr/bin/env @PYTHON@
338 #
339 # Copyright (c) 2010 Nicira, Inc.
340 #
341diff --git a/utilities/ovs-test.in b/utilities/ovs-test.in
342index fb1f9ad..4dba169 100644
343--- a/utilities/ovs-test.in
344+++ b/utilities/ovs-test.in
345@@ -1,4 +1,4 @@
346-#! @PYTHON@
347+#!/usr/bin/env @PYTHON@
348 #
349 # Licensed under the Apache License, Version 2.0 (the "License");
350 # you may not use this file except in compliance with the License.
351diff --git a/utilities/ovs-vlan-test.in b/utilities/ovs-vlan-test.in
352index e229498..5b70118 100755
353--- a/utilities/ovs-vlan-test.in
354+++ b/utilities/ovs-vlan-test.in
355@@ -1,4 +1,4 @@
356-#! @PYTHON@
357+#!/usr/bin/env @PYTHON@
358 #
359 # Copyright (c) 2010 Nicira, Inc.
360 #
361diff --git a/vtep/ovs-vtep.in b/vtep/ovs-vtep.in
362index 3383870..42f98db 100755
363--- a/vtep/ovs-vtep.in
364+++ b/vtep/ovs-vtep.in
365@@ -1,4 +1,4 @@
366-#! @PYTHON@
367+#!/usr/bin/env @PYTHON@
368 # Copyright (C) 2013 Nicira, Inc. All Rights Reserved.
369 #
370 # Licensed under the Apache License, Version 2.0 (the "License");
371--
3722.8.1
373
diff --git a/recipes-networking/openvswitch/files/python-switch-remaining-scripts-to-use-python3.patch b/recipes-networking/openvswitch/files/python-switch-remaining-scripts-to-use-python3.patch
index 64e0e3f4..113bc91d 100644
--- a/recipes-networking/openvswitch/files/python-switch-remaining-scripts-to-use-python3.patch
+++ b/recipes-networking/openvswitch/files/python-switch-remaining-scripts-to-use-python3.patch
@@ -10,13 +10,12 @@ Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
10--- 10---
11 ofproto/ipfix-gen-entities | 2 +- 11 ofproto/ipfix-gen-entities | 2 +-
12 tests/test-l7.py | 2 +- 12 tests/test-l7.py | 2 +-
13 utilities/checkpatch.py | 2 +-
14 utilities/ovs-dev.py | 2 +- 13 utilities/ovs-dev.py | 2 +-
15 utilities/ovs-pipegen.py | 2 +- 14 utilities/ovs-pipegen.py | 2 +-
16 xenserver/etc_xapi.d_plugins_openvswitch-cfg-update | 2 +- 15 xenserver/etc_xapi.d_plugins_openvswitch-cfg-update | 2 +-
17 xenserver/opt_xensource_libexec_interface-reconfigure | 2 +- 16 xenserver/opt_xensource_libexec_interface-reconfigure | 2 +-
18 xenserver/usr_share_openvswitch_scripts_ovs-xapi-sync | 2 +- 17 xenserver/usr_share_openvswitch_scripts_ovs-xapi-sync | 2 +-
19 8 files changed, 8 insertions(+), 8 deletions(-) 18 7 files changed, 7 insertions(+), 7 deletions(-)
20 19
21diff --git a/ofproto/ipfix-gen-entities b/ofproto/ipfix-gen-entities 20diff --git a/ofproto/ipfix-gen-entities b/ofproto/ipfix-gen-entities
22index 0be7199..d2cce42 100755 21index 0be7199..d2cce42 100755
@@ -38,16 +37,6 @@ index d7854a1..f09defb 100755
38 # Copyright (c) 2015, 2016 Nicira, Inc. 37 # Copyright (c) 2015, 2016 Nicira, Inc.
39 # 38 #
40 # Licensed under the Apache License, Version 2.0 (the "License"); 39 # Licensed under the Apache License, Version 2.0 (the "License");
41diff --git a/utilities/checkpatch.py b/utilities/checkpatch.py
42index f929714..e17a1cf 100755
43--- a/utilities/checkpatch.py
44+++ b/utilities/checkpatch.py
45@@ -1,4 +1,4 @@
46-#!/usr/bin/env python
47+#!/usr/bin/env python3
48 # Copyright (c) 2016, 2017 Red Hat, Inc.
49 # Copyright (c) 2018 Nicira, Inc.
50 #
51diff --git a/utilities/ovs-dev.py b/utilities/ovs-dev.py 40diff --git a/utilities/ovs-dev.py b/utilities/ovs-dev.py
52index 9ce0f04..839e13e 100755 41index 9ce0f04..839e13e 100755
53--- a/utilities/ovs-dev.py 42--- a/utilities/ovs-dev.py
diff --git a/recipes-networking/openvswitch/openvswitch-git/0002-Define-WAIT_ANY-if-not-provided-by-system.patch b/recipes-networking/openvswitch/openvswitch-git/0002-Define-WAIT_ANY-if-not-provided-by-system.patch
deleted file mode 100644
index f997bbff..00000000
--- a/recipes-networking/openvswitch/openvswitch-git/0002-Define-WAIT_ANY-if-not-provided-by-system.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From 801023e72b31e7c49cbccedd76ade33a17fcbe45 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 20 Mar 2017 12:13:30 -0700
4Subject: [PATCH] Define WAIT_ANY if not provided by system
5
6POSIX does not define it and uses -1 directly
7some libc do not have this definitions
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10
11---
12 tests/test-ovn.c | 4 ++++
13 1 file changed, 4 insertions(+)
14
15diff --git a/tests/test-ovn.c b/tests/test-ovn.c
16index 84adf81..2bc6bdf 100644
17--- a/tests/test-ovn.c
18+++ b/tests/test-ovn.c
19@@ -38,6 +38,10 @@
20 #include "simap.h"
21 #include "util.h"
22
23+#ifndef WAIT_ANY
24+# define WAIT_ANY (-1) /* Any process. */
25+#endif
26+
27 /* --relops: Bitmap of the relational operators to test, in exhaustive test. */
28 static unsigned int test_relops;
29
diff --git a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-6beb94976e2b3e0c51430b63214de14186d8db39.patch b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch
index a8fc86c9..a8fc86c9 100644
--- a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-6beb94976e2b3e0c51430b63214de14186d8db39.patch
+++ b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch
diff --git a/recipes-networking/openvswitch/openvswitch-git/ovsdb-idlc.in-fix-dict-change-during-iteration.patch b/recipes-networking/openvswitch/openvswitch-git/ovsdb-idlc.in-fix-dict-change-during-iteration.patch
deleted file mode 100644
index bf49ff65..00000000
--- a/recipes-networking/openvswitch/openvswitch-git/ovsdb-idlc.in-fix-dict-change-during-iteration.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1From d84109f0b60096ce71cd0537b31b69a7f5ea8756 Mon Sep 17 00:00:00 2001
2From: Flavio Leitner <fbl@sysclose.org>
3Date: Sat, 14 Sep 2019 20:17:28 -0300
4Subject: [PATCH] ovsdb-idlc.in: fix dict change during iteration.
5
6Commit d84109f0b600 from git://github.com/openvswitch/ovs.git
7
8Python3 complains if a dict key is changed during the
9iteration.
10
11Use list() to create a copy of it.
12
13Traceback (most recent call last):
14 File "./ovsdb/ovsdb-idlc.in", line 1581, in <module>
15 func(*args[1:])
16 File "./ovsdb/ovsdb-idlc.in", line 185, in printCIDLHeader
17 replace_cplusplus_keyword(schema)
18 File "./ovsdb/ovsdb-idlc.in", line 179, in replace_cplusplus_keyword
19 for columnName in table.columns:
20RuntimeError: dictionary keys changed during iteration
21
22Signed-off-by: Flavio Leitner <fbl@sysclose.org>
23Signed-off-by: Ben Pfaff <blp@ovn.org>
24[MA: Upstream-Status: Submitted]
25Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
26---
27 ovsdb/ovsdb-idlc.in | 2 +-
28 1 file changed, 1 insertion(+), 1 deletion(-)
29
30diff --git a/ovsdb/ovsdb-idlc.in b/ovsdb/ovsdb-idlc.in
31index 40fef39..22d0a4e 100755
32--- a/ovsdb/ovsdb-idlc.in
33+++ b/ovsdb/ovsdb-idlc.in
34@@ -176,7 +176,7 @@ def replace_cplusplus_keyword(schema):
35 'wchar_t', 'while', 'xor', 'xor_eq'}
36
37 for tableName, table in schema.tables.items():
38- for columnName in table.columns:
39+ for columnName in list(table.columns):
40 if columnName in keywords:
41 table.columns[columnName + '_'] = table.columns.pop(columnName)
42
43--
442.7.4
45
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index 141a609a..07258be7 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -5,7 +5,7 @@ DEPENDS += "virtual/kernel"
5PACKAGE_ARCH = "${MACHINE_ARCH}" 5PACKAGE_ARCH = "${MACHINE_ARCH}"
6 6
7RDEPENDS_${PN}-ptest += "\ 7RDEPENDS_${PN}-ptest += "\
8 python3-logging python3-syslog python3-io \ 8 python3-logging python3-syslog python3-io python3-core \
9 python3-fcntl python3-shell python3-xml python3-math \ 9 python3-fcntl python3-shell python3-xml python3-math \
10 python3-datetime python3-netclient python3 sed \ 10 python3-datetime python3-netclient python3 sed \
11 ldd perl-module-socket perl-module-carp perl-module-exporter \ 11 ldd perl-module-socket perl-module-carp perl-module-exporter \
@@ -14,26 +14,23 @@ RDEPENDS_${PN}-ptest += "\
14 " 14 "
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17PV = "2.12+${SRCPV}" 17PV = "2.13+${SRCPV}"
18 18
19FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:" 19FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:"
20 20
21SRCREV = "6beb94976e2b3e0c51430b63214de14186d8db39" 21SRCREV = "71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3"
22SRC_URI = "file://openvswitch-switch \ 22SRC_URI = "file://openvswitch-switch \
23 file://openvswitch-switch-setup \ 23 file://openvswitch-switch-setup \
24 file://openvswitch-testcontroller \ 24 file://openvswitch-testcontroller \
25 file://openvswitch-testcontroller-setup \ 25 file://openvswitch-testcontroller-setup \
26 git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.12 \ 26 git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.13 \
27 file://openvswitch-add-ptest-6beb94976e2b3e0c51430b63214de14186d8db39.patch \ 27 file://openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch \
28 file://run-ptest \ 28 file://run-ptest \
29 file://disable_m4_check.patch \ 29 file://disable_m4_check.patch \
30 file://kernel_module.patch \ 30 file://kernel_module.patch \
31 file://python-make-remaining-scripts-use-usr-bin-env.patch \
32 file://0002-Define-WAIT_ANY-if-not-provided-by-system.patch \
33 file://python-switch-remaining-scripts-to-use-python3.patch \ 31 file://python-switch-remaining-scripts-to-use-python3.patch \
34 file://systemd-update-tool-paths.patch \ 32 file://systemd-update-tool-paths.patch \
35 file://systemd-create-runtime-dirs.patch \ 33 file://systemd-create-runtime-dirs.patch \
36 file://ovsdb-idlc.in-fix-dict-change-during-iteration.patch \
37 " 34 "
38 35
39LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab" 36LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"