summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-05-14 18:25:59 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-14 18:27:09 -0400
commita82acb5d0ce339eb928a4810cbfe4c8804f42354 (patch)
treedb314c7d47d6f348410bf4390254b17ecd78029d /recipes-networking/openvswitch
parent9b0bacbb501093c4d5470df96c24eb9895ad9755 (diff)
downloadmeta-virtualization-a82acb5d0ce339eb928a4810cbfe4c8804f42354.tar.gz
openvswitch: uprev to v2.1.2
Updating to the latest OVS 2.x. Only minor patch refreshes required, and no regressions were found during sanity testing. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking/openvswitch')
-rw-r--r--recipes-networking/openvswitch/files/openvswitch-add-ptest.patch17
-rw-r--r--recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch103
-rw-r--r--recipes-networking/openvswitch/openvswitch_2.1.2.bb (renamed from recipes-networking/openvswitch/openvswitch_2.0.0.bb)6
3 files changed, 57 insertions, 69 deletions
diff --git a/recipes-networking/openvswitch/files/openvswitch-add-ptest.patch b/recipes-networking/openvswitch/files/openvswitch-add-ptest.patch
index aebb1823..cb708dea 100644
--- a/recipes-networking/openvswitch/files/openvswitch-add-ptest.patch
+++ b/recipes-networking/openvswitch/files/openvswitch-add-ptest.patch
@@ -2,19 +2,20 @@ Add test-install rule to support ptest execution
2 2
3Signed-off-by: Radu Patriu <radu.patriu@enea.com> 3Signed-off-by: Radu Patriu <radu.patriu@enea.com>
4 4
5Index: ovs/Makefile.am 5Index: openvswitch-2.1.2/Makefile.am
6=================================================================== 6===================================================================
7--- ovs.orig/Makefile.am 2014-03-10 16:19:46.000000000 +0200 7--- openvswitch-2.1.2.orig/Makefile.am
8+++ ovs/Makefile.am 2014-03-10 16:23:10.481075341 +0200 8+++ openvswitch-2.1.2/Makefile.am
9@@ -276,3 +276,4 @@ 9@@ -300,3 +300,5 @@
10 include python/automake.mk
11 include python/compat/automake.mk 10 include python/compat/automake.mk
12 include tutorial/automake.mk 11 include tutorial/automake.mk
12 include vtep/automake.mk
13+include test.mk 13+include test.mk
14Index: ovs/test.mk 14+
15Index: openvswitch-2.1.2/test.mk
15=================================================================== 16===================================================================
16--- /dev/null 1970-01-01 00:00:00.000000000 +0000 17--- /dev/null
17+++ ovs/test.mk 2014-03-10 16:42:41.000000000 +0200 18+++ openvswitch-2.1.2/test.mk
18@@ -0,0 +1,49 @@ 19@@ -0,0 +1,49 @@
19+TEST_DEST ?= ${prefix}/lib/openvswitch 20+TEST_DEST ?= ${prefix}/lib/openvswitch
20+TEST_ROOT ?= ${prefix}/lib/openvswitch 21+TEST_ROOT ?= ${prefix}/lib/openvswitch
diff --git a/recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch b/recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch
index 59607dad..97b352cb 100644
--- a/recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch
+++ b/recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch
@@ -24,11 +24,11 @@ Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
24 utilities/ovs-vlan-test.in | 2 +- 24 utilities/ovs-vlan-test.in | 2 +-
25 11 files changed, 17 insertions(+), 9 deletions(-) 25 11 files changed, 17 insertions(+), 9 deletions(-)
26 26
27diff --git a/Makefile.am b/Makefile.am 27Index: openvswitch-2.1.2/Makefile.am
28index b71ca1f..c4f8341 100644 28===================================================================
29--- a/Makefile.am 29--- openvswitch-2.1.2.orig/Makefile.am
30+++ b/Makefile.am 30+++ openvswitch-2.1.2/Makefile.am
31@@ -112,6 +112,7 @@ SUFFIXES += .in 31@@ -125,6 +125,7 @@
32 -e 's,[@]DBDIR[@],$(DBDIR),g' \ 32 -e 's,[@]DBDIR[@],$(DBDIR),g' \
33 -e 's,[@]PERL[@],$(PERL),g' \ 33 -e 's,[@]PERL[@],$(PERL),g' \
34 -e 's,[@]PYTHON[@],$(PYTHON),g' \ 34 -e 's,[@]PYTHON[@],$(PYTHON),g' \
@@ -36,11 +36,11 @@ index b71ca1f..c4f8341 100644
36 -e 's,[@]RUNDIR[@],$(RUNDIR),g' \ 36 -e 's,[@]RUNDIR[@],$(RUNDIR),g' \
37 -e 's,[@]VERSION[@],$(VERSION),g' \ 37 -e 's,[@]VERSION[@],$(VERSION),g' \
38 -e 's,[@]localstatedir[@],$(localstatedir),g' \ 38 -e 's,[@]localstatedir[@],$(localstatedir),g' \
39diff --git a/configure.ac b/configure.ac 39Index: openvswitch-2.1.2/configure.ac
40index 060b53f..74cb691 100644 40===================================================================
41--- a/configure.ac 41--- openvswitch-2.1.2.orig/configure.ac
42+++ b/configure.ac 42+++ openvswitch-2.1.2/configure.ac
43@@ -101,6 +101,13 @@ AC_ARG_VAR(KARCH, [Kernel Architecture String]) 43@@ -118,6 +118,13 @@
44 AC_SUBST(KARCH) 44 AC_SUBST(KARCH)
45 OVS_CHECK_LINUX 45 OVS_CHECK_LINUX
46 46
@@ -51,99 +51,86 @@ index 060b53f..74cb691 100644
51+fi 51+fi
52+AC_SUBST(TARGET_PYTHON) 52+AC_SUBST(TARGET_PYTHON)
53+ 53+
54 AC_CONFIG_FILES([Makefile 54 AC_CONFIG_FILES(Makefile)
55 datapath/Makefile 55 AC_CONFIG_FILES(datapath/Makefile)
56 datapath/linux/Kbuild 56 AC_CONFIG_FILES(datapath/linux/Kbuild)
57diff --git a/ovsdb/ovsdbmonitor/ovsdbmonitor.in b/ovsdb/ovsdbmonitor/ovsdbmonitor.in 57Index: openvswitch-2.1.2/utilities/bugtool/ovs-bugtool.in
58index e26130a..aaf1aff 100755 58===================================================================
59--- a/ovsdb/ovsdbmonitor/ovsdbmonitor.in 59--- openvswitch-2.1.2.orig/utilities/bugtool/ovs-bugtool.in
60+++ b/ovsdb/ovsdbmonitor/ovsdbmonitor.in 60+++ openvswitch-2.1.2/utilities/bugtool/ovs-bugtool.in
61@@ -1,4 +1,4 @@
62-#! @PYTHON@
63+#! @TARGET_PYTHON@
64 # Copyright (c) 2010 Citrix Systems, Inc.
65 #
66 # Licensed under the Apache License, Version 2.0 (the "License");
67diff --git a/utilities/bugtool/ovs-bugtool.in b/utilities/bugtool/ovs-bugtool.in
68index 2074e23..525939e 100755
69--- a/utilities/bugtool/ovs-bugtool.in
70+++ b/utilities/bugtool/ovs-bugtool.in
71@@ -1,4 +1,4 @@ 61@@ -1,4 +1,4 @@
72-#! @PYTHON@ 62-#! @PYTHON@
73+#! @TARGET_PYTHON@ 63+#! @TARGET_PYTHON@
74 64
75 # This library is free software; you can redistribute it and/or 65 # This library is free software; you can redistribute it and/or
76 # modify it under the terms of version 2.1 of the GNU Lesser General Public 66 # modify it under the terms of version 2.1 of the GNU Lesser General Public
77diff --git a/utilities/ovs-check-dead-ifs.in b/utilities/ovs-check-dead-ifs.in 67Index: openvswitch-2.1.2/utilities/ovs-check-dead-ifs.in
78index 9b806ed..b6f6fcb 100755 68===================================================================
79--- a/utilities/ovs-check-dead-ifs.in 69--- openvswitch-2.1.2.orig/utilities/ovs-check-dead-ifs.in
80+++ b/utilities/ovs-check-dead-ifs.in 70+++ openvswitch-2.1.2/utilities/ovs-check-dead-ifs.in
81@@ -1,4 +1,4 @@ 71@@ -1,4 +1,4 @@
82-#! @PYTHON@ 72-#! @PYTHON@
83+#! @TARGET_PYTHON@ 73+#! @TARGET_PYTHON@
84 74
85 import os 75 import os
86 import re 76 import re
87diff --git a/utilities/ovs-l3ping.in b/utilities/ovs-l3ping.in 77Index: openvswitch-2.1.2/utilities/ovs-l3ping.in
88index 1b07972..4fedb6f 100644 78===================================================================
89--- a/utilities/ovs-l3ping.in 79--- openvswitch-2.1.2.orig/utilities/ovs-l3ping.in
90+++ b/utilities/ovs-l3ping.in 80+++ openvswitch-2.1.2/utilities/ovs-l3ping.in
91@@ -1,4 +1,4 @@ 81@@ -1,4 +1,4 @@
92-#! @PYTHON@ 82-#! @PYTHON@
93+#! @TARGET_PYTHON@ 83+#! @TARGET_PYTHON@
94 # 84 #
95 # Licensed under the Apache License, Version 2.0 (the "License"); 85 # Licensed under the Apache License, Version 2.0 (the "License");
96 # you may not use this file except in compliance with the License. 86 # you may not use this file except in compliance with the License.
97diff --git a/utilities/ovs-parse-backtrace.in b/utilities/ovs-parse-backtrace.in 87Index: openvswitch-2.1.2/utilities/ovs-parse-backtrace.in
98index 4f793be..4a07f47 100755 88===================================================================
99--- a/utilities/ovs-parse-backtrace.in 89--- openvswitch-2.1.2.orig/utilities/ovs-parse-backtrace.in
100+++ b/utilities/ovs-parse-backtrace.in 90+++ openvswitch-2.1.2/utilities/ovs-parse-backtrace.in
101@@ -1,4 +1,4 @@ 91@@ -1,4 +1,4 @@
102-#! @PYTHON@ 92-#! @PYTHON@
103+#! @TARGET_PYTHON@ 93+#! @TARGET_PYTHON@
104 # 94 #
105 # Copyright (c) 2012 Nicira, Inc. 95 # Copyright (c) 2012 Nicira, Inc.
106 # 96 #
107diff --git a/utilities/ovs-pcap.in b/utilities/ovs-pcap.in 97Index: openvswitch-2.1.2/utilities/ovs-pcap.in
108index 5306480..3221c7c 100755 98===================================================================
109--- a/utilities/ovs-pcap.in 99--- openvswitch-2.1.2.orig/utilities/ovs-pcap.in
110+++ b/utilities/ovs-pcap.in 100+++ openvswitch-2.1.2/utilities/ovs-pcap.in
111@@ -1,4 +1,4 @@ 101@@ -1,4 +1,4 @@
112-#! @PYTHON@ 102-#! @PYTHON@
113+#! @TARGET_PYTHON@ 103+#! @TARGET_PYTHON@
114 # 104 #
115 # Copyright (c) 2010 Nicira, Inc. 105 # Copyright (c) 2010 Nicira, Inc.
116 # 106 #
117diff --git a/utilities/ovs-tcpundump.in b/utilities/ovs-tcpundump.in 107Index: openvswitch-2.1.2/utilities/ovs-tcpundump.in
118index 0268c50..dad0bb5 100755 108===================================================================
119--- a/utilities/ovs-tcpundump.in 109--- openvswitch-2.1.2.orig/utilities/ovs-tcpundump.in
120+++ b/utilities/ovs-tcpundump.in 110+++ openvswitch-2.1.2/utilities/ovs-tcpundump.in
121@@ -1,4 +1,4 @@ 111@@ -1,4 +1,4 @@
122-#! @PYTHON@ 112-#! @PYTHON@
123+#! @TARGET_PYTHON@ 113+#! @TARGET_PYTHON@
124 # 114 #
125 # Copyright (c) 2010 Nicira, Inc. 115 # Copyright (c) 2010 Nicira, Inc.
126 # 116 #
127diff --git a/utilities/ovs-test.in b/utilities/ovs-test.in 117Index: openvswitch-2.1.2/utilities/ovs-test.in
128index fb1f9ad..bddd327 100644 118===================================================================
129--- a/utilities/ovs-test.in 119--- openvswitch-2.1.2.orig/utilities/ovs-test.in
130+++ b/utilities/ovs-test.in 120+++ openvswitch-2.1.2/utilities/ovs-test.in
131@@ -1,4 +1,4 @@ 121@@ -1,4 +1,4 @@
132-#! @PYTHON@ 122-#! @PYTHON@
133+#! @TARGET_PYTHON@ 123+#! @TARGET_PYTHON@
134 # 124 #
135 # Licensed under the Apache License, Version 2.0 (the "License"); 125 # Licensed under the Apache License, Version 2.0 (the "License");
136 # you may not use this file except in compliance with the License. 126 # you may not use this file except in compliance with the License.
137diff --git a/utilities/ovs-vlan-test.in b/utilities/ovs-vlan-test.in 127Index: openvswitch-2.1.2/utilities/ovs-vlan-test.in
138index e229498..da64040 100755 128===================================================================
139--- a/utilities/ovs-vlan-test.in 129--- openvswitch-2.1.2.orig/utilities/ovs-vlan-test.in
140+++ b/utilities/ovs-vlan-test.in 130+++ openvswitch-2.1.2/utilities/ovs-vlan-test.in
141@@ -1,4 +1,4 @@ 131@@ -1,4 +1,4 @@
142-#! @PYTHON@ 132-#! @PYTHON@
143+#! @TARGET_PYTHON@ 133+#! @TARGET_PYTHON@
144 # 134 #
145 # Copyright (c) 2010 Nicira, Inc. 135 # Copyright (c) 2010 Nicira, Inc.
146 # 136 #
147--
1481.8.1.2
149
diff --git a/recipes-networking/openvswitch/openvswitch_2.0.0.bb b/recipes-networking/openvswitch/openvswitch_2.1.2.bb
index 01003082..3f092afb 100644
--- a/recipes-networking/openvswitch/openvswitch_2.0.0.bb
+++ b/recipes-networking/openvswitch/openvswitch_2.1.2.bb
@@ -35,10 +35,10 @@ SRC_URI = "http://openvswitch.org/releases/openvswitch-${PV}.tar.gz \
35 file://run-ptest \ 35 file://run-ptest \
36 " 36 "
37 37
38SRC_URI[md5sum] = "7d7a58350e634e515e0fe43c64d64f44" 38SRC_URI[md5sum] = "430ff6d1e1fc81e9c5ebc2e641cfc953"
39SRC_URI[sha256sum] = "5060e2be69cce01c15f67b481482cb1a0eaa6ef5cbdbed592bac3c3ab2a390f8" 39SRC_URI[sha256sum] = "875429b052c4001815b6cb38616c7a6cb212df4bba74602164ee0a99b172079b"
40 40
41LIC_FILES_CHKSUM = "file://COPYING;md5=49eeb5acb1f5e510f12c44f176c42253" 41LIC_FILES_CHKSUM = "file://COPYING;md5=e03b0d9c4115c44518594e5618e653f8"
42 42
43# Don't compile kernel modules by default since it heavily depends on 43# Don't compile kernel modules by default since it heavily depends on
44# kernel version. Use the in-kernel module for now. 44# kernel version. Use the in-kernel module for now.