summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-11-13 14:01:31 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-11-13 14:01:31 -0500
commita626d480cf9b0e12ad17ba476f89aa18e2b72d07 (patch)
tree6ceb7ba3196a62f7c07e7ee2b131cee8d4e78c3f /recipes-networking/openvswitch
parent0623683135ae782c206b6fae3782e7c229e78b48 (diff)
downloadmeta-virtualization-a626d480cf9b0e12ad17ba476f89aa18e2b72d07.tar.gz
openvswitch: make postinst indentation consistent
right or wrong, we shouldn't have a mix of tabs or spaces, so in this cleanup, we'll make them all tabs. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking/openvswitch')
-rw-r--r--recipes-networking/openvswitch/openvswitch_2.0.0.bb50
1 files changed, 25 insertions, 25 deletions
diff --git a/recipes-networking/openvswitch/openvswitch_2.0.0.bb b/recipes-networking/openvswitch/openvswitch_2.0.0.bb
index cc34cfdb..0ca707ed 100644
--- a/recipes-networking/openvswitch/openvswitch_2.0.0.bb
+++ b/recipes-networking/openvswitch/openvswitch_2.0.0.bb
@@ -82,36 +82,36 @@ do_install_append() {
82 82
83pkg_postinst_${PN}-pki () { 83pkg_postinst_${PN}-pki () {
84 # can't do this offline 84 # can't do this offline
85 if [ "x$D" != "x" ]; then 85 if [ "x$D" != "x" ]; then
86 exit 1 86 exit 1
87 fi 87 fi
88 if test ! -d $D/${datadir}/${PN}/pki; then 88 if test ! -d $D/${datadir}/${PN}/pki; then
89 ovs-pki init --dir=$D/${datadir}/${PN}/pki 89 ovs-pki init --dir=$D/${datadir}/${PN}/pki
90 fi 90 fi
91} 91}
92 92
93pkg_postinst_${PN}-controller () { 93pkg_postinst_${PN}-controller () {
94 # can't do this offline 94 # can't do this offline
95 if [ "x$D" != "x" ]; then 95 if [ "x$D" != "x" ]; then
96 exit 1 96 exit 1
97 fi 97 fi
98 98
99 if test ! -d $D/${datadir}/${PN}/pki; then 99 if test ! -d $D/${datadir}/${PN}/pki; then
100 ovs-pki init --dir=$D/${datadir}/${PN}/pki 100 ovs-pki init --dir=$D/${datadir}/${PN}/pki
101 fi 101 fi
102 102
103 cd $D/${sysconfdir}/openvswitch-controller 103 cd $D/${sysconfdir}/openvswitch-controller
104 if ! test -e cacert.pem; then 104 if ! test -e cacert.pem; then
105 ln -s $D/${datadir}/${PN}/pki/switchca/cacert.pem cacert.pem 105 ln -s $D/${datadir}/${PN}/pki/switchca/cacert.pem cacert.pem
106 fi 106 fi
107 if ! test -e privkey.pem || ! test -e cert.pem; then 107 if ! test -e privkey.pem || ! test -e cert.pem; then
108 oldumask=$(umask) 108 oldumask=$(umask)
109 umask 077 109 umask 077
110 ovs-pki req+sign --dir=$D/${datadir}/${PN}/pki tmp controller >/dev/null 110 ovs-pki req+sign --dir=$D/${datadir}/${PN}/pki tmp controller >/dev/null
111 mv tmp-privkey.pem privkey.pem 111 mv tmp-privkey.pem privkey.pem
112 mv tmp-cert.pem cert.pem 112 mv tmp-cert.pem cert.pem
113 mv tmp-req.pem req.pem 113 mv tmp-req.pem req.pem
114 chmod go+r cert.pem req.pem 114 chmod go+r cert.pem req.pem
115 umask $oldumask 115 umask $oldumask
116 fi 116 fi
117} 117}