summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch
diff options
context:
space:
mode:
authorMihai Prica <mihai.prica@intel.com>2013-07-26 17:06:44 +0300
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-07-30 22:57:34 -0400
commit4d1aed483420fdb3d2cbcca4a5b646ad5426349c (patch)
tree3d5d9a3c2c95e820113df31c804e34eebeb6bb23 /recipes-networking/openvswitch
parentfaf6fc48858b8e8fa1e04cf314851511943658d3 (diff)
downloadmeta-virtualization-4d1aed483420fdb3d2cbcca4a5b646ad5426349c.tar.gz
openvswitch: Ensure pki directory creation
RPM doesn't guarantee the order in which postinstalls are ran. Added code to ensure the pki directory is initialized. Signed-off-by: Mihai Prica <mihai.prica@intel.com>
Diffstat (limited to 'recipes-networking/openvswitch')
-rw-r--r--recipes-networking/openvswitch/openvswitch_1.10.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-networking/openvswitch/openvswitch_1.10.0.bb b/recipes-networking/openvswitch/openvswitch_1.10.0.bb
index fff597c1..4fb2670b 100644
--- a/recipes-networking/openvswitch/openvswitch_1.10.0.bb
+++ b/recipes-networking/openvswitch/openvswitch_1.10.0.bb
@@ -14,7 +14,7 @@ RDEPENDS_${PN}-pki = "${PN}"
14RDEPENDS_${PN}-brcompat = "${PN} ${PN}-switch" 14RDEPENDS_${PN}-brcompat = "${PN} ${PN}-switch"
15RRECOMMENDS_${PN} += "kernel-module-openvswitch" 15RRECOMMENDS_${PN} += "kernel-module-openvswitch"
16 16
17PR = "r1" 17PR = "r2"
18 18
19SRC_URI = "http://openvswitch.org/releases/openvswitch-${PV}.tar.gz \ 19SRC_URI = "http://openvswitch.org/releases/openvswitch-${PV}.tar.gz \
20 file://openvswitch-switch \ 20 file://openvswitch-switch \
@@ -91,6 +91,10 @@ pkg_postinst_${PN}-controller () {
91 exit 1 91 exit 1
92 fi 92 fi
93 93
94 if test ! -d $D/${datadir}/${PN}/pki; then
95 ovs-pki init --dir=$D/${datadir}/${PN}/pki
96 fi
97
94 cd $D/${sysconfdir}/openvswitch-controller 98 cd $D/${sysconfdir}/openvswitch-controller
95 if ! test -e cacert.pem; then 99 if ! test -e cacert.pem; then
96 ln -s $D/${datadir}/${PN}/pki/switchca/cacert.pem cacert.pem 100 ln -s $D/${datadir}/${PN}/pki/switchca/cacert.pem cacert.pem