summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch
diff options
context:
space:
mode:
authorPaul Barker <paul.barker@sancloud.com>2022-10-06 09:10:20 +0100
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-10-08 22:59:22 -0400
commit30c3df4c222e78e3167c348afa4f9c875e17572a (patch)
treeaf2f4366a9e0fcbf66f352e946f8c34614e9c558 /recipes-networking/openvswitch
parent8177e4a6b72d5b701b92b2028baf1a8860cf18e6 (diff)
downloadmeta-virtualization-30c3df4c222e78e3167c348afa4f9c875e17572a.tar.gz
openvswitch: Fix INSTALL_MOD_PATH
If the usrmerge DISTRO_FEATURE is enabled, modules should be installed under /usr/lib instead of /lib. We can handle this by using ${root_prefix} in INSTALL_MOD_PATH. Signed-off-by: Paul Barker <paul.barker@sancloud.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-networking/openvswitch')
-rw-r--r--recipes-networking/openvswitch/openvswitch.inc2
-rw-r--r--recipes-networking/openvswitch/openvswitch_git.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-networking/openvswitch/openvswitch.inc b/recipes-networking/openvswitch/openvswitch.inc
index 251a7056..e6c9091a 100644
--- a/recipes-networking/openvswitch/openvswitch.inc
+++ b/recipes-networking/openvswitch/openvswitch.inc
@@ -132,7 +132,7 @@ do_install:append() {
132 install -d ${D}/usr/share/openvswitch/scripts/ 132 install -d ${D}/usr/share/openvswitch/scripts/
133 install -m 755 ${S}/rhel/usr_share_openvswitch_scripts_ovs-systemd-reload ${D}/usr/share/openvswitch/scripts/ovs-systemd-reload 133 install -m 755 ${S}/rhel/usr_share_openvswitch_scripts_ovs-systemd-reload ${D}/usr/share/openvswitch/scripts/ovs-systemd-reload
134 134
135 oe_runmake modules_install INSTALL_MOD_PATH=${D} 135 oe_runmake modules_install INSTALL_MOD_PATH=${D}${root_prefix}
136 install -d ${D}${libdir}/python${PYTHON_BASEVERSION}/site-packages 136 install -d ${D}${libdir}/python${PYTHON_BASEVERSION}/site-packages
137 cp -r ${S}/python/ovstest/ ${D}${libdir}/python${PYTHON_BASEVERSION}/site-packages/ 137 cp -r ${S}/python/ovstest/ ${D}${libdir}/python${PYTHON_BASEVERSION}/site-packages/
138} 138}
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index 2e125e78..f5d85f3f 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -53,5 +53,5 @@ do_install_ptest() {
53} 53}
54 54
55do_install:append() { 55do_install:append() {
56 oe_runmake modules_install INSTALL_MOD_PATH=${D} 56 oe_runmake modules_install INSTALL_MOD_PATH=${D}${root_prefix}
57} 57}