summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2020-02-12 12:51:44 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-02-13 17:21:44 -0500
commit0ab14d82b1b1aec59dc6c7f180f2688ccee1459e (patch)
treea36a213e8c95252598721b227ab408766743c87a /recipes-networking/openvswitch
parentb8c810c6083311593b0432ede69cefeb4226cdf6 (diff)
downloadmeta-virtualization-0ab14d82b1b1aec59dc6c7f180f2688ccee1459e.tar.gz
openvswitch: uprev from v2.11 to v2.12
A mostly straightforward uprev. Unfortunately a required patch for python3 is only available on a non-release branch so we must carry it in order to build (the discussion on the mailing list was that an uprev might have avoided this, but this is not the case). The ptest results are similar to after the v2.11 uprev ERROR: 2413 tests were run, 23 failed unexpectedly. 383 tests were skipped. NOTE, however, that they have now marked many tests as 'skipped', such as the python2 results, so the failed and skipped numbers have essentially swapped with each other. The failed tests were in the following areas: checkpatch.at (5) ovs-ofctl.at (1) dpif-netdev.at (1) ofproto-dpif.at (6) bridge.at (2) ovn.at (2) ovn-controller-vtep.at (6) Most were issues with the test or expectations that source code would be available. There might be an issue around packaging of "/vswitchd/vswitch.ovsschema" but we should be able to overlook this for now, as we have with previous versions. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-networking/openvswitch')
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-6beb94976e2b3e0c51430b63214de14186d8db39.patch (renamed from recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-78e203138cb7253e9ca5ad8a2c4ed6bb6752f23e.patch)0
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/ovsdb-idlc.in-fix-dict-change-during-iteration.patch45
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/systemd-create-runtime-dirs.patch12
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/systemd-update-tool-paths.patch32
-rw-r--r--recipes-networking/openvswitch/openvswitch_git.bb11
5 files changed, 74 insertions, 26 deletions
diff --git a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-78e203138cb7253e9ca5ad8a2c4ed6bb6752f23e.patch b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-6beb94976e2b3e0c51430b63214de14186d8db39.patch
index a8fc86c9..a8fc86c9 100644
--- a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-78e203138cb7253e9ca5ad8a2c4ed6bb6752f23e.patch
+++ b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-6beb94976e2b3e0c51430b63214de14186d8db39.patch
diff --git a/recipes-networking/openvswitch/openvswitch-git/ovsdb-idlc.in-fix-dict-change-during-iteration.patch b/recipes-networking/openvswitch/openvswitch-git/ovsdb-idlc.in-fix-dict-change-during-iteration.patch
new file mode 100644
index 00000000..bf49ff65
--- /dev/null
+++ b/recipes-networking/openvswitch/openvswitch-git/ovsdb-idlc.in-fix-dict-change-during-iteration.patch
@@ -0,0 +1,45 @@
1From d84109f0b60096ce71cd0537b31b69a7f5ea8756 Mon Sep 17 00:00:00 2001
2From: Flavio Leitner <fbl@sysclose.org>
3Date: Sat, 14 Sep 2019 20:17:28 -0300
4Subject: [PATCH] ovsdb-idlc.in: fix dict change during iteration.
5
6Commit d84109f0b600 from git://github.com/openvswitch/ovs.git
7
8Python3 complains if a dict key is changed during the
9iteration.
10
11Use list() to create a copy of it.
12
13Traceback (most recent call last):
14 File "./ovsdb/ovsdb-idlc.in", line 1581, in <module>
15 func(*args[1:])
16 File "./ovsdb/ovsdb-idlc.in", line 185, in printCIDLHeader
17 replace_cplusplus_keyword(schema)
18 File "./ovsdb/ovsdb-idlc.in", line 179, in replace_cplusplus_keyword
19 for columnName in table.columns:
20RuntimeError: dictionary keys changed during iteration
21
22Signed-off-by: Flavio Leitner <fbl@sysclose.org>
23Signed-off-by: Ben Pfaff <blp@ovn.org>
24[MA: Upstream-Status: Submitted]
25Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
26---
27 ovsdb/ovsdb-idlc.in | 2 +-
28 1 file changed, 1 insertion(+), 1 deletion(-)
29
30diff --git a/ovsdb/ovsdb-idlc.in b/ovsdb/ovsdb-idlc.in
31index 40fef39..22d0a4e 100755
32--- a/ovsdb/ovsdb-idlc.in
33+++ b/ovsdb/ovsdb-idlc.in
34@@ -176,7 +176,7 @@ def replace_cplusplus_keyword(schema):
35 'wchar_t', 'while', 'xor', 'xor_eq'}
36
37 for tableName, table in schema.tables.items():
38- for columnName in table.columns:
39+ for columnName in list(table.columns):
40 if columnName in keywords:
41 table.columns[columnName + '_'] = table.columns.pop(columnName)
42
43--
442.7.4
45
diff --git a/recipes-networking/openvswitch/openvswitch-git/systemd-create-runtime-dirs.patch b/recipes-networking/openvswitch/openvswitch-git/systemd-create-runtime-dirs.patch
index 65290cf6..0438cf88 100644
--- a/recipes-networking/openvswitch/openvswitch-git/systemd-create-runtime-dirs.patch
+++ b/recipes-networking/openvswitch/openvswitch-git/systemd-create-runtime-dirs.patch
@@ -1,4 +1,4 @@
1From 219e7cf9f28fdf14747fdf674bec293f763fe8e3 Mon Sep 17 00:00:00 2001 1From 6876e0c155b7f83e1f8545446e2dd69c2b7989f2 Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com> 2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Tue, 4 Sep 2018 15:38:59 -0400 3Date: Tue, 4 Sep 2018 15:38:59 -0400
4Subject: [PATCH] systemd: create runtime dirs 4Subject: [PATCH] systemd: create runtime dirs
@@ -15,17 +15,17 @@ Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
15 1 file changed, 1 insertion(+) 15 1 file changed, 1 insertion(+)
16 16
17diff --git a/rhel/usr_lib_systemd_system_ovsdb-server.service b/rhel/usr_lib_systemd_system_ovsdb-server.service 17diff --git a/rhel/usr_lib_systemd_system_ovsdb-server.service b/rhel/usr_lib_systemd_system_ovsdb-server.service
18index 694598f..0bb2274 100644 18index aad557f..69b0bf6 100644
19--- a/rhel/usr_lib_systemd_system_ovsdb-server.service 19--- a/rhel/usr_lib_systemd_system_ovsdb-server.service
20+++ b/rhel/usr_lib_systemd_system_ovsdb-server.service 20+++ b/rhel/usr_lib_systemd_system_ovsdb-server.service
21@@ -10,6 +10,7 @@ Type=forking 21@@ -11,6 +11,7 @@ PIDFile=/var/run/openvswitch/ovsdb-server.pid
22 Restart=on-failure 22 Restart=on-failure
23 EnvironmentFile=/etc/openvswitch/default.conf 23 EnvironmentFile=/etc/openvswitch/default.conf
24 EnvironmentFile=-/etc/sysconfig/openvswitch 24 EnvironmentFile=-/etc/sysconfig/openvswitch
25+ExecStartPre=-/bin/mkdir /var/run/openvswitch /var/log/openvswitch 25+ExecStartPre=-/bin/mkdir /var/run/openvswitch /var/log/openvswitch
26 ExecStartPre=/bin/chown ${OVS_USER_ID} /var/run/openvswitch /var/log/openvswitch 26 ExecStartPre=-/bin/chown ${OVS_USER_ID} /var/run/openvswitch /var/log/openvswitch
27 ExecStartPre=/bin/sh -c 'rm -f /run/openvswitch/useropts; if [ "$${OVS_USER_ID/:*/}" != "root" ]; then /bin/echo "OVSUSER=--ovs-user=${OVS_USER_ID}" > /run/openvswitch/useropts; fi' 27 ExecStartPre=/bin/sh -c 'rm -f /run/openvswitch.useropts; /bin/echo "OVS_USER_ID=${OVS_USER_ID}" > /run/openvswitch.useropts'
28 EnvironmentFile=-/run/openvswitch/useropts 28 ExecStartPre=/bin/sh -c 'if [ "$${OVS_USER_ID/:*/}" != "root" ]; then /bin/echo "OVS_USER_OPT=--ovs-user=${OVS_USER_ID}" >> /run/openvswitch.useropts; fi'
29-- 29--
302.7.4 302.7.4
31 31
diff --git a/recipes-networking/openvswitch/openvswitch-git/systemd-update-tool-paths.patch b/recipes-networking/openvswitch/openvswitch-git/systemd-update-tool-paths.patch
index d7d4c159..aae44fe7 100644
--- a/recipes-networking/openvswitch/openvswitch-git/systemd-update-tool-paths.patch
+++ b/recipes-networking/openvswitch/openvswitch-git/systemd-update-tool-paths.patch
@@ -1,7 +1,7 @@
1From 163020a5bba1323dc337d72d4771bb81d824b0dc Mon Sep 17 00:00:00 2001 1From efd6b8f03ef7278d2477833f84bb8488bd0c346d Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com> 2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Tue, 29 May 2018 18:57:46 +0000 3Date: Tue, 29 May 2018 18:57:46 +0000
4Subject: [PATCH] systemd: update tool paths 4Subject: [PATCH 1/2] systemd: update tool paths
5 5
6We are using the rhel files but we install our tools in a slightly 6We are using the rhel files but we install our tools in a slightly
7different path, update accordingly. 7different path, update accordingly.
@@ -9,16 +9,16 @@ different path, update accordingly.
9Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> 9Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
10--- 10---
11 rhel/usr_lib_systemd_system_ovs-vswitchd.service.in | 4 ++-- 11 rhel/usr_lib_systemd_system_ovs-vswitchd.service.in | 4 ++--
12 rhel/usr_lib_systemd_system_ovsdb-server.service | 4 ++-- 12 rhel/usr_lib_systemd_system_ovsdb-server.service | 6 +++---
13 2 files changed, 4 insertions(+), 4 deletions(-) 13 2 files changed, 5 insertions(+), 5 deletions(-)
14 14
15diff --git a/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in b/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in 15diff --git a/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in b/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in
16index 11b34c6..94c48f8 100644 16index ff43dae..f88b57c 100644
17--- a/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in 17--- a/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in
18+++ b/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in 18+++ b/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in
19@@ -15,8 +15,8 @@ EnvironmentFile=/etc/openvswitch/default.conf 19@@ -17,8 +17,8 @@ EnvironmentFile=-/etc/sysconfig/openvswitch
20 EnvironmentFile=-/etc/sysconfig/openvswitch 20 EnvironmentFile=-/run/openvswitch.useropts
21 EnvironmentFile=-/run/openvswitch/useropts 21 LimitSTACK=2M
22 @begin_dpdk@ 22 @begin_dpdk@
23-ExecStartPre=-/bin/sh -c '/usr/bin/chown :$${OVS_USER_ID##*:} /dev/hugepages' 23-ExecStartPre=-/bin/sh -c '/usr/bin/chown :$${OVS_USER_ID##*:} /dev/hugepages'
24-ExecStartPre=-/usr/bin/chmod 0775 /dev/hugepages 24-ExecStartPre=-/usr/bin/chmod 0775 /dev/hugepages
@@ -28,18 +28,20 @@ index 11b34c6..94c48f8 100644
28 ExecStart=/usr/share/openvswitch/scripts/ovs-ctl \ 28 ExecStart=/usr/share/openvswitch/scripts/ovs-ctl \
29 --no-ovsdb-server --no-monitor --system-id=random \ 29 --no-ovsdb-server --no-monitor --system-id=random \
30diff --git a/rhel/usr_lib_systemd_system_ovsdb-server.service b/rhel/usr_lib_systemd_system_ovsdb-server.service 30diff --git a/rhel/usr_lib_systemd_system_ovsdb-server.service b/rhel/usr_lib_systemd_system_ovsdb-server.service
31index 70da1ec..694598f 100644 31index 4c170c0..aad557f 100644
32--- a/rhel/usr_lib_systemd_system_ovsdb-server.service 32--- a/rhel/usr_lib_systemd_system_ovsdb-server.service
33+++ b/rhel/usr_lib_systemd_system_ovsdb-server.service 33+++ b/rhel/usr_lib_systemd_system_ovsdb-server.service
34@@ -10,8 +10,8 @@ Type=forking 34@@ -11,9 +11,9 @@ PIDFile=/var/run/openvswitch/ovsdb-server.pid
35 Restart=on-failure 35 Restart=on-failure
36 EnvironmentFile=/etc/openvswitch/default.conf 36 EnvironmentFile=/etc/openvswitch/default.conf
37 EnvironmentFile=-/etc/sysconfig/openvswitch 37 EnvironmentFile=-/etc/sysconfig/openvswitch
38-ExecStartPre=/usr/bin/chown ${OVS_USER_ID} /var/run/openvswitch /var/log/openvswitch 38-ExecStartPre=-/usr/bin/chown ${OVS_USER_ID} /var/run/openvswitch /var/log/openvswitch
39-ExecStartPre=/bin/sh -c 'rm -f /run/openvswitch/useropts; if [ "$${OVS_USER_ID/:*/}" != "root" ]; then /usr/bin/echo "OVSUSER=--ovs-user=${OVS_USER_ID}" > /run/openvswitch/useropts; fi' 39-ExecStartPre=/bin/sh -c 'rm -f /run/openvswitch.useropts; /usr/bin/echo "OVS_USER_ID=${OVS_USER_ID}" > /run/openvswitch.useropts'
40+ExecStartPre=/bin/chown ${OVS_USER_ID} /var/run/openvswitch /var/log/openvswitch 40-ExecStartPre=/bin/sh -c 'if [ "$${OVS_USER_ID/:*/}" != "root" ]; then /usr/bin/echo "OVS_USER_OPT=--ovs-user=${OVS_USER_ID}" >> /run/openvswitch.useropts; fi'
41+ExecStartPre=/bin/sh -c 'rm -f /run/openvswitch/useropts; if [ "$${OVS_USER_ID/:*/}" != "root" ]; then /bin/echo "OVSUSER=--ovs-user=${OVS_USER_ID}" > /run/openvswitch/useropts; fi' 41+ExecStartPre=-/bin/chown ${OVS_USER_ID} /var/run/openvswitch /var/log/openvswitch
42 EnvironmentFile=-/run/openvswitch/useropts 42+ExecStartPre=/bin/sh -c 'rm -f /run/openvswitch.useropts; /bin/echo "OVS_USER_ID=${OVS_USER_ID}" > /run/openvswitch.useropts'
43+ExecStartPre=/bin/sh -c 'if [ "$${OVS_USER_ID/:*/}" != "root" ]; then /bin/echo "OVS_USER_OPT=--ovs-user=${OVS_USER_ID}" >> /run/openvswitch.useropts; fi'
44 EnvironmentFile=-/run/openvswitch.useropts
43 ExecStart=/usr/share/openvswitch/scripts/ovs-ctl \ 45 ExecStart=/usr/share/openvswitch/scripts/ovs-ctl \
44 --no-ovs-vswitchd --no-monitor --system-id=random \ 46 --no-ovs-vswitchd --no-monitor --system-id=random \
45-- 47--
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index 072d7f14..141a609a 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -10,21 +10,21 @@ RDEPENDS_${PN}-ptest += "\
10 python3-datetime python3-netclient python3 sed \ 10 python3-datetime python3-netclient python3 sed \
11 ldd perl-module-socket perl-module-carp perl-module-exporter \ 11 ldd perl-module-socket perl-module-carp perl-module-exporter \
12 perl-module-xsloader python3-netserver python3-threading \ 12 perl-module-xsloader python3-netserver python3-threading \
13 python3-resource findutils which \ 13 python3-resource findutils which diffutils \
14 " 14 "
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17PV = "2.11+${SRCPV}" 17PV = "2.12+${SRCPV}"
18 18
19FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:" 19FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:"
20 20
21SRCREV = "f22ca8011fdb7e81ffce5017cd26539bccf50e94" 21SRCREV = "6beb94976e2b3e0c51430b63214de14186d8db39"
22SRC_URI = "file://openvswitch-switch \ 22SRC_URI = "file://openvswitch-switch \
23 file://openvswitch-switch-setup \ 23 file://openvswitch-switch-setup \
24 file://openvswitch-testcontroller \ 24 file://openvswitch-testcontroller \
25 file://openvswitch-testcontroller-setup \ 25 file://openvswitch-testcontroller-setup \
26 git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.11 \ 26 git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.12 \
27 file://openvswitch-add-ptest-78e203138cb7253e9ca5ad8a2c4ed6bb6752f23e.patch \ 27 file://openvswitch-add-ptest-6beb94976e2b3e0c51430b63214de14186d8db39.patch \
28 file://run-ptest \ 28 file://run-ptest \
29 file://disable_m4_check.patch \ 29 file://disable_m4_check.patch \
30 file://kernel_module.patch \ 30 file://kernel_module.patch \
@@ -33,6 +33,7 @@ SRC_URI = "file://openvswitch-switch \
33 file://python-switch-remaining-scripts-to-use-python3.patch \ 33 file://python-switch-remaining-scripts-to-use-python3.patch \
34 file://systemd-update-tool-paths.patch \ 34 file://systemd-update-tool-paths.patch \
35 file://systemd-create-runtime-dirs.patch \ 35 file://systemd-create-runtime-dirs.patch \
36 file://ovsdb-idlc.in-fix-dict-change-during-iteration.patch \
36 " 37 "
37 38
38LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab" 39LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"