summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch/openvswitch_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-06-20 16:25:54 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-06-21 14:25:14 -0400
commite86ae39489f1c17405d557f9204747594af29e6a (patch)
tree19896072691430242d237adbb7cf64bdeff5cbd1 /recipes-networking/openvswitch/openvswitch_git.bb
parentb263370eebd1df8befb9533da53c5ff8439607cc (diff)
downloadmeta-virtualization-e86ae39489f1c17405d557f9204747594af29e6a.tar.gz
openvswitch: switch to depending on python3
As far as I can tell openvswitch has been updated to work with python3 as well as with python(2). Switch to depend on python3 and use python3 for associated scripts. For the most part openvswitch will bind at runtime to either py2 or py3 regardless of these changes, with these changes we just do a better job of setting up the dependencies to facilitate py3 bindings. The openvswitch autotests results are mostly identical before and after this switch (failures move from python3 to python(2) test cases as expected, with some exceptions see below). When running the autotests/ptest with python(2) vs python3 we see a slightly higher failure rate (334 failures vs. 284 failures). I do not believe this higher fail rate reflects actual errors in the runtime, rather the tests are not adapted to python3. At any rate like the rest of openvswitch it is fairly straightforward to hack the logic for autotests to be run using py2 as long as it is available in the image, so these changes don't prevent falling back to py2 for autotests. This should facilitate any debugging we need to do based on us switching to favor py3. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking/openvswitch/openvswitch_git.bb')
-rw-r--r--recipes-networking/openvswitch/openvswitch_git.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index a17c273c..a2893e9d 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -3,12 +3,12 @@ require openvswitch.inc
3DEPENDS += "virtual/kernel" 3DEPENDS += "virtual/kernel"
4 4
5RDEPENDS_${PN}-ptest += "\ 5RDEPENDS_${PN}-ptest += "\
6 python-logging python-syslog python-argparse python-io \ 6 python3-logging python3-syslog python3-argparse python3-io \
7 python-fcntl python-shell python-lang python-xml python-math \ 7 python3-fcntl python3-shell python3-lang python3-xml python3-math \
8 python-datetime python-netclient python sed \ 8 python3-datetime python3-netclient python3 sed \
9 ldd perl-module-socket perl-module-carp perl-module-exporter \ 9 ldd perl-module-socket perl-module-carp perl-module-exporter \
10 perl-module-xsloader python-netserver python-threading \ 10 perl-module-xsloader python3-netserver python3-threading \
11 python-resource python-subprocess findutils which \ 11 python3-resource python3-subprocess findutils which \
12 " 12 "
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
@@ -30,6 +30,7 @@ SRC_URI = "file://openvswitch-switch \
30 file://0001-use-the-linux-if_packet.h-Interface-directly.patch \ 30 file://0001-use-the-linux-if_packet.h-Interface-directly.patch \
31 file://0002-Define-WAIT_ANY-if-not-provided-by-system.patch \ 31 file://0002-Define-WAIT_ANY-if-not-provided-by-system.patch \
32 file://CVE-2017-9263.patch \ 32 file://CVE-2017-9263.patch \
33 file://python-switch-remaining-scripts-to-use-python3.patch \
33 " 34 "
34 35
35LIC_FILES_CHKSUM = "file://COPYING;md5=17b2c9d4c70853a09c0e143137754b35" 36LIC_FILES_CHKSUM = "file://COPYING;md5=17b2c9d4c70853a09c0e143137754b35"