summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch/openvswitch_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-05-30 11:47:10 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-06-03 23:26:54 -0400
commit1fd1ff3720140baa3680d795f6d97597e5113e90 (patch)
tree41e63c2363391e512dae7cd1c8777db51ad928a1 /recipes-networking/openvswitch/openvswitch_git.bb
parent1a5853f87cfc0b16d992ed222bbb0ff6066b2617 (diff)
downloadmeta-virtualization-1fd1ff3720140baa3680d795f6d97597e5113e90.tar.gz
openvswitch: uprev to v2.9.2
This brings us up to date with the latest upstream release. I suspect there will be an upcoming release to add compatibility with DPDK v18.05 (the DPDK release is due out any day now) but getting this fairly large release bump out of the way first will facilitate any upcoming uprev. We are able to drop they python3 patches as they have been merged upstream. Some scripts which needed to be updated to use python3 disappeared, new ones appeared so the 'use python3' patches are updated accordingly. Beyond this the biggest change is related to the systemd unit files, the ovsdb-server has been updated upstream to be generated on the fly via the spec file, we mimic this in the install_prepend. We also add the various configuration files which the unit files source before launching the services. As usual this was tested against out typical usecases including usage in meta-overc. As well the ptests have been run and the results are no better or worse. Previous version: ERROR: 2332 tests were run, 21 failed unexpectedly. 3 tests were skipped. New version: ERROR: 2527 tests were run, 29 failed unexpectedly. 3 tests were skipped. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking/openvswitch/openvswitch_git.bb')
-rw-r--r--recipes-networking/openvswitch/openvswitch_git.bb22
1 files changed, 4 insertions, 18 deletions
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index c3a83019..9cdd4842 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -12,39 +12,26 @@ RDEPENDS_${PN}-ptest += "\
12 " 12 "
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15PV = "2.7.3+${SRCREV}" 15PV = "2.9.2+${SRCREV}"
16 16
17FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:" 17FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:"
18 18
19SRCREV = "b8dcfbebee9e7dbc74ec5eecc9b45d335d6150c1" 19SRCREV = "7e614671cba3c4e338d1c5003b74a10047d7a8eb"
20SRC_URI = "file://openvswitch-switch \ 20SRC_URI = "file://openvswitch-switch \
21 file://openvswitch-switch-setup \ 21 file://openvswitch-switch-setup \
22 file://openvswitch-testcontroller \ 22 file://openvswitch-testcontroller \
23 file://openvswitch-testcontroller-setup \ 23 file://openvswitch-testcontroller-setup \
24 git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.7 \ 24 git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.9 \
25 file://openvswitch-add-ptest-${SRCREV}.patch \ 25 file://openvswitch-add-ptest-${SRCREV}.patch \
26 file://run-ptest \ 26 file://run-ptest \
27 file://disable_m4_check.patch \ 27 file://disable_m4_check.patch \
28 file://kernel_module.patch \ 28 file://kernel_module.patch \
29 file://python-make-remaining-scripts-use-usr-bin-env.patch \ 29 file://python-make-remaining-scripts-use-usr-bin-env.patch \
30 file://0001-use-the-linux-if_packet.h-Interface-directly.patch \
31 file://0002-Define-WAIT_ANY-if-not-provided-by-system.patch \ 30 file://0002-Define-WAIT_ANY-if-not-provided-by-system.patch \
32 file://python-switch-remaining-scripts-to-use-python3.patch \ 31 file://python-switch-remaining-scripts-to-use-python3.patch \
32 file://systemd-update-tool-paths.patch \
33 " 33 "
34 34
35# Temporarily backport patches to better support py3. These have been
36# merged upstream but are not part of v2.7.1.
37SRC_URI += " \
38 file://0001-Python3-compatibility-Convert-print-statements.patch \
39 file://0002-Python3-compatibility-exception-cleanup.patch \
40 file://0003-Python3-compatibility-execfile-to-exec.patch \
41 file://0004-Python3-compatibility-iteritems-to-items.patch \
42 file://0005-Python3-compatibility-fix-integer-problems.patch \
43 file://0006-Python3-compatibility-math-error-compatibility.patch \
44 file://0007-Python3-compatibility-unicode-to-str.patch \
45 file://0008-AUTHORS-Add-Jason-Wessel.patch \
46"
47
48LIC_FILES_CHKSUM = "file://COPYING;md5=17b2c9d4c70853a09c0e143137754b35" 35LIC_FILES_CHKSUM = "file://COPYING;md5=17b2c9d4c70853a09c0e143137754b35"
49 36
50DPDK_INSTALL_DIR ?= "/opt/dpdk" 37DPDK_INSTALL_DIR ?= "/opt/dpdk"
@@ -71,5 +58,4 @@ do_install_ptest() {
71 58
72do_install_append() { 59do_install_append() {
73 oe_runmake modules_install INSTALL_MOD_PATH=${D} 60 oe_runmake modules_install INSTALL_MOD_PATH=${D}
74 rm -r ${D}/${localstatedir}/run
75} 61}