summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-5563e309b80bbea9bff538e71ecfd7e5e538bab9.patch
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-09-04 16:12:39 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-09-04 16:14:18 -0400
commite47cd6f12e91dfef4c874193b516869fbac4abda (patch)
tree7e8ea19a349b0a09120e4e8afbd591c0b988dca4 /recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-5563e309b80bbea9bff538e71ecfd7e5e538bab9.patch
parent5fe3950136d2db42c97cee245b88a893784ab4bc (diff)
downloadmeta-virtualization-e47cd6f12e91dfef4c874193b516869fbac4abda.tar.gz
openvswitch: uprev to v2.10.0
The current version (v2.9.3) started to fail to build due to changes in openssl. Upstream must have run into similar issues as this was identified and addressed in v2.10.0 by including a copy of 'dhparams.c' instead of relying on it being generated. (see commit "dhparams: Add pregenerated .c file to the repository.") Additionally v2.10.0 is better aligned for our kernel and dpdk versions: kernel === 2.10.x 3.10 to 4.17 dpdk === 2.10.x 17.11.3 The changes in this commit allow for the building of v2.10.0. A second commit will be necessary to deal with a few runtime changes which prevent ovsdb-server from starting correctly. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-5563e309b80bbea9bff538e71ecfd7e5e538bab9.patch')
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-5563e309b80bbea9bff538e71ecfd7e5e538bab9.patch110
1 files changed, 110 insertions, 0 deletions
diff --git a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-5563e309b80bbea9bff538e71ecfd7e5e538bab9.patch b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-5563e309b80bbea9bff538e71ecfd7e5e538bab9.patch
new file mode 100644
index 00000000..a8fc86c9
--- /dev/null
+++ b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-5563e309b80bbea9bff538e71ecfd7e5e538bab9.patch
@@ -0,0 +1,110 @@
1From 37df262d2b0f0b8c177aa850623f2c5880484ff0 Mon Sep 17 00:00:00 2001
2From: He Zhe <zhe.he@windriver.com>
3Date: Wed, 30 Mar 2016 06:23:45 -0400
4Subject: [PATCH] openvswitch: Add test-install rule to support ptest execution
5
6Signed-off-by: Radu Patriu <radu.patriu@enea.com>
7
8Fix ptest for v2.5
9 - Copy certain files from srcdir since it has been different from
10 build directory.
11 - Copy more necessary files for new added test cases.
12 - Modify config files for running on target.
13
14Signed-off-by: He Zhe <zhe.he@windriver.com>
15
16---
17 Makefile.am | 1 +
18 test.mk | 74 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
19 2 files changed, 75 insertions(+)
20 create mode 100644 test.mk
21
22diff --git a/Makefile.am b/Makefile.am
23index 7889728..6435399 100644
24--- a/Makefile.am
25+++ b/Makefile.am
26@@ -494,3 +494,4 @@ include windows/automake.mk
27 include ovn/automake.mk
28 include selinux/automake.mk
29 include build-aux/automake.mk
30+include test.mk
31diff --git a/test.mk b/test.mk
32new file mode 100644
33index 0000000..0b4587c
34--- /dev/null
35+++ b/test.mk
36@@ -0,0 +1,74 @@
37+TEST_DEST ?= ${prefix}/lib/openvswitch
38+TEST_ROOT ?= ${prefix}/lib/openvswitch
39+TEST_DEPEND =
40+
41+if HAVE_OPENSSL
42+TEST_DEPEND += $(TESTPKI_FILES)
43+endif
44+
45+test-install: $(TEST_DEPEND)
46+ @list='$(noinst_PROGRAMS) $(EXTRA_DIST) $(dist_check_SCRIPTS) $(TEST_DEPEND) tests/atlocal tests/atconfig' ;\
47+ install -d $(TEST_DEST)/tests ;\
48+ install $(srcdir)/vtep/ovs-vtep $(TEST_DEST)/tests ;\
49+ install -d $(TEST_DEST)/python ;\
50+ install -d $(TEST_DEST)/python/ovs ;\
51+ install -d $(TEST_DEST)/python/ovs/db ;\
52+ install -d $(TEST_DEST)/python/ovs/compat ;\
53+ install -d $(TEST_DEST)/python/ovs/compat/sortedcontainers ;\
54+ install -d $(TEST_DEST)/python/ovs/unixctl ;\
55+ install -d $(TEST_DEST)/vswitchd ;\
56+ install $(srcdir)/vswitchd/vswitch.ovsschema $(TEST_DEST)/vswitchd ;\
57+ install vswitchd/ovs-vswitchd $(TEST_DEST)/vswitchd ;\
58+ install -d $(TEST_DEST)/debian ;\
59+ install $(srcdir)/debian/ovs-monitor-ipsec $(TEST_DEST)/debian ;\
60+ install -d $(TEST_DEST)/build-aux ;\
61+ install $(srcdir)/build-aux/check-structs $(TEST_DEST)/build-aux ;\
62+ install -d $(TEST_DEST)/xenserver ;\
63+ install $(srcdir)/xenserver/usr_share_openvswitch_scripts_ovs-xapi-sync $(TEST_DEST)/xenserver ;\
64+ install $(srcdir)/xenserver/opt_xensource_libexec_interface-reconfigure $(TEST_DEST)/xenserver ;\
65+ install $(srcdir)/xenserver/opt_xensource_libexec_InterfaceReconfigure.py $(TEST_DEST)/xenserver ;\
66+ install $(srcdir)/xenserver/opt_xensource_libexec_InterfaceReconfigureBridge.py $(TEST_DEST)/xenserver ;\
67+ install $(srcdir)/xenserver/opt_xensource_libexec_InterfaceReconfigureVswitch.py $(TEST_DEST)/xenserver ;\
68+ install -d $(TEST_DEST)/vtep ;\
69+ install $(srcdir)/vtep/vtep.ovsschema $(TEST_DEST)/vtep ;\
70+ install -d $(TEST_DEST)/ovn ;\
71+ install $(srcdir)/ovn/ovn-nb.ovsschema $(TEST_DEST)/ovn ;\
72+ install $(srcdir)/ovn/ovn-sb.ovsschema $(TEST_DEST)/ovn ;\
73+ install -d $(TEST_DEST)/utilities ;\
74+ install $(srcdir)/utilities/ovs-pcap.in $(TEST_DEST)/utilities ;\
75+ install $(srcdir)/utilities/ovs-pki.in $(TEST_DEST)/utilities ;\
76+ for p in $$list ; do \
77+ echo $$p ;\
78+ p=$${p#../git/} ;\
79+ pre=$${p#tests\/} ;\
80+ if test $$pre != $$p ; then \
81+ echo installing $$p to $(TEST_DEST)/tests/$$pre ;\
82+ if test -f $$p ; then \
83+ install $$p $(TEST_DEST)/tests/$$pre ;\
84+ else \
85+ install $(srcdir)/$$p $(TEST_DEST)/tests/$$pre ;\
86+ fi ;\
87+ continue ;\
88+ fi ;\
89+ pre=$${p#python\/ovs\/} ;\
90+ if test $$pre != $$p ; then \
91+ echo installing $$p to $(TEST_DEST)/python/ovs/$$pre ;\
92+ if test -f $$p ; then \
93+ install $$p $(TEST_DEST)/python/ovs/$$pre ;\
94+ else \
95+ install $(srcdir)/$$p $(TEST_DEST)/python/ovs/$$pre ;\
96+ fi ;\
97+ continue ;\
98+ fi; \
99+ done ;\
100+ sed -i 's|abs_builddir=.*|abs_builddir='"'"'$(TEST_ROOT)/tests'"'"'|g' $(TEST_DEST)/tests/atconfig
101+ sed -i 's|abs_srcdir=.*|abs_srcdir='"'"'$(TEST_ROOT)/tests'"'"'|g' $(TEST_DEST)/tests/atconfig
102+ sed -i 's|abs_top_srcdir=.*|abs_top_srcdir='"'"'$(TEST_ROOT)'"'"'|g' $(TEST_DEST)/tests/atconfig
103+ sed -i 's|abs_top_builddir=.*|abs_top_builddir='"'"'$(TEST_ROOT)'"'"'|g' $(TEST_DEST)/tests/atconfig
104+ sed -i 's|at_srcdir=.*|at_srcdir='"'"'.'"'"'|g' $(TEST_DEST)/tests/atconfig
105+ sed -i 's|at_top_srcdir=.*|at_top_srcdir='"'"'..'"'"'|g' $(TEST_DEST)/tests/atconfig
106+ sed -i 's|at_top_build_prefix=.*|at_top_build_prefix='"'"'../'"'"'|g' $(TEST_DEST)/tests/atconfig
107+ sed -i 's|^\(.*config\.log.*\)|#\1|g' $(TEST_DEST)/tests/testsuite
108+ sed -i 's|$$srcdir|$$abs_srcdir|g' $(TEST_DEST)/tests/testsuite
109+ sed -i 's|ovs-appctl-bashcomp\.bash|/etc/bash_completion.d/ovs-appctl-bashcomp\.bash|g' $(TEST_DEST)/tests/testsuite
110+ sed -i 's|ovs-vsctl-bashcomp\.bash|/etc/bash_completion.d/ovs-vsctl-bashcomp\.bash|g' $(TEST_DEST)/tests/testsuite