summaryrefslogtreecommitdiffstats
path: root/recipes-networking/netns
diff options
context:
space:
mode:
authorPaul Barker <paul@betafive.co.uk>2019-01-08 13:34:24 +0000
committerBruce Ashfield <bruce.ashfield@windriver.com>2019-01-10 13:08:44 -0500
commitea4ea5fbc3f305fd3ce757573cbdacd23438f31d (patch)
treef6ef262dbeb0e743b82526cac21671fd2a3c3619 /recipes-networking/netns
parent2387a8876e4aaa52143a623ae5000cf064e55a64 (diff)
downloadmeta-virtualization-ea4ea5fbc3f305fd3ce757573cbdacd23438f31d.tar.gz
netns: Use correct go toolchain
If we don't explicitly set the GO variable as an argument to make then the native go toolchain is invoked instead of the cross-toolchain we actually want. This can result in a netns binary which is built for the wrong architecture. Signed-off-by: Paul Barker <paul@betafive.co.uk> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking/netns')
-rw-r--r--recipes-networking/netns/netns_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-networking/netns/netns_git.bb b/recipes-networking/netns/netns_git.bb
index 82a961bf..b6d35948 100644
--- a/recipes-networking/netns/netns_git.bb
+++ b/recipes-networking/netns/netns_git.bb
@@ -15,6 +15,8 @@ S = "${WORKDIR}/git"
15inherit goarch 15inherit goarch
16inherit go 16inherit go
17 17
18EXTRA_OEMAKE = "GO='${GO}'"
19
18do_compile() { 20do_compile() {
19 export GOARCH="${TARGET_GOARCH}" 21 export GOARCH="${TARGET_GOARCH}"
20 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go" 22 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"