summaryrefslogtreecommitdiffstats
path: root/recipes-networking/netns
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-03-20 15:54:50 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-03-20 15:55:03 -0400
commita050e7a61dac3d8fc2f8f68e763002b4a4664d71 (patch)
treee164e6ec28b789bda3d47741437ad2efb973e270 /recipes-networking/netns
parentb44fce825df56c0f26adb6ae1f647ae07f6096ee (diff)
downloadmeta-virtualization-a050e7a61dac3d8fc2f8f68e763002b4a4664d71.tar.gz
go: use inherit go versus explicit DEPENDS
We can now use the oe-core go bbclass to get our DEPENDS correct for building these go packages. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking/netns')
-rw-r--r--recipes-networking/netns/netns_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-networking/netns/netns_git.bb b/recipes-networking/netns/netns_git.bb
index 247b37d6..1efcf9a6 100644
--- a/recipes-networking/netns/netns_git.bb
+++ b/recipes-networking/netns/netns_git.bb
@@ -2,7 +2,6 @@ HOMEPAGE = "https://github.com/jfrazelle/netns"
2SUMMARY = "Runc hook for setting up default bridge networking." 2SUMMARY = "Runc hook for setting up default bridge networking."
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1"
5DEPENDS = "go-cross-${TARGET_ARCH}"
6 5
7SRC_URI = "git://github.com/jfrazelle/netns;branch=master" 6SRC_URI = "git://github.com/jfrazelle/netns;branch=master"
8SRCREV = "2804050eeab661bfa75c3aa06bdcf60273b02ca7" 7SRCREV = "2804050eeab661bfa75c3aa06bdcf60273b02ca7"
@@ -11,6 +10,7 @@ PV = "0.1.0+git${SRCPV}"
11S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
12 11
13inherit go-osarchmap 12inherit go-osarchmap
13inherit go
14 14
15do_compile() { 15do_compile() {
16 export GOARCH="${TARGET_GOARCH}" 16 export GOARCH="${TARGET_GOARCH}"