summaryrefslogtreecommitdiffstats
path: root/recipes-networking/netns
diff options
context:
space:
mode:
authorPaul Barker <paul@betafive.co.uk>2019-09-24 10:37:37 +0100
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-09-26 10:35:25 -0400
commit98cad7ae363b758355efb04c025ffb6461b6e2ce (patch)
tree30ada222e65aeb17ab1b4c642052a5f95dc777dd /recipes-networking/netns
parent4663fee526e86cdcb2a23d3f74822dd259eb9ee8 (diff)
downloadmeta-virtualization-98cad7ae363b758355efb04c025ffb6461b6e2ce.tar.gz
netns: Fix build on qemux86-64
The build has broken again on master, even for non-static builds of netns. The simplest fix is to extend our existing patch to cover this case as well. Signed-off-by: Paul Barker <paul@betafive.co.uk> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-networking/netns')
-rw-r--r--recipes-networking/netns/files/Makefile-force-rebuilding-all-packages-to-avoid-cgo.patch16
1 files changed, 11 insertions, 5 deletions
diff --git a/recipes-networking/netns/files/Makefile-force-rebuilding-all-packages-to-avoid-cgo.patch b/recipes-networking/netns/files/Makefile-force-rebuilding-all-packages-to-avoid-cgo.patch
index 3ed4c21e..e4967d2e 100644
--- a/recipes-networking/netns/files/Makefile-force-rebuilding-all-packages-to-avoid-cgo.patch
+++ b/recipes-networking/netns/files/Makefile-force-rebuilding-all-packages-to-avoid-cgo.patch
@@ -37,14 +37,20 @@ Forward-ported to v0.5.3.
37 37
38Signed-off-by: Paul Barker <paul@betafive.co.uk> 38Signed-off-by: Paul Barker <paul@betafive.co.uk>
39--- 39---
40 basic.mk | 2 +- 40 basic.mk | 4 ++--
41 1 file changed, 1 insertion(+), 1 deletion(-) 41 1 file changed, 2 insertions(+), 2 deletions(-)
42 42
43diff --git a/basic.mk b/basic.mk 43diff --git a/basic.mk b/basic.mk
44index 187dff3..fb080b7 100644 44index 187dff3..76a8d93 100644
45--- a/src/import/basic.mk 45--- a/src/import/basic.mk
46+++ b/src/import/basic.mk 46+++ b/src/import/basic.mk
47@@ -50,7 +50,7 @@ $(NAME): $(wildcard *.go) $(wildcard */*.go) VERSION.txt 47@@ -45,12 +45,12 @@ build: prebuild $(NAME) ## Builds a dynamic executable or package.
48
49 $(NAME): $(wildcard *.go) $(wildcard */*.go) VERSION.txt
50 @echo "+ $@"
51- $(GO) build -tags "$(BUILDTAGS)" ${GO_LDFLAGS} -o $(NAME) .
52+ $(GO) build -a -pkgdir dontusecurrentpkgs -tags "$(BUILDTAGS)" ${GO_LDFLAGS} -o $(NAME) .
53
48 .PHONY: static 54 .PHONY: static
49 static: prebuild ## Builds a static executable. 55 static: prebuild ## Builds a static executable.
50 @echo "+ $@" 56 @echo "+ $@"
@@ -54,5 +60,5 @@ index 187dff3..fb080b7 100644
54 ${GO_LDFLAGS_STATIC} -o $(NAME) . 60 ${GO_LDFLAGS_STATIC} -o $(NAME) .
55 61
56-- 62--
572.17.1 632.23.0
58 64