summaryrefslogtreecommitdiffstats
path: root/recipes-networking/netns
diff options
context:
space:
mode:
authorPaul Barker <pbarker@toganlabs.com>2017-10-05 13:38:16 +0000
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-10-05 10:44:04 -0400
commit81944693a030497ebf77f7ec9856ce23dca2ea88 (patch)
tree5139a5f1474b4782fe577222dcffc99bd752ebf3 /recipes-networking/netns
parent5d564365cff33041d3055b6bdeffc4b173665c8a (diff)
downloadmeta-virtualization-81944693a030497ebf77f7ec9856ce23dca2ea88.tar.gz
netns: Update to v0.2.1
Signed-off-by: Paul Barker <pbarker@toganlabs.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking/netns')
-rw-r--r--recipes-networking/netns/netns_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/recipes-networking/netns/netns_git.bb b/recipes-networking/netns/netns_git.bb
index 8e771f5b..44377647 100644
--- a/recipes-networking/netns/netns_git.bb
+++ b/recipes-networking/netns/netns_git.bb
@@ -4,8 +4,8 @@ LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1" 4LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1"
5 5
6SRC_URI = "git://github.com/jessfraz/netns;branch=master" 6SRC_URI = "git://github.com/jessfraz/netns;branch=master"
7SRCREV = "85b1ab9fcccbaa404a2636b52a48bbde02437cf7" 7SRCREV = "74e23a0e5c4e7ac011aafcc4623586c196f1b3ef"
8PV = "0.1.0+git${SRCPV}" 8PV = "0.2.1"
9GO_IMPORT = "import" 9GO_IMPORT = "import"
10 10
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
@@ -21,11 +21,12 @@ do_compile() {
21 # Go looks in a src directory under any directory in GOPATH but netns 21 # Go looks in a src directory under any directory in GOPATH but netns
22 # uses 'vendor' instead of 'vendor/src'. We can fix this with a symlink. 22 # uses 'vendor' instead of 'vendor/src'. We can fix this with a symlink.
23 # 23 #
24 # We also need to link in the ipallocator directory as that is not under 24 # We also need to link in the ipallocator and version directories as
25 # a src directory. 25 # they are not under the src directory.
26 ln -sfn . "${S}/src/import/vendor/src" 26 ln -sfn . "${S}/src/import/vendor/src"
27 mkdir -p "${S}/src/import/vendor/src/github.com/jessfraz/netns" 27 mkdir -p "${S}/src/import/vendor/src/github.com/jessfraz/netns"
28 ln -sfn "${S}/src/import/ipallocator" "${S}/src/import/vendor/src/github.com/jessfraz/netns/ipallocator" 28 ln -sfn "${S}/src/import/ipallocator" "${S}/src/import/vendor/src/github.com/jessfraz/netns/ipallocator"
29 ln -sfn "${S}/src/import/version" "${S}/src/import/vendor/src/github.com/jessfraz/netns/version"
29 export GOPATH="${S}/src/import/vendor" 30 export GOPATH="${S}/src/import/vendor"
30 31
31 # Pass the needed cflags/ldflags so that cgo 32 # Pass the needed cflags/ldflags so that cgo