summaryrefslogtreecommitdiffstats
path: root/recipes-networking/netns
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2017-09-13 12:39:46 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-09-14 09:49:00 -0400
commit01a8d4537012ad93dc8510e9b762acdc8c4536c7 (patch)
tree8b22ba0333f7a8c83193bee31b33a3b307f1164a /recipes-networking/netns
parent718592922bd64da4d609c96e831f6aba05e44a8d (diff)
downloadmeta-virtualization-01a8d4537012ad93dc8510e9b762acdc8c4536c7.tar.gz
nets, docker, runc, oci-*tools: go.bbclass compile fixes
Recently in the oe-core the go.bbclass changed and requires the defition of the GO_IMPORT variable. This was intended to simplify how the compilation works with go packages and it is still a work in progress. This patch set makes the recipes compatible to generate the same end result as before using the new go.bbclass from oe-core. Any patches that were included in the recipes had to have the paths adjusted because the new go.bbclass manipulates the notion of S to be S + "src" + "$GO_IMPORT" internally for the purpose of unpack, patch and compile. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking/netns')
-rw-r--r--recipes-networking/netns/netns_git.bb14
1 files changed, 8 insertions, 6 deletions
diff --git a/recipes-networking/netns/netns_git.bb b/recipes-networking/netns/netns_git.bb
index 641d55fc..8e771f5b 100644
--- a/recipes-networking/netns/netns_git.bb
+++ b/recipes-networking/netns/netns_git.bb
@@ -1,11 +1,12 @@
1HOMEPAGE = "https://github.com/jfrazelle/netns" 1HOMEPAGE = "https://github.com/jfrazelle/netns"
2SUMMARY = "Runc hook for setting up default bridge networking." 2SUMMARY = "Runc hook for setting up default bridge networking."
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1" 4LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1"
5 5
6SRC_URI = "git://github.com/jessfraz/netns;branch=master" 6SRC_URI = "git://github.com/jessfraz/netns;branch=master"
7SRCREV = "85b1ab9fcccbaa404a2636b52a48bbde02437cf7" 7SRCREV = "85b1ab9fcccbaa404a2636b52a48bbde02437cf7"
8PV = "0.1.0+git${SRCPV}" 8PV = "0.1.0+git${SRCPV}"
9GO_IMPORT = "import"
9 10
10S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
11 12
@@ -22,10 +23,10 @@ do_compile() {
22 # 23 #
23 # We also need to link in the ipallocator directory as that is not under 24 # We also need to link in the ipallocator directory as that is not under
24 # a src directory. 25 # a src directory.
25 ln -sfn . "${S}/vendor/src" 26 ln -sfn . "${S}/src/import/vendor/src"
26 mkdir -p "${S}/vendor/src/github.com/jessfraz/netns" 27 mkdir -p "${S}/src/import/vendor/src/github.com/jessfraz/netns"
27 ln -sfn "${S}/ipallocator" "${S}/vendor/src/github.com/jessfraz/netns/ipallocator" 28 ln -sfn "${S}/src/import/ipallocator" "${S}/src/import/vendor/src/github.com/jessfraz/netns/ipallocator"
28 export GOPATH="${S}/vendor" 29 export GOPATH="${S}/src/import/vendor"
29 30
30 # Pass the needed cflags/ldflags so that cgo 31 # Pass the needed cflags/ldflags so that cgo
31 # can find the needed headers files and libraries 32 # can find the needed headers files and libraries
@@ -35,10 +36,11 @@ do_compile() {
35 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 36 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
36 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 37 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
37 38
39 cd ${S}/src/import
38 oe_runmake static 40 oe_runmake static
39} 41}
40 42
41do_install() { 43do_install() {
42 install -d ${D}/${sbindir} 44 install -d ${D}/${sbindir}
43 install ${S}/netns ${D}/${sbindir}/netns 45 install ${S}/src/import/netns ${D}/${sbindir}/netns
44} 46}