summaryrefslogtreecommitdiffstats
path: root/recipes-networking/cni
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-05-26 13:03:11 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-06-04 08:43:11 -0400
commit6957b542e3212ae09afc2d66dd08917c44d97aaf (patch)
tree782d2a842716018ae5a83f937dc1a92da2717829 /recipes-networking/cni
parent9bacb690c1a8ddff2134eaaab3c69509a072746f (diff)
downloadmeta-virtualization-6957b542e3212ae09afc2d66dd08917c44d97aaf.tar.gz
cni/plugins: update to 0.9.1
Update the cni plugins part of the recipe to the 0.9.1 release: c4d4aa7 Remove Bryan Boreham as maintainer af26bab host-local: support ip/prefix in env args and CNI args f72aa98 [sbr]: Use different tableID for every ipCfg Check tableID not in use for every ipCfg 40c225e Small typo improves in README.md 76ef07e Allow multiple routes to be added for the same prefix. Enables ECMP d6bf1ea Update to lastest vendor/github.com/vishvananda/netlink bdaaa20 tuning: always update MAC in CNI result 33a2929 vendor: bump to libcni v1.0-rc1 820fee9 tuning: Add support of altering the allmulticast flag f34c600 [sbr]: Use different tableID for every ipCfg Move default table routes which match the ipCfg config 8f32968 Fix nil-pointer check 028fc2f host-local: support custom IPs allocation through runtime configuration 7da1c84 pkg/ip: introduce a new type `IP` to support formated <ip>[/<prefix>] 2eac102 go.mod: github.com/j-keck/arping v1.0.1 f4d2925 go.mod: github.com/buger/jsonparser v1.1.1 c3d0153 go.mod: github.com/alexflint/go-filemutex v1.1.0 75b64e0 go.mod github.com/Microsoft/hcsshim v0.8.16 bc85637 go.mod: godbus/dbus/v5 v5.0.3, coreos/go-systemd v22.2.0 d2d89dd go.mod: github.com/mattn/go-shellwords v1.0.11 59a6259 go.mod: github.com/sirupsen/logrus v1.8.1 3cc1135 CI: Install linux-modules-extra for VRF module 5b02c2a Fix broken links to online docs in plugin READMEs f275746 gha: update actions/setup-go@v2 b811967 remove redundant startRange in RangeIter due to overlap check on multi ranges 178d7c0 fix(win-bridge): panic while calling HNS api e09a17f portmap: use slashes in sysctl template to support interface names which separated by dots 9b09f16 pkg/ipam: use slash as sysctl separator so interface name can have dot e31cd2c [macvlan] Stop setting proxy-arp on macvlan interface 8e540bf tuning: increase test coverage to 1.0.0 and older spec versions d2e5b5d portmap: increase test coverage to 1.0.0 and older spec versions 8f7fe6d flannel: increase test coverage to 1.0.0 and older spec versions f33eedb firewall: increase test coverage to 1.0.0 and older spec versions da52be3 bandwidth: increase test coverage to 1.0.0 and older spec versions 02cdaaf host-local: increase test coverage to 1.0.0 and older spec versions f534133 static: increase test coverage to 1.0.0 and older spec versions 932653f dhcp: increase test coverage to 1.0.0 and older spec versions dd3f606 dhcp: add -resendmax option to limit lease acquisition time for testcases 4ddc8ba vlan: increase test coverage to 1.0.0 and older spec versions f56545c ptp: increase test coverage to 1.0.0 and older spec versions bbf7189 macvlan: increase test coverage to 1.0.0 and older spec versions 5eae558 loopback: increase test coverage to 1.0.0 and older spec versions 5096b53 ipvlan: increase test coverage to 1.0.0 and older spec versions 34cee8c host-device: increase test coverage to 1.0.0 and older spec versions c3c286c bridge: increase test coverage to 1.0.0 and older spec versions c8f341d bridge: simplify version-based testcase code 8c25db8 testutils: add test utilities for spec version features 7d8c767 plugins: update to spec version 1.0.0 9e2430b vendor: bump CNI to 1.0.0-pre @ 62e54113 Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-networking/cni')
-rw-r--r--recipes-networking/cni/cni_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-networking/cni/cni_git.bb b/recipes-networking/cni/cni_git.bb
index f7bead08..161b98b0 100644
--- a/recipes-networking/cni/cni_git.bb
+++ b/recipes-networking/cni/cni_git.bb
@@ -10,8 +10,8 @@ is simple to implement. \
10" 10"
11 11
12SRCREV_cni = "b5ab16f010e822936eb974690ecec38ba69afc01" 12SRCREV_cni = "b5ab16f010e822936eb974690ecec38ba69afc01"
13# Version 0.8.5 13# Version 0.9.1
14SRCREV_plugins = "fa48f7515b50272b7106702a662fadbf2ead3d18" 14SRCREV_plugins = "78702e9d8a2cdb6931fab433f1d1e6789162954f"
15SRC_URI = "\ 15SRC_URI = "\
16 git://github.com/containernetworking/cni.git;nobranch=1;name=cni \ 16 git://github.com/containernetworking/cni.git;nobranch=1;name=cni \
17 git://github.com/containernetworking/plugins.git;nobranch=1;destsuffix=${S}/src/github.com/containernetworking/plugins;name=plugins \ 17 git://github.com/containernetworking/plugins.git;nobranch=1;destsuffix=${S}/src/github.com/containernetworking/plugins;name=plugins \
@@ -69,4 +69,4 @@ INSANE_SKIP_${PN} += "ldflags already-stripped"
69 69
70deltask compile_ptest_base 70deltask compile_ptest_base
71 71
72RDEPENDS_${PN} += " ca-certificates" \ No newline at end of file 72RDEPENDS_${PN} += " ca-certificates"