summaryrefslogtreecommitdiffstats
path: root/recipes-networking/cni
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-10-05 11:13:17 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-10-05 15:50:41 -0400
commit4c0363bc9b0393971c01892e68b780a7b009934e (patch)
treeb066043f914c130fff13513cf321d7d2840f5e58 /recipes-networking/cni
parent9d4da563b0c6adb8cccbdae3e32e1a4be2fde96f (diff)
downloadmeta-virtualization-4c0363bc9b0393971c01892e68b780a7b009934e.tar.gz
cni: rprovide kubernetes-cni
Many distros make a 'kubernetes-cni' package available. This is no more than a binary extracted set of 'cni' plugins. We already have 'cni' available in the build system, so we make sure it rprovides kubernetes-cni to keep conflicts and confusion at a minimum. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking/cni')
-rw-r--r--recipes-networking/cni/cni_git.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-networking/cni/cni_git.bb b/recipes-networking/cni/cni_git.bb
index 137ce661..427a812f 100644
--- a/recipes-networking/cni/cni_git.bb
+++ b/recipes-networking/cni/cni_git.bb
@@ -16,6 +16,8 @@ SRC_URI = "\
16 git://github.com/containernetworking/plugins.git;nobranch=1;destsuffix=plugins;name=plugins \ 16 git://github.com/containernetworking/plugins.git;nobranch=1;destsuffix=plugins;name=plugins \
17 " 17 "
18 18
19RPROVIDES_${PN} += "kubernetes-cni"
20
19LICENSE = "Apache-2.0" 21LICENSE = "Apache-2.0"
20LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc" 22LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
21 23
@@ -78,7 +80,7 @@ do_compile() {
78} 80}
79 81
80do_install() { 82do_install() {
81 localbindir="/usr/local/bin" 83 localbindir="/opt/cni/bin"
82 84
83 install -d ${D}${localbindir} 85 install -d ${D}${localbindir}
84 install -d ${D}/${sysconfdir}/cni/net.d 86 install -d ${D}/${sysconfdir}/cni/net.d
@@ -87,7 +89,7 @@ do_install() {
87 install -m 755 -D ${WORKDIR}/plugins/bin/* ${D}/${localbindir} 89 install -m 755 -D ${WORKDIR}/plugins/bin/* ${D}/${localbindir}
88} 90}
89 91
90FILES_${PN} += "/usr/local/bin/*" 92FILES_${PN} += "/opt/cni/bin/*"
91 93
92INHIBIT_PACKAGE_STRIP = "1" 94INHIBIT_PACKAGE_STRIP = "1"
93INSANE_SKIP_${PN} += "ldflags already-stripped" 95INSANE_SKIP_${PN} += "ldflags already-stripped"