summaryrefslogtreecommitdiffstats
path: root/recipes-networking/cni/cni_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-01-25 14:44:26 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-03-15 17:17:19 +0000
commitf1892e34f6a827c21e4bd19fddf5cbabecb36dbc (patch)
tree3bf8891f7fe70a1f50b6322f46955017d940aee8 /recipes-networking/cni/cni_git.bb
parent2a217f7e9177665f1c0fb10f98eb58af91c7d01c (diff)
downloadmeta-virtualization-f1892e34f6a827c21e4bd19fddf5cbabecb36dbc.tar.gz
cni: convert recipe to vendor fetched format
The latest update to the CNI recipe brings in more vendor dependencies. To fix the build, we convert it to the same format as other vendored recipes in meta-virtualiation. The files in the udpated a recipe were created via: ./scripts/oe-go-mod-autogen.py --repo https://github.com/containernetworking/cni.git --rev b62753aa2bfa365c1ceaff6f25774a8047c896b5 Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-networking/cni/cni_git.bb')
-rw-r--r--recipes-networking/cni/cni_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-networking/cni/cni_git.bb b/recipes-networking/cni/cni_git.bb
index 59b56f6e..fda7af60 100644
--- a/recipes-networking/cni/cni_git.bb
+++ b/recipes-networking/cni/cni_git.bb
@@ -17,7 +17,17 @@ SRC_URI = "\
17 git://github.com/containernetworking/cni.git;branch=main;name=cni;protocol=https \ 17 git://github.com/containernetworking/cni.git;branch=main;name=cni;protocol=https \
18 git://github.com/containernetworking/plugins.git;branch=main;destsuffix=${S}/src/github.com/containernetworking/plugins;name=plugins;protocol=https \ 18 git://github.com/containernetworking/plugins.git;branch=main;destsuffix=${S}/src/github.com/containernetworking/plugins;name=plugins;protocol=https \
19 git://github.com/flannel-io/cni-plugin;branch=main;name=flannel_plugin;protocol=https;destsuffix=${S}/src/github.com/containernetworking/plugins/plugins/meta/flannel \ 19 git://github.com/flannel-io/cni-plugin;branch=main;name=flannel_plugin;protocol=https;destsuffix=${S}/src/github.com/containernetworking/plugins/plugins/meta/flannel \
20 file://modules.txt \
20 " 21 "
22
23# generated via:
24# ./scripts/oe-go-mod-autogen.py --repo https://github.com/containernetworking/cni.git --rev <insert your rev here>
25include src_uri.inc
26
27DEPENDS = " \
28 rsync-native \
29 "
30
21LICENSE = "Apache-2.0" 31LICENSE = "Apache-2.0"
22LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc" 32LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
23 33
@@ -31,10 +41,19 @@ inherit goarch
31# https://github.com/llvm/llvm-project/issues/53999 41# https://github.com/llvm/llvm-project/issues/53999
32TOOLCHAIN = "gcc" 42TOOLCHAIN = "gcc"
33 43
44# sets the "sites" variable.
45include relocation.inc
46
34do_compile() { 47do_compile() {
35 mkdir -p ${S}/src/github.com/containernetworking 48 mkdir -p ${S}/src/github.com/containernetworking
36 ln -sfr ${S}/src/import ${S}/src/github.com/containernetworking/cni 49 ln -sfr ${S}/src/import ${S}/src/github.com/containernetworking/cni
37 50
51 # our copied .go files are to be used for the build
52 ln -sf vendor.copy vendor
53
54 # inform go that we know what we are doing
55 cp ${WORKDIR}/modules.txt vendor/
56
38 export GO111MODULE=off 57 export GO111MODULE=off
39 58
40 cd ${B}/src/github.com/containernetworking/cni/libcni 59 cd ${B}/src/github.com/containernetworking/cni/libcni