summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-11-08 21:57:02 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-11-08 21:57:02 -0500
commitf3e3653d4dd96a69e07f6d2eae3644b51935c6a4 (patch)
tree463a0eef86b5eb2407baeda5743dfa64626853b6 /recipes-kernel
parent7223f80a2b3fc178c61f75f72ad985cf427bec8c (diff)
downloadmeta-virtualization-f3e3653d4dd96a69e07f6d2eae3644b51935c6a4.tar.gz
lopper: update to v1.0 and setuptools based project
Switching to lopper 1.0 brings us a more standard setuptools based project for install and packaging. This update also fixes the experimental update to master-next, which was incomplete and broken. The only signficant user visible change with this update is that lopper.py is now 'lopper' and any calling recipes need to be updated accordingly. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/lopper/lopper.bb45
-rw-r--r--recipes-kernel/lopper/lopper_git.bb31
2 files changed, 31 insertions, 45 deletions
diff --git a/recipes-kernel/lopper/lopper.bb b/recipes-kernel/lopper/lopper.bb
deleted file mode 100644
index f36b898c..00000000
--- a/recipes-kernel/lopper/lopper.bb
+++ /dev/null
@@ -1,45 +0,0 @@
1SUMMARY = "Device Tree Lopper"
2DESCRIPTION = "Tool for manipulation of system device tree files"
3LICENSE = "BSD-3-Clause"
4SECTION = "bootloader"
5
6SRC_URI = "git://github.com/devicetree-org/lopper.git;branch=master-next;protocol=https"
7SRCREV = "3e6aa522d2469ba7563fc6691802cf4aae3d2fd7"
8S = "${WORKDIR}/git"
9
10LIC_FILES_CHKSUM = "file://LICENSE.md;md5=8e5f5f691f01c9fdfa7a7f2d535be619"
11
12RDEPENDS:${PN} = " \
13 python3-core \
14 python3-dtc \
15 python3-humanfriendly \
16 "
17
18do_install() {
19 install -d "${D}/${bindir}"
20 install -d "${D}/${datadir}/${BPN}"
21
22 install -m 0644 "${S}/README.md" "${D}/${datadir}/${BPN}"
23 install -m 0644 "${S}/README-architecture.md" "${D}/${datadir}/${BPN}"
24 install -m 0644 "${S}/README.pydoc" "${D}/${datadir}/${BPN}"
25 install -m 0644 "${S}/LICENSE.md" "${D}/${datadir}/${BPN}"
26
27 install -d "${D}/${datadir}/${BPN}/lopper/assists"
28 cp -r "${S}/lopper/assists/"* "${D}/${datadir}/${BPN}/lopper/assists/"
29
30 install -d "${D}/${datadir}/${BPN}/lopper/lops"
31 install -m 0644 "${S}/lopper/lops/"* "${D}/${datadir}/${BPN}/lopper/lops/"
32
33 install -d "${D}/${datadir}/${BPN}/device-trees"
34 install -m 0644 "${S}/device-trees/"* "${D}/${datadir}/${BPN}/device-trees/"
35
36 install -m 0755 "${S}/"lopper*.py "${D}/${datadir}/${BPN}/"
37
38 datadir_relpath=${@os.path.relpath(d.getVar('datadir'), d.getVar('bindir'))}
39 ln -s "${datadir_relpath}/${BPN}/lopper.py" "${D}/${bindir}/"
40}
41
42do_configure[noexec] = "1"
43do_compile[noexec] = "1"
44
45BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-kernel/lopper/lopper_git.bb b/recipes-kernel/lopper/lopper_git.bb
new file mode 100644
index 00000000..606dab64
--- /dev/null
+++ b/recipes-kernel/lopper/lopper_git.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Device Tree Lopper"
2DESCRIPTION = "Tool for manipulation of system device tree files"
3LICENSE = "BSD-3-Clause"
4SECTION = "bootloader"
5
6SRC_URI = "git://github.com/devicetree-org/lopper.git;branch=master;protocol=https"
7SRCREV = "3c81fcce08eeb64cbbde1535abd83572985a8689"
8S = "${WORKDIR}/git"
9
10PV="v1.0+git${SRCPV}"
11
12LIC_FILES_CHKSUM = "file://LICENSE.md;md5=8e5f5f691f01c9fdfa7a7f2d535be619"
13
14RDEPENDS:${PN} = " \
15 python3-core \
16 python3-dtc \
17 python3-humanfriendly \
18 "
19
20inherit setuptools3
21
22INHIBIT_PACKAGE_STRIP = "1"
23
24do_install:append() {
25 # we have to remove the vendor'd libfdt, since an attempt to strip it
26 # will be made, and it will fail in a cross environment.
27 rm -rf ${D}/${PYTHON_SITEPACKAGES_DIR}/${BPN}/vendor
28}
29
30BBCLASSEXTEND = "native nativesdk"
31