summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorDavid Nyström <david.nystrom@enea.com>2012-12-06 14:02:18 +0100
committerDavid Nyström <david.nystrom@enea.com>2012-12-07 15:32:31 +0100
commit20b24d56952b6d77ec7c702b19d48acca16f7aa9 (patch)
tree80a20ac5b7e87cbb7d9c45c140f7f7e2d007d1ad /recipes-kernel
parente2a26a782440c2269a72dc933dc3959db2087af6 (diff)
downloadmeta-virtualization-20b24d56952b6d77ec7c702b19d48acca16f7aa9.tar.gz
Added kernel configuration for LxC and in kernel OpenvSwitch
Signed-off-by: David Nyström <david.nystrom@enea.com> Reviewed-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-yocto/lxc.cfg22
-rw-r--r--recipes-kernel/linux/linux-yocto/lxc.scc4
-rw-r--r--recipes-kernel/linux/linux-yocto/vswitch.cfg2
-rw-r--r--recipes-kernel/linux/linux-yocto/vswitch.scc4
-rw-r--r--recipes-kernel/linux/linux-yocto_3.4.bbappend5
5 files changed, 36 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-yocto/lxc.cfg b/recipes-kernel/linux/linux-yocto/lxc.cfg
new file mode 100644
index 00000000..f720ca6d
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto/lxc.cfg
@@ -0,0 +1,22 @@
1CONFIG_CGROUP_DEVICE=y
2CONFIG_CPUSETS=y
3CONFIG_PROC_PID_CPUSET=y
4CONFIG_RESOURCE_COUNTERS=y
5CONFIG_CGROUP_MEM_RES_CTLR=y
6CONFIG_CGROUP_SCHED=y
7CONFIG_FAIR_GROUP_SCHED=y
8CONFIG_RT_GROUP_SCHED=y
9CONFIG_CHECKPOINT_RESTORE=y
10CONFIG_NAMESPACES=y
11CONFIG_UTS_NS=y
12CONFIG_IPC_NS=y
13CONFIG_USER_NS=y
14CONFIG_PID_NS=y
15CONFIG_NET_NS=y
16CONFIG_SECCOMP=y
17CONFIG_SECURITY_APPARMOR=y
18
19CONFIG_CLS_CGROUP=m
20CONFIG_BLK_CGROUP=m
21CONFIG_NETPRIO_CGROUP=m
22
diff --git a/recipes-kernel/linux/linux-yocto/lxc.scc b/recipes-kernel/linux/linux-yocto/lxc.scc
new file mode 100644
index 00000000..ee518835
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto/lxc.scc
@@ -0,0 +1,4 @@
1define KFEATURE_DESCRIPTION "Enable Features needed by LxC, namespaces, cgroups et.c."
2define KFEATURE_COMPATIBILITY board
3
4kconf non-hardware lxc.cfg
diff --git a/recipes-kernel/linux/linux-yocto/vswitch.cfg b/recipes-kernel/linux/linux-yocto/vswitch.cfg
new file mode 100644
index 00000000..fcc0ca68
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto/vswitch.cfg
@@ -0,0 +1,2 @@
1CONFIG_OPENVSWITCH=m
2
diff --git a/recipes-kernel/linux/linux-yocto/vswitch.scc b/recipes-kernel/linux/linux-yocto/vswitch.scc
new file mode 100644
index 00000000..2790b4fe
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto/vswitch.scc
@@ -0,0 +1,4 @@
1define KFEATURE_DESCRIPTION "Enable in kernel OpenvSwitch module"
2define KFEATURE_COMPATIBILITY board
3
4kconf non-hardware vswitch.cfg
diff --git a/recipes-kernel/linux/linux-yocto_3.4.bbappend b/recipes-kernel/linux/linux-yocto_3.4.bbappend
index dc97c1b8..5b163fff 100644
--- a/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -1,5 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3SRC_URI += "file://xt-checksum.scc \ 3SRC_URI += "file://xt-checksum.scc \
4 file://ebtables.scc " 4 file://ebtables.scc \
5 file://vswitch.scc \
6 file://lxc.scc \
7 "
5 8