summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-01-19 09:53:08 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-01-19 09:53:11 -0500
commit9377e68bcd4bd4dd686807f43adac90dfed20da7 (patch)
tree94be99b53e2f234288cae18a69902a4c3c1cd189 /recipes-kernel/linux
parentd62fe6dbd116990c19c13899c79341e7452fe335 (diff)
downloadmeta-virtualization-9377e68bcd4bd4dd686807f43adac90dfed20da7.tar.gz
xen: clone 4.1 config to 4.4
4.4 is available in oe-core, and will be built by default in many configurations. That leaves us either needing to force the preferred version or copy our config to 4.4. This is a direct clone of the 4.1 config to 4.4, and is currently untested, but forms a baseline for more updates. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-yocto_4.4.bbappend19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto_4.4.bbappend b/recipes-kernel/linux/linux-yocto_4.4.bbappend
new file mode 100644
index 00000000..85e98cc6
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto_4.4.bbappend
@@ -0,0 +1,19 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "file://xt-checksum.scc \
4 file://ebtables.scc \
5 file://vswitch.scc \
6 file://lxc.scc \
7 "
8KERNEL_FEATURES_append = " features/kvm/qemu-kvm-enable.scc"
9
10KERNEL_MODULE_AUTOLOAD += "openvswitch"
11KERNEL_MODULE_AUTOLOAD += "kvm"
12KERNEL_MODULE_AUTOLOAD += "kvm-amd"
13KERNEL_MODULE_AUTOLOAD += "kvm-intel"
14
15# aufs kernel support required for xen-image-minimal
16KERNEL_FEATURES_append += "${@base_contains('DISTRO_FEATURES', 'aufs', ' features/aufs/aufs-enable.scc', '', d)}"
17
18# xen kernel support
19SRC_URI += "${@base_contains('DISTRO_FEATURES', 'xen', ' file://xen.scc', '', d)}"