summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-yocto_4.12.bbappend
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-09-13 12:50:02 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-09-13 12:50:02 -0400
commit537971d35ad65c7a3e5aee832f3262e0b0c41d73 (patch)
treee397f980780738f4128538fde723e7ee3dd12604 /recipes-kernel/linux/linux-yocto_4.12.bbappend
parentba35378ce5e24f2bfcb85caa806774b873983d9f (diff)
downloadmeta-virtualization-537971d35ad65c7a3e5aee832f3262e0b0c41d73.tar.gz
kernel: add linux-yocto 4.12 bappend
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-kernel/linux/linux-yocto_4.12.bbappend')
-rw-r--r--recipes-kernel/linux/linux-yocto_4.12.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto_4.12.bbappend b/recipes-kernel/linux/linux-yocto_4.12.bbappend
new file mode 100644
index 00000000..f163fdfc
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto_4.12.bbappend
@@ -0,0 +1,20 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "file://xt-checksum.scc \
4 file://ebtables.scc \
5 file://vswitch.scc \
6 file://lxc.scc \
7 file://docker.scc \
8 "
9KERNEL_FEATURES_append = " features/kvm/qemu-kvm-enable.scc"
10
11KERNEL_MODULE_AUTOLOAD += "openvswitch"
12KERNEL_MODULE_AUTOLOAD += "kvm"
13KERNEL_MODULE_AUTOLOAD += "kvm-amd"
14KERNEL_MODULE_AUTOLOAD += "kvm-intel"
15
16# aufs kernel support required for xen-image-minimal
17KERNEL_FEATURES_append += "${@bb.utils.contains('DISTRO_FEATURES', 'aufs', ' features/aufs/aufs-enable.scc', '', d)}"
18
19# xen kernel support
20SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'xen', ' file://xen.scc', '', d)}"