summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-01-22 16:07:51 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-22 16:07:51 +0000
commitd4b8bad25b12611ecbc4f08b01300762dd7822ae (patch)
treeded59dcef0abcc59fdc2d7e81ddfd19830861c94 /recipes-graphics
parent56c3ce96a2a68669892777bb4a8dea4e942106f7 (diff)
downloadmeta-virtualization-d4b8bad25b12611ecbc4f08b01300762dd7822ae.tar.gz
xorg-xserver: make changes conditional on xen distro feature
The changes in this bbappend should only trigger when xen is in the distro features. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend13
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_xen.inc13
2 files changed, 14 insertions, 12 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
index 95034045..f5ae9033 100644
--- a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
@@ -1,13 +1,2 @@
1# Change the default Xserver OpenGL configuration for non-x86 distros with Xen: deselect 'glamor'. 1require ${@bb.utils.contains('DISTRO_FEATURES', 'xen', '${BPN}_xen.inc', '', d)}
2# This removes the dependency on libegl to simplify the domU build.
3#
4# To override this (eg. if wanted for dom0 images) define:
5# REMOVED_OPENGL_PKGCONFIGS = ""
6 2
7XEN_REMOVED_OPENGL_PKGCONFIGS ?= "glamor"
8XEN_REMOVED_OPENGL_PKGCONFIGS_x86 = ""
9XEN_REMOVED_OPENGL_PKGCONFIGS_x86-64 = ""
10
11REMOVED_OPENGL_PKGCONFIGS ?= "${@bb.utils.contains('DISTRO_FEATURES', 'xen', "${XEN_REMOVED_OPENGL_PKGCONFIGS}", '', d)}"
12
13OPENGL_PKGCONFIGS_remove = "${REMOVED_OPENGL_PKGCONFIGS}"
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_xen.inc b/recipes-graphics/xorg-xserver/xserver-xorg_xen.inc
new file mode 100644
index 00000000..95034045
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_xen.inc
@@ -0,0 +1,13 @@
1# Change the default Xserver OpenGL configuration for non-x86 distros with Xen: deselect 'glamor'.
2# This removes the dependency on libegl to simplify the domU build.
3#
4# To override this (eg. if wanted for dom0 images) define:
5# REMOVED_OPENGL_PKGCONFIGS = ""
6
7XEN_REMOVED_OPENGL_PKGCONFIGS ?= "glamor"
8XEN_REMOVED_OPENGL_PKGCONFIGS_x86 = ""
9XEN_REMOVED_OPENGL_PKGCONFIGS_x86-64 = ""
10
11REMOVED_OPENGL_PKGCONFIGS ?= "${@bb.utils.contains('DISTRO_FEATURES', 'xen', "${XEN_REMOVED_OPENGL_PKGCONFIGS}", '', d)}"
12
13OPENGL_PKGCONFIGS_remove = "${REMOVED_OPENGL_PKGCONFIGS}"