summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2017-09-17 18:21:38 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-09-19 09:22:55 -0400
commit33e8e20d3c52afbbaf3675383fedc20225f2c19b (patch)
tree12e928185ed2e581331261c4b318f6b84013140c /recipes-graphics
parent55b1cbe55dcd356e4d6b257ee1f58df9bb728665 (diff)
downloadmeta-virtualization-33e8e20d3c52afbbaf3675383fedc20225f2c19b.tar.gz
xen-guest-image-minimal: Fix non-x86. Select x11 via IMAGE_FEATURES.
Fix the image for non-x86, both with and without x11 included. * Only install xf86-video-vesa on x86 platforms as it is not available elsewhere. * In the absence of xf86-video-vesa (ie. on non-x86 platforms) enable opengl and remove wayland from IMAGE_INSTALL to satisfy build requirements for x11. * Use IMAGE_FEATURES instead of DISTRO_FEATURES to enable x11 inclusion in the image. * Verify the required DISTRO_FEATURE of 'xen' and if enabled, 'x11'. * When building the Xserver with Xen in DISTRO_FEATURES, on non-x86, turn off glamor by default, to remove dependency on egl. Introduces: xserver-xorg_%.bbappend Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
new file mode 100644
index 00000000..95034045
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
@@ -0,0 +1,13 @@
1# Change the default Xserver OpenGL configuration for non-x86 distros with Xen: deselect 'glamor'.
2# This removes the dependency on libegl to simplify the domU build.
3#
4# To override this (eg. if wanted for dom0 images) define:
5# REMOVED_OPENGL_PKGCONFIGS = ""
6
7XEN_REMOVED_OPENGL_PKGCONFIGS ?= "glamor"
8XEN_REMOVED_OPENGL_PKGCONFIGS_x86 = ""
9XEN_REMOVED_OPENGL_PKGCONFIGS_x86-64 = ""
10
11REMOVED_OPENGL_PKGCONFIGS ?= "${@bb.utils.contains('DISTRO_FEATURES', 'xen', "${XEN_REMOVED_OPENGL_PKGCONFIGS}", '', d)}"
12
13OPENGL_PKGCONFIGS_remove = "${REMOVED_OPENGL_PKGCONFIGS}"