summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorJeremy Puhlman <jpuhlman@mvista.com>2020-01-29 14:20:09 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-02-03 17:08:30 -0500
commitc487e0f511ab5bf61e559ba8476fab232369633c (patch)
tree025696729f91885e88dc093e7d1beb80e2dc92a9 /recipes-extended
parent7c42107c713abff639bc536484714f5c25f57948 (diff)
downloadmeta-virtualization-c487e0f511ab5bf61e559ba8476fab232369633c.tar.gz
libvirt: Use python3-native for python install
Signed-off-by: Jeremy Puhlman <jpuhlman@mvista.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/libvirt/libvirt-python.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-extended/libvirt/libvirt-python.inc b/recipes-extended/libvirt/libvirt-python.inc
index 02fca548..d15500ea 100644
--- a/recipes-extended/libvirt/libvirt-python.inc
+++ b/recipes-extended/libvirt/libvirt-python.inc
@@ -42,14 +42,14 @@ python __anonymous () {
42do_compile_append() { 42do_compile_append() {
43 if [ "${LIBVIRT_PYTHON_ENABLE}" = "1" ]; then 43 if [ "${LIBVIRT_PYTHON_ENABLE}" = "1" ]; then
44 cd ${WORKDIR}/${BPN}-python-${PV} && \ 44 cd ${WORKDIR}/${BPN}-python-${PV} && \
45 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build 45 ${STAGING_BINDIR_NATIVE}/python3-native/python3 setup.py build
46 fi 46 fi
47} 47}
48 48
49do_install_append() { 49do_install_append() {
50 if [ "${LIBVIRT_PYTHON_ENABLE}" = "1" ]; then 50 if [ "${LIBVIRT_PYTHON_ENABLE}" = "1" ]; then
51 cd ${WORKDIR}/${BPN}-python-${PV} && \ 51 cd ${WORKDIR}/${BPN}-python-${PV} && \
52 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py install \ 52 ${STAGING_BINDIR_NATIVE}/python3-native/python3 setup.py install \
53 --install-lib=${D}/${PYTHON_SITEPACKAGES_DIR} ${LIBVIRT_INSTALL_ARGS} 53 --install-lib=${D}/${PYTHON_SITEPACKAGES_DIR} ${LIBVIRT_INSTALL_ARGS}
54 fi 54 fi
55} 55}