summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-05-14 11:51:53 +0200
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-05-14 08:28:42 -0400
commitaea26f7791d221ccd4865f69ca8db237571963ee (patch)
tree8c4f0ebb32ee830059d671dfbe49abd7d9761390 /recipes-extended
parent670fbe932cb83581a1288eb16d288ba95f10222d (diff)
downloadmeta-virtualization-aea26f7791d221ccd4865f69ca8db237571963ee.tar.gz
ipxe: Inhibit -Werror to fix build with gcc-11
* with gcc-11 it fails with: drivers/net/ath/ath5k/ath5k_eeprom.c:437:65: error: 'val' may be used uninitialized [-Werror=maybe-uninitialized] 437 | ee->ee_switch_settling_turbo[mode] = (val >> 8) & 0x7f; | ~~~~~~~~~~~^~~~~~ tests/bigint_test.c: In function 'bigint_test_exec': tests/bigint_test.c:232:14: error: 'result_raw' may be used uninitialized [-Werror=maybe-uninitialized] 232 | ok ( memcmp ( result_raw, expected_raw, \ | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 233 | sizeof ( result_raw ) ) == 0 ); \ | ~~~~~~~~~~~~~~~~~~~~~~~ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/ipxe/ipxe_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-extended/ipxe/ipxe_git.bb b/recipes-extended/ipxe/ipxe_git.bb
index 43c8f0ed..9e98495a 100644
--- a/recipes-extended/ipxe/ipxe_git.bb
+++ b/recipes-extended/ipxe/ipxe_git.bb
@@ -28,6 +28,7 @@ EXTRA_OEMAKE = " \
28 CROSS_COMPILE="${TARGET_PREFIX}" \ 28 CROSS_COMPILE="${TARGET_PREFIX}" \
29 EXTRA_HOST_CFLAGS="${BUILD_CFLAGS}" \ 29 EXTRA_HOST_CFLAGS="${BUILD_CFLAGS}" \
30 EXTRA_HOST_LDFLAGS="${BUILD_LDFLAGS}" \ 30 EXTRA_HOST_LDFLAGS="${BUILD_LDFLAGS}" \
31 NO_WERROR="1" \
31" 32"
32 33
33S = "${WORKDIR}/git/src" 34S = "${WORKDIR}/git/src"