summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-05-14 10:27:09 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-14 18:27:09 -0400
commit9ae9894c154c967d5dd198dc77e7cf4e5f72a114 (patch)
treec39ea6339fb3d51cc6b22ea2edb4c2ab528bfdb6 /recipes-extended
parent4d8814f0d191457290eacc06cc94051e253cc2a6 (diff)
downloadmeta-virtualization-9ae9894c154c967d5dd198dc77e7cf4e5f72a114.tar.gz
libvirt: uprev to 1.2.4
Updating the version of libvirt to 1.2.4. Only small changes are required to the ptest and python chnages for this new version, but otherwise, all packaging and build optinos are the same. Sanity tests show no regressions from 1.2.2. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/libvirt/libvirt-python.inc4
-rw-r--r--recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch88
-rw-r--r--recipes-extended/libvirt/libvirt/runptest.patch31
-rw-r--r--recipes-extended/libvirt/libvirt_1.2.4.bb (renamed from recipes-extended/libvirt/libvirt_1.2.2.bb)4
4 files changed, 61 insertions, 66 deletions
diff --git a/recipes-extended/libvirt/libvirt-python.inc b/recipes-extended/libvirt/libvirt-python.inc
index 181e9d3c..1c95b07f 100644
--- a/recipes-extended/libvirt/libvirt-python.inc
+++ b/recipes-extended/libvirt/libvirt-python.inc
@@ -18,8 +18,8 @@ FILES_${PN}-python = "${bindir}/* ${libdir}/* ${libdir}/${PYTHON_DIR}/*"
18SRC_URI += "http://libvirt.org/sources/python/libvirt-python-${PV}.tar.gz;name=libvirt_python" 18SRC_URI += "http://libvirt.org/sources/python/libvirt-python-${PV}.tar.gz;name=libvirt_python"
19SRC_URI += "file://libvirt_api_xml_path.patch;patchdir=../libvirt-python-${PV}" 19SRC_URI += "file://libvirt_api_xml_path.patch;patchdir=../libvirt-python-${PV}"
20 20
21SRC_URI[libvirt_python.md5sum] = "cd3b75c0eb64e933f0b648fbdca6e868" 21SRC_URI[libvirt_python.md5sum] = "fbcb68f898390b321cbfcbdaa8d0c1ba"
22SRC_URI[libvirt_python.sha256sum] = "94d79d662b6010f6c688b8856b2d95077736d48ffa35feed5a339d7fafbf8c39" 22SRC_URI[libvirt_python.sha256sum] = "a2f30059b8870b3808b2bd2f19210422a348649a8f53523c2cbfa5cd64af217e"
23 23
24export LIBVIRT_API_PATH = "${S}/docs/libvirt-api.xml" 24export LIBVIRT_API_PATH = "${S}/docs/libvirt-api.xml"
25export LIBVIRT_CFLAGS = "-I${S}/include" 25export LIBVIRT_CFLAGS = "-I${S}/include"
diff --git a/recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch b/recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch
index 0aa3bde2..16321db5 100644
--- a/recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch
+++ b/recipes-extended/libvirt/libvirt/libvirt_api_xml_path.patch
@@ -14,41 +14,26 @@ Signed-off-by: Martin Kletzander <mkletzan redhat com>
14 setup.py | 25 ++++++++++++++++++++++--- 14 setup.py | 25 ++++++++++++++++++++++---
15 1 file changed, 22 insertions(+), 3 deletions(-) 15 1 file changed, 22 insertions(+), 3 deletions(-)
16 16
17Index: libvirt-python-1.2.1/setup.py 17Index: libvirt-python-1.2.4/setup.py
18=================================================================== 18===================================================================
19--- libvirt-python-1.2.1.orig/setup.py 19--- libvirt-python-1.2.4.orig/setup.py
20+++ libvirt-python-1.2.1/setup.py 20+++ libvirt-python-1.2.4/setup.py
21@@ -30,18 +30,19 @@ 21@@ -40,13 +40,7 @@
22 if pkgcfg is None: 22 "libvirt"])
23 raise Exception("pkg-config binary is required to compile libvirt-python")
24 23
25-spawn([pkgcfg, 24 def have_libvirt_lxc():
26- "--print-errors", 25- try:
27- "--atleast-version=%s" % MIN_LIBVIRT, 26- spawn([get_pkgcfg(),
28- "libvirt"]) 27- "--atleast-version=%s" % MIN_LIBVIRT_LXC,
29+# spawn([pkgcfg, 28- "libvirt"])
30+# "--print-errors", 29- return True
31+# "--atleast-version=%s" % MIN_LIBVIRT, 30- except DistutilsExecError:
32+# "libvirt"]) 31- return False
33 32+ return True
34 have_libvirt_lxc=True
35-try:
36- spawn([pkgcfg,
37- "--atleast-version=%s" % MIN_LIBVIRT_LXC,
38- "libvirt"])
39-except DistutilsExecError:
40- have_libvirt_lxc=False
41+# try:
42+# spawn([pkgcfg,
43+# "--atleast-version=%s" % MIN_LIBVIRT_LXC,
44+# "libvirt"])
45+# except DistutilsExecError:
46+# have_libvirt_lxc=False
47+have_libvirt_lxc=True
48 33
49 def get_pkgconfig_data(args, mod, required=True): 34 def get_pkgconfig_data(args, mod, required=True):
50 """Run pkg-config to and return content associated with it""" 35 """Run pkg-config to and return content associated with it"""
51@@ -63,7 +64,17 @@ 36@@ -68,7 +62,17 @@
52 """Check with pkg-config that libvirt is present and extract 37 """Check with pkg-config that libvirt is present and extract
53 the API XML file paths we need from it""" 38 the API XML file paths we need from it"""
54 39
@@ -67,23 +52,32 @@ Index: libvirt-python-1.2.1/setup.py
67 52
68 offset = libvirt_api.index("-api.xml") 53 offset = libvirt_api.index("-api.xml")
69 libvirt_qemu_api = libvirt_api[0:offset] + "-qemu-api.xml" 54 libvirt_qemu_api = libvirt_api[0:offset] + "-qemu-api.xml"
70@@ -73,8 +84,17 @@ 55@@ -88,8 +92,17 @@
71
72 return (libvirt_api, libvirt_qemu_api, libvirt_lxc_api)
73 56
74-ldflags = get_pkgconfig_data(["--libs-only-L"], "libvirt", False) 57 c_modules = []
75-cflags = get_pkgconfig_data(["--cflags"], "libvirt", False) 58 py_modules = []
76+libvirt_cflags = os.getenv("LIBVIRT_CFLAGS") 59- ldflags = get_pkgconfig_data(["--libs-only-L"], "libvirt", False)
77+if libvirt_cflags: 60- cflags = get_pkgconfig_data(["--cflags"], "libvirt", False)
78+ cflags = libvirt_cflags 61+ libvirt_cflags = os.getenv("LIBVIRT_CFLAGS")
79+else: 62+ if libvirt_cflags:
80+ cflags = get_pkgconfig_data(["--cflags"], "libvirt", False) 63+ cflags = libvirt_cflags
64+ else:
65+ cflags = get_pkgconfig_data(["--cflags"], "libvirt", False)
81+ 66+
82+libvirt_libs = os.getenv("LIBVIRT_LIBS") 67+ libvirt_libs = os.getenv("LIBVIRT_LIBS")
83+if libvirt_libs: 68+ if libvirt_libs:
84+ ldflags = libvirt_libs 69+ ldflags = libvirt_libs
85+else: 70+ else:
86+ ldflags = get_pkgconfig_data(["--libs-only-L"], "libvirt", False) 71+ ldflags = get_pkgconfig_data(["--libs-only-L"], "libvirt", False)
72
73 module = Extension('libvirtmod',
74 sources = ['libvirt-override.c', 'build/libvirt.c', 'typewrappers.c', 'libvirt-utils.c'],
75@@ -138,7 +151,7 @@
76 class my_build(build):
77
78 def run(self):
79- check_minimum_libvirt_version()
80+# check_minimum_libvirt_version()
81 apis = get_api_xml_files()
87 82
88 c_modules = [] 83 self.spawn([sys.executable, "generator.py", "libvirt", apis[0]])
89 py_modules = []
diff --git a/recipes-extended/libvirt/libvirt/runptest.patch b/recipes-extended/libvirt/libvirt/runptest.patch
index 0c019751..cdc0f65c 100644
--- a/recipes-extended/libvirt/libvirt/runptest.patch
+++ b/recipes-extended/libvirt/libvirt/runptest.patch
@@ -4,24 +4,25 @@ Change TESTS_ENVIRONMENT to allow running outside build dir.
4Signed-off-by: Mihaela Sendrea <mihaela.sendrea@enea.com> 4Signed-off-by: Mihaela Sendrea <mihaela.sendrea@enea.com>
5Upstream-status: Pending 5Upstream-status: Pending
6 6
7diff -uNr a/tests/Makefile.am b/tests/Makefile.am 7Index: libvirt-1.2.4/tests/Makefile.am
8--- a/tests/Makefile.am 2014-03-11 11:37:31.497605736 +0200 8===================================================================
9+++ b/tests/Makefile.am 2014-03-17 15:57:35.515268399 +0200 9--- libvirt-1.2.4.orig/tests/Makefile.am
10@@ -27,9 +27,11 @@ 10+++ libvirt-1.2.4/tests/Makefile.am
11@@ -31,9 +31,11 @@
11 -I$(top_srcdir)/src/conf \ 12 -I$(top_srcdir)/src/conf \
12 $(GETTEXT_CPPFLAGS) 13 $(GETTEXT_CPPFLAGS)
13 14
14+PTEST_DIR ?= /usr/lib/libvirt/ptest 15+PTEST_DIR ?= /usr/lib/libvirt/ptest
15+ 16+
16 AM_CFLAGS = \ 17 AM_CFLAGS = \
17- -Dabs_builddir="\"`pwd`\"" \ 18- -Dabs_builddir="\"$(abs_builddir)\"" \
18- -Dabs_srcdir="\"`cd '$(srcdir)'; pwd`\"" \ 19- -Dabs_srcdir="\"$(abs_srcdir)\"" \
19+ -Dabs_builddir="\"$(PTEST_DIR)/tests\"" \ 20+ -Dabs_builddir="\"$(PTEST_DIR)/tests\"" \
20+ -Dabs_srcdir="\"$(PTEST_DIR)/tests\"" \ 21+ -Dabs_srcdir="\"$(PTEST_DIR)/tests\"" \
21 $(LIBXML_CFLAGS) \ 22 $(LIBXML_CFLAGS) \
22 $(GNUTLS_CFLAGS) \ 23 $(GNUTLS_CFLAGS) \
23 $(SASL_CFLAGS) \ 24 $(SASL_CFLAGS) \
24@@ -41,7 +43,7 @@ 25@@ -48,7 +50,7 @@
25 26
26 if WITH_DRIVER_MODULES 27 if WITH_DRIVER_MODULES
27 INCLUDES += \ 28 INCLUDES += \
@@ -30,11 +31,11 @@ diff -uNr a/tests/Makefile.am b/tests/Makefile.am
30 endif WITH_DRIVER_MODULES 31 endif WITH_DRIVER_MODULES
31 32
32 PROBES_O = 33 PROBES_O =
33@@ -344,20 +346,19 @@ 34@@ -409,20 +411,19 @@
34 # Also, BSD sh doesn't like 'a=b b=$$a', so we can't use an 35 # Also, BSD sh doesn't like 'a=b b=$$a', so we can't use an
35 # intermediate shell variable, but must do all the expansion in make 36 # intermediate shell variable, but must do all the expansion in make
36 37
37-lv_abs_top_builddir=`cd '$(top_builddir)'; pwd` 38-lv_abs_top_builddir=$(shell cd '$(top_builddir)' && pwd)
38 path_add = $(subst :,$(PATH_SEPARATOR),\ 39 path_add = $(subst :,$(PATH_SEPARATOR),\
39- $(subst !,$(lv_abs_top_builddir)/,!daemon:!tools:!tests)) 40- $(subst !,$(lv_abs_top_builddir)/,!daemon:!tools:!tests))
40+ $(subst !,$(PTEST_DIR)/,!daemon:!tools:!tests)) 41+ $(subst !,$(PTEST_DIR)/,!daemon:!tools:!tests))
@@ -43,9 +44,9 @@ diff -uNr a/tests/Makefile.am b/tests/Makefile.am
43 TESTS_ENVIRONMENT = \ 44 TESTS_ENVIRONMENT = \
44- abs_top_builddir=$(lv_abs_top_builddir) \ 45- abs_top_builddir=$(lv_abs_top_builddir) \
45- abs_top_srcdir=`cd '$(top_srcdir)'; pwd` \ 46- abs_top_srcdir=`cd '$(top_srcdir)'; pwd` \
46- abs_builddir=`pwd` \ 47- abs_builddir=$(abs_builddir) \
47- abs_srcdir=`cd '$(srcdir)'; pwd` \ 48- abs_srcdir=$(abs_srcdir) \
48- CONFIG_HEADER="`cd '$(top_builddir)'; pwd`/config.h" \ 49- CONFIG_HEADER="$(lv_abs_top_builddir)/config.h" \
49+ abs_top_builddir="$(PTEST_DIR)" \ 50+ abs_top_builddir="$(PTEST_DIR)" \
50+ abs_top_srcdir="$(PTEST_DIR)" \ 51+ abs_top_srcdir="$(PTEST_DIR)" \
51+ abs_builddir="$(PTEST_DIR)/tests" \ 52+ abs_builddir="$(PTEST_DIR)/tests" \
@@ -58,8 +59,8 @@ diff -uNr a/tests/Makefile.am b/tests/Makefile.am
58 LIBVIRT_AUTOSTART=0 \ 59 LIBVIRT_AUTOSTART=0 \
59 LC_ALL=C \ 60 LC_ALL=C \
60 VIR_TEST_EXPENSIVE=$(VIR_TEST_EXPENSIVE) \ 61 VIR_TEST_EXPENSIVE=$(VIR_TEST_EXPENSIVE) \
61@@ -933,5 +934,51 @@ 62@@ -1137,5 +1138,51 @@
62 EXTRA_DIST += object-locking.ml 63 EXTRA_DIST += objectlocking.ml
63 endif ! WITH_CIL 64 endif ! WITH_CIL
64 65
65+buildtest-TESTS: $(TESTS) $(test_libraries) $(test_helpers) 66+buildtest-TESTS: $(TESTS) $(test_libraries) $(test_helpers)
@@ -109,4 +110,4 @@ diff -uNr a/tests/Makefile.am b/tests/Makefile.am
109+ sed -i -e 's|^\(.*\.log:\) \(.*EXEEXT.*\)|\1|g' $(DEST_DIR)/tests/Makefile 110+ sed -i -e 's|^\(.*\.log:\) \(.*EXEEXT.*\)|\1|g' $(DEST_DIR)/tests/Makefile
110+ 111+
111 CLEANFILES = *.cov *.gcov .libs/*.gcda .libs/*.gcno *.gcno *.gcda *.cmi *.cmx \ 112 CLEANFILES = *.cov *.gcov .libs/*.gcda .libs/*.gcno *.gcno *.gcda *.cmi *.cmx \
112 object-locking-files.txt 113 objectlocking-files.txt
diff --git a/recipes-extended/libvirt/libvirt_1.2.2.bb b/recipes-extended/libvirt/libvirt_1.2.4.bb
index 22ae2c7a..c2eea495 100644
--- a/recipes-extended/libvirt/libvirt_1.2.2.bb
+++ b/recipes-extended/libvirt/libvirt_1.2.4.bb
@@ -32,8 +32,8 @@ SRC_URI = "http://libvirt.org/sources/libvirt-${PV}.tar.gz;name=libvirt \
32 file://tests-allow-separated-src-and-build-dirs.patch \ 32 file://tests-allow-separated-src-and-build-dirs.patch \
33 " 33 "
34 34
35SRC_URI[libvirt.md5sum] = "592958ad1ddce7574d8cb0a31e635acd" 35SRC_URI[libvirt.md5sum] = "da7a9ca519df45a460659189fe0024e6"
36SRC_URI[libvirt.sha256sum] = "a48377e307c5c21b67e43db99af909a23c33aff8cbbaa3361fd389eb047cbbc3" 36SRC_URI[libvirt.sha256sum] = "e43ac5f6b2baeafcd01777be03a897e636f8d48c0cdfb4c4cbb80d45faa9e875"
37 37
38inherit autotools gettext update-rc.d pkgconfig ptest 38inherit autotools gettext update-rc.d pkgconfig ptest
39 39