summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-11-29 17:21:36 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-11-29 17:21:36 -0500
commit9a7aa013db5a13a82e9aa38ff0b1692ef4bf5478 (patch)
tree2afaaf374edf2e764415f51f156b871c8e6ef998 /recipes-extended
parentda0f1599ce3e001c809a2ddb9d0a1c75491dda94 (diff)
downloadmeta-virtualization-9a7aa013db5a13a82e9aa38ff0b1692ef4bf5478.tar.gz
xvisor: uprev to latest master and fix python reference
Bumping to the latest xvisor tip. We drop one patch that is now part of the upstream, and we add another to remove /usr/bin/python from scripts called during build, since it breaks the build on hosts without /usr/bin/python. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/xvisor/files/0001-EMULATORS-Allow-Xvisor-to-compile-with-gcc-10.patch55
-rw-r--r--recipes-extended/xvisor/files/0001-build-use-usr-bin-env-for-python-scripts.patch36
-rw-r--r--recipes-extended/xvisor/xvisor_git.bb4
3 files changed, 38 insertions, 57 deletions
diff --git a/recipes-extended/xvisor/files/0001-EMULATORS-Allow-Xvisor-to-compile-with-gcc-10.patch b/recipes-extended/xvisor/files/0001-EMULATORS-Allow-Xvisor-to-compile-with-gcc-10.patch
deleted file mode 100644
index 221a314c..00000000
--- a/recipes-extended/xvisor/files/0001-EMULATORS-Allow-Xvisor-to-compile-with-gcc-10.patch
+++ /dev/null
@@ -1,55 +0,0 @@
1From 417184cc41cfd33ae7b4c11c8396e0f47f43e2ba Mon Sep 17 00:00:00 2001
2From: Jean-Christophe Dubois <jcd@tribudubois.net>
3Date: Fri, 8 May 2020 15:17:36 +0200
4Subject: [PATCH] EMULATORS: Allow Xvisor to compile with gcc 10.
5
6With gcc 10 because some header files do not declare some variable
7definition as extern, the variable get duplicated in all files
8using it.
9
10This patch allow xvisor to compile with the latest gcc.
11
12Signed-off-by: Jean-Christophe Dubois <jcd@tribudubois.net>
13Reviewed-by: Anup Patel <anup@brainfault.org>
14---
15 drivers/mmc/core/core.h | 2 +-
16 emulators/display/drawfn.h | 10 +++++-----
17 2 files changed, 6 insertions(+), 6 deletions(-)
18
19diff --git a/drivers/mmc/core/core.h b/drivers/mmc/core/core.h
20index d75d135a..e2ca3141 100644
21--- a/drivers/mmc/core/core.h
22+++ b/drivers/mmc/core/core.h
23@@ -64,7 +64,7 @@ int mmc_go_idle(struct mmc_host *host);
24 * Note: Must be called with host->lock held.
25 */
26 extern struct vmm_bus sdio_bus_type;
27-struct vmm_device_type sdio_func_type;
28+extern struct vmm_device_type sdio_func_type;
29
30 int __sdio_attach(struct mmc_host *host);
31
32diff --git a/emulators/display/drawfn.h b/emulators/display/drawfn.h
33index f9163cff..385deaf6 100644
34--- a/emulators/display/drawfn.h
35+++ b/emulators/display/drawfn.h
36@@ -69,14 +69,14 @@ typedef void (*drawfn)(struct vmm_surface *,
37 DRAWFN_ORDER_MAX * \
38 DRAWFN_FORMAT_MAX)
39
40-drawfn drawfn_surface_fntable_8[DRAWFN_FNTABLE_SIZE];
41+extern drawfn drawfn_surface_fntable_8[DRAWFN_FNTABLE_SIZE];
42
43-drawfn drawfn_surface_fntable_15[DRAWFN_FNTABLE_SIZE];
44+extern drawfn drawfn_surface_fntable_15[DRAWFN_FNTABLE_SIZE];
45
46-drawfn drawfn_surface_fntable_16[DRAWFN_FNTABLE_SIZE];
47+extern drawfn drawfn_surface_fntable_16[DRAWFN_FNTABLE_SIZE];
48
49-drawfn drawfn_surface_fntable_24[DRAWFN_FNTABLE_SIZE];
50+extern drawfn drawfn_surface_fntable_24[DRAWFN_FNTABLE_SIZE];
51
52-drawfn drawfn_surface_fntable_32[DRAWFN_FNTABLE_SIZE];
53+extern drawfn drawfn_surface_fntable_32[DRAWFN_FNTABLE_SIZE];
54
55 #endif
diff --git a/recipes-extended/xvisor/files/0001-build-use-usr-bin-env-for-python-scripts.patch b/recipes-extended/xvisor/files/0001-build-use-usr-bin-env-for-python-scripts.patch
new file mode 100644
index 00000000..dfbb00b1
--- /dev/null
+++ b/recipes-extended/xvisor/files/0001-build-use-usr-bin-env-for-python-scripts.patch
@@ -0,0 +1,36 @@
1From eb351ca63a86f53cfb18987284a1445d543dfe56 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Mon, 29 Nov 2021 17:20:00 -0500
4Subject: [PATCH] build: use /usr/bin/env for python scripts
5
6Without this, we break on hosts without /usr/bin/python
7
8Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
9---
10 tools/scripts/d2c.py | 2 +-
11 tools/scripts/memimg.py | 2 +-
12 2 files changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/tools/scripts/d2c.py b/tools/scripts/d2c.py
15index b46a7bc4..0a6bce08 100755
16--- a/tools/scripts/d2c.py
17+++ b/tools/scripts/d2c.py
18@@ -1,4 +1,4 @@
19-#!/usr/bin/python
20+#!/usr/bin/env python3
21 #/**
22 # Copyright (c) 2013 Anup Patel.
23 # All rights reserved.
24diff --git a/tools/scripts/memimg.py b/tools/scripts/memimg.py
25index 423c9c33..ba2f06cb 100755
26--- a/tools/scripts/memimg.py
27+++ b/tools/scripts/memimg.py
28@@ -1,4 +1,4 @@
29-#!/usr/bin/python
30+#!/usr/bin/env python3
31 #/**
32 # Copyright (c) 2011 Anup Patel.
33 # All rights reserved.
34--
352.19.1
36
diff --git a/recipes-extended/xvisor/xvisor_git.bb b/recipes-extended/xvisor/xvisor_git.bb
index 749fec3d..4d2a719e 100644
--- a/recipes-extended/xvisor/xvisor_git.bb
+++ b/recipes-extended/xvisor/xvisor_git.bb
@@ -9,10 +9,10 @@ require xvisor-configs.inc
9inherit autotools-brokensep 9inherit autotools-brokensep
10 10
11# This version support the RISC-V v0.5.0 Hypervisor extensions 11# This version support the RISC-V v0.5.0 Hypervisor extensions
12SRCREV = "b3dac5b1f61f23f21dc59b3880897cff78f3b618" 12SRCREV = "6b23764a1439f9d08b2ed2f363da522460d8a22b"
13SRC_URI = "git://github.com/avpatel/xvisor-next.git;branch=master;protocol=https \ 13SRC_URI = "git://github.com/avpatel/xvisor-next.git;branch=master;protocol=https \
14 file://0001-TESTS-Don-t-specify-mabi-or-march-for-RISC-V.patch \ 14 file://0001-TESTS-Don-t-specify-mabi-or-march-for-RISC-V.patch \
15 file://0001-EMULATORS-Allow-Xvisor-to-compile-with-gcc-10.patch \ 15 file://0001-build-use-usr-bin-env-for-python-scripts.patch \
16" 16"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"