summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2023-08-28 16:38:56 +0200
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-08-29 02:08:15 +0000
commit8fbf94bc9a4e3043a45813aee62a469cac6bc2f5 (patch)
tree67a92ca323db359d2ed82e4774db6f8b69fa72a5 /recipes-extended
parent4c21ae49dbe05923309892d2fac63d166fd7d508 (diff)
downloadmeta-virtualization-8fbf94bc9a4e3043a45813aee62a469cac6bc2f5.tar.gz
cloud-init: bump SRCREV to fix update to 23.2.2
* the update from commit 0f1601d98f2c926a109b7beb7df21a5dfe6188d9 Author: Bruce Ashfield <bruce.ashfield@gmail.com> Date: Thu Aug 3 20:15:04 2023 +0000 Subject: cloud-init: update to 23.2.2 Bumping cloud-init to version 23.2.2, which comprises the following commits: e65a715d Release 23.2.2 was missing the SRCREV update, so it was still 23.1: cloud-init/v23.2.2+git/git $ git describe --tags 23.1-52-ge02c46079 fix that by using the right one of the 23.2.2 tag: cloud-init/v23.2.2+git/git $ git show-ref -d 23.2.2 293c6546f038ef4da98910dfeb8d0ade65707952 refs/tags/23.2.2 e65a715d524456285e07ac521457424713ea4aa5 refs/tags/23.2.2^{} * this fix also allows up to drop the patch backported from 23.2 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/cloud-init/cloud-init/0002-setup.py-use-pkg-config-for-udev-rules-path-2137.patch50
-rw-r--r--recipes-extended/cloud-init/cloud-init_git.bb3
2 files changed, 1 insertions, 52 deletions
diff --git a/recipes-extended/cloud-init/cloud-init/0002-setup.py-use-pkg-config-for-udev-rules-path-2137.patch b/recipes-extended/cloud-init/cloud-init/0002-setup.py-use-pkg-config-for-udev-rules-path-2137.patch
deleted file mode 100644
index 9f3760c4..00000000
--- a/recipes-extended/cloud-init/cloud-init/0002-setup.py-use-pkg-config-for-udev-rules-path-2137.patch
+++ /dev/null
@@ -1,50 +0,0 @@
1From 57752970ebea017820343aadf11b65c537bef336 Mon Sep 17 00:00:00 2001
2From: dankm <dan.mcgregor@usask.ca>
3Date: Fri, 28 Apr 2023 15:10:34 -0600
4Subject: [PATCH] setup.py: use pkg-config for udev/rules path (#2137)
5
6Distributions other than RHEL also use /usr/lib/udev for the rules
7path. Instead of hardcoding the udev rules path for RedHat, check
8pkg-config for the proper location.
9
10Upstream-Status: Backport [23.2 https://github.com/canonical/cloud-init/commit/5abf5f5f2cf93c57ac74220251d2a2acce5f7099]
11Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
12---
13 setup.py | 14 ++++++++------
14 1 file changed, 8 insertions(+), 6 deletions(-)
15
16diff --git a/setup.py b/setup.py
17index a6dbc5c23..66e618d3a 100644
18--- a/setup.py
19+++ b/setup.py
20@@ -46,7 +46,10 @@ def pkg_config_read(library, var):
21 "systemdsystemconfdir": "/etc/systemd/system",
22 "systemdsystemunitdir": "/lib/systemd/system",
23 "systemdsystemgeneratordir": "/lib/systemd/system-generators",
24- }
25+ },
26+ "udev": {
27+ "udevdir": "/lib/udev",
28+ },
29 }
30 cmd = ["pkg-config", "--variable=%s" % var, library]
31 try:
32@@ -309,14 +312,13 @@ data_files = [
33 ),
34 ]
35 if not platform.system().endswith("BSD"):
36-
37- RULES_PATH = LIB
38- if os.path.isfile("/etc/redhat-release"):
39- RULES_PATH = "/usr/lib"
40+ RULES_PATH = pkg_config_read("udev", "udevdir")
41+ if not in_virtualenv():
42+ RULES_PATH = "/" + RULES_PATH
43
44 data_files.extend(
45 [
46- (RULES_PATH + "/udev/rules.d", [f for f in glob("udev/*.rules")]),
47+ (RULES_PATH + "/rules.d", [f for f in glob("udev/*.rules")]),
48 (
49 ETC + "/systemd/system/sshd-keygen@.service.d/",
50 ["systemd/disable-sshd-keygen-if-cloud-init-active.conf"],
diff --git a/recipes-extended/cloud-init/cloud-init_git.bb b/recipes-extended/cloud-init/cloud-init_git.bb
index b5c2d711..9d84f47e 100644
--- a/recipes-extended/cloud-init/cloud-init_git.bb
+++ b/recipes-extended/cloud-init/cloud-init_git.bb
@@ -7,11 +7,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c6dd79b6ec2130a3364f6fa9d6380408 \
7 file://LICENSE-Apache2.0;md5=3b83ef96387f14655fc854ddc3c6bd57 \ 7 file://LICENSE-Apache2.0;md5=3b83ef96387f14655fc854ddc3c6bd57 \
8" 8"
9 9
10SRCREV = "e02c4607923af64311c70ae9a06d6794355e9a61" 10SRCREV = "293c6546f038ef4da98910dfeb8d0ade65707952"
11SRC_URI = "git://github.com/canonical/cloud-init;branch=23.2.x;protocol=https \ 11SRC_URI = "git://github.com/canonical/cloud-init;branch=23.2.x;protocol=https \
12 file://cloud-init-source-local-lsb-functions.patch \ 12 file://cloud-init-source-local-lsb-functions.patch \
13 file://0001-setup.py-check-for-install-anywhere-in-args.patch \ 13 file://0001-setup.py-check-for-install-anywhere-in-args.patch \
14 file://0002-setup.py-use-pkg-config-for-udev-rules-path-2137.patch \
15" 14"
16 15
17PV = "v23.2.2+git" 16PV = "v23.2.2+git"