summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@windriver.com>2021-05-28 15:50:48 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-06-01 08:52:18 -0400
commit8ded083436c6c884d53d99daa23279ffa383e336 (patch)
treedefe96e4c11bd5250198b9f41723e79e5b205e79 /recipes-extended
parent638d31de1384f27bde7f0b8c55c1564f2cbddba5 (diff)
downloadmeta-virtualization-8ded083436c6c884d53d99daa23279ffa383e336.tar.gz
ceph: Fix compile error with snappy
snappy changed a data type in the last update, this is a known issue in ceph. Signed-off-by: Saul Wold <saul.wold@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/ceph/ceph/0001-SnappyCompressor.h-fix-snappy-compiler-error.patch30
-rw-r--r--recipes-extended/ceph/ceph_15.2.12.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes-extended/ceph/ceph/0001-SnappyCompressor.h-fix-snappy-compiler-error.patch b/recipes-extended/ceph/ceph/0001-SnappyCompressor.h-fix-snappy-compiler-error.patch
new file mode 100644
index 00000000..2ebd32d1
--- /dev/null
+++ b/recipes-extended/ceph/ceph/0001-SnappyCompressor.h-fix-snappy-compiler-error.patch
@@ -0,0 +1,30 @@
1From 85bde55627cfbb35d8b4735dec32bf33fa30079f Mon Sep 17 00:00:00 2001
2From: Saul Wold <saul.wold@windriver.com>
3Date: Fri, 28 May 2021 10:16:07 -0700
4Subject: [PATCH] SnappyCompressor.h: fix snappy compiler error
5
6snappy quietly changed public type
7
8Known issue in ceph: https://tracker.ceph.com/issues/50934
9
10Upstream-Status: Pending
11
12Signed-off-by: Saul Wold <saul.wold@windriver.com>
13
14---
15 src/compressor/snappy/SnappyCompressor.h | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/src/compressor/snappy/SnappyCompressor.h b/src/compressor/snappy/SnappyCompressor.h
19index 0cfb819c..2fbe35b7 100644
20--- a/src/compressor/snappy/SnappyCompressor.h
21+++ b/src/compressor/snappy/SnappyCompressor.h
22@@ -96,7 +96,7 @@ class SnappyCompressor : public Compressor {
23 if (qat_enabled)
24 return qat_accel.decompress(p, compressed_len, dst);
25 #endif
26- snappy::uint32 res_len = 0;
27+ uint32_t res_len = 0;
28 BufferlistSource source_1(p, compressed_len);
29 if (!snappy::GetUncompressedLength(&source_1, &res_len)) {
30 return -1;
diff --git a/recipes-extended/ceph/ceph_15.2.12.bb b/recipes-extended/ceph/ceph_15.2.12.bb
index 9ba72b40..3c2e1c62 100644
--- a/recipes-extended/ceph/ceph_15.2.12.bb
+++ b/recipes-extended/ceph/ceph_15.2.12.bb
@@ -14,6 +14,7 @@ SRC_URI = "http://download.ceph.com/tarballs/ceph-${PV}.tar.gz \
14 file://ceph.conf \ 14 file://ceph.conf \
15 file://0001-add-missing-include-for-atomic-bool.patch \ 15 file://0001-add-missing-include-for-atomic-bool.patch \
16 file://0001-cmake-add-support-for-python3.9.patch \ 16 file://0001-cmake-add-support-for-python3.9.patch \
17 file://0001-SnappyCompressor.h-fix-snappy-compiler-error.patch \
17" 18"
18 19
19SRC_URI[sha1sum] = "9c76b298e1e659b9c5501003ac77fb28aab7823d" 20SRC_URI[sha1sum] = "9c76b298e1e659b9c5501003ac77fb28aab7823d"