summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2021-04-16 11:41:36 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-04-18 20:19:28 -0400
commit7f18136e1f2d7385ebc7e77145a925adfc8b4f1c (patch)
tree53d9f768816622a7e5cee1971eaa6ab6309b119f /recipes-extended
parent5f51e806b8f56c30eb160c21d241c73268a4dedf (diff)
downloadmeta-virtualization-7f18136e1f2d7385ebc7e77145a925adfc8b4f1c.tar.gz
xtf-image: add a new image for the Xen Test Framework
Testing the Xen hypervisor, with the qemux86-64 MACHINE: runqemu xtf-image nographic slirp (login as root) cd /usr/libexec/xtf ./xtf-runner --list pv # run an example test: ./xtf-runner test-pv64-livepatch-priv-check Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com> Reviewed-by: Bertrand Marquis <bertrand.marquis@arm.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/images/xtf-image.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-extended/images/xtf-image.bb b/recipes-extended/images/xtf-image.bb
new file mode 100644
index 00000000..3f9af259
--- /dev/null
+++ b/recipes-extended/images/xtf-image.bb
@@ -0,0 +1,24 @@
1require recipes-extended/images/xen-image-minimal.bb
2DESCRIPTION = "A minimal Xen Test Framework (XTF) image for testing the Xen hypervisor"
3
4# To run XTF tests with an image built for the qemux86-64 MACHINE:
5#
6# runqemu xtf-image nographic slirp
7# (login as root)
8# # xtf-runner expects to be run from the top of the tests directory:
9# cd /usr/libexec/xtf
10# # list the tests available for PV guest types:
11# ./xtf-runner --list pv
12# # run an example test:
13# ./xtf-runner test-pv64-livepatch-priv-check
14
15IMAGE_NAME="xtf"
16
17IMAGE_INSTALL_append = " xtf"
18
19QB_DEFAULT_FSTYPE = "wic"
20
21# Set the dom0 memory level lower than that assigned to qemu so that Xen has
22# some available memory for allocating to the XTF microkernel guests to run:
23QB_MEM = "-m 400"
24SYSLINUX_XEN_ARGS_append = " dom0_mem=256M"