summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-04-23 11:38:43 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-04-26 11:17:27 -0400
commit6c991dab48d6bfd930156f754220ec57a7d9e9b5 (patch)
tree9bf351ec38458e9ace9ea51518b10f800021a31f /recipes-extended
parent144d1ae8973e8c67709d7b544dc53b80bf924754 (diff)
downloadmeta-virtualization-6c991dab48d6bfd930156f754220ec57a7d9e9b5.tar.gz
xen-python2: drop recipe
python2 is no longer supported, and we are breaking yocto layer compatibilty by keeping this recipe around (since there is no provider of 'python'). This hasn't been updated in over a year, so it is time to retire it. If it is required, we can bring it back in some other manner. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/xen/xen-python2.bb71
1 files changed, 0 insertions, 71 deletions
diff --git a/recipes-extended/xen/xen-python2.bb b/recipes-extended/xen/xen-python2.bb
deleted file mode 100644
index ad3c1fd6..00000000
--- a/recipes-extended/xen/xen-python2.bb
+++ /dev/null
@@ -1,71 +0,0 @@
1SUMMARY = "Xen hypervisor tools written in python 2"
2DESCRIPTION = "Unported utility scripts for the Xen hypervisor"
3HOMEPAGE = "http://xen.org"
4LICENSE = "GPLv2"
5SECTION = "console/tools"
6
7SRCREV ?= "a5fcafbfbee55261853fba07149c1c795f2baf58"
8
9# The same restriction as xen-tools.inc, because of the dependency on xen-tools-xentrace from xen-tools-xentrace-format
10COMPATIBLE_HOST = 'i686-.*-linux|(x86_64.*).*-linux|aarch64.*-linux|arm-.*-linux-gnueabi'
11
12XEN_REL ?= "4.12"
13XEN_BRANCH ?= "stable-4.12"
14
15SRC_URI = "git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH}"
16
17LIC_FILES_CHKSUM ?= "file://COPYING;md5=bbb4b1bdc2c3b6743da3c39d03249095"
18
19PV = "${XEN_REL}+git${SRCPV}"
20
21S = "${WORKDIR}/git"
22
23# Packages in this recipe do not use ${PN} to allow for simpler
24# movement of the package back into the xen-tools recipe if/when
25# the scripts are ported to python 3.
26
27RDEPENDS_xen-tools-xencov-split ="python"
28RDEPENDS_xen-tools-xencons = "python"
29RDEPENDS_xen-tools-xenpvnetboot = "python"
30RDEPENDS_xen-tools-xentrace-format = "python"
31
32RRECOMMENDS_xen-tools-xencov-trace = "xen-tools-xencov"
33RRECOMMENDS_xen-tools-xentrace-format = "xen-tools-xentrace"
34
35PACKAGES = " \
36 xen-tools-xencons \
37 xen-tools-xencov-split \
38 xen-tools-xenpvnetboot \
39 xen-tools-xentrace-format \
40 "
41
42FILES_xen-tools-xencons = " \
43 ${bindir}/xencons \
44 "
45
46FILES_xen-tools-xencov-split = " \
47 ${bindir}/xencov_split \
48 "
49
50FILES_xen-tools-xenpvnetboot = " \
51 ${libdir}/xen/bin/xenpvnetboot \
52 "
53
54FILES_xen-tools-xentrace-format = " \
55 ${bindir}/xentrace_format \
56 "
57
58do_configure[noexec] = "1"
59do_compile[noexec] = "1"
60
61do_install() {
62 install -d ${D}${bindir}
63 install -m 0755 ${S}/tools/xentrace/xentrace_format \
64 ${D}${bindir}/xentrace_format
65 install -m 0755 ${S}/tools/misc/xencons ${D}${bindir}/xencons
66 install -m 0755 ${S}/tools/misc/xencov_split ${D}${bindir}/xencov_split
67
68 install -d ${D}${libdir}/xen/bin
69 install -m 0755 ${S}/tools/misc/xenpvnetboot \
70 ${D}${libdir}/xen/bin/xenpvnetboot
71}